<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '959847655721995117',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>'Text Bomb' Is Latest Apple Bug - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="An anonymous reader quotes a report from the BBC: A new &#34;text bomb&#34; affecting Apple's iPhone and Mac computers has been discovered. Abraham Masri, a software developer, tweeted about the flaw which typically causes an iPhone to crash and in some cases restart. Simply sending a message containing a l...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="it.slashdot.org">
		<meta property="og:url" content="https://it.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug">
	    
		<meta property="og:title" content="'Text Bomb' Is Latest Apple Bug - Slashdot">
		<meta property="og:description" content="An anonymous reader quotes a report from the BBC: A new &#34;text bomb&#34; affecting Apple's iPhone and Mac computers has been discovered. Abraham Masri, a software developer, tweeted about the flaw which typically causes an iPhone to crash and in some cases restart. Simply sending a message containing a l...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/security_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://it.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/336271" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?38debda35a274e8c" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?38debda35a274e8c" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?38debda35a274e8c" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?38debda35a274e8c">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?38debda35a274e8c"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?38debda35a274e8c" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//it.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotIt" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //it.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Catch up on stories from the past week (and beyond) at the <a href="//slashdot.org/archive.pl">Slashdot story archive</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <a href="https://slashdot.org/newsletter">Sign up for the Slashdot Daily Newsletter!</a> <strong>DEAL:</strong> For $25 - <a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-96725977" data-fhid="96725977" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">96725977</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-96725977">
			<a href="//it.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		
	
		
		
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=bug" onclick="return addfhfilter('bug');">
			
				<img src="//a.fsdn.com/sd/topics/bug_64.png" width="64" height="64" alt="Bug" title="Bug">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=communications" onclick="return addfhfilter('communications');">
			
				<img src="//a.fsdn.com/sd/topics/communications_64.png" width="64" height="64" alt="Communications" title="Communications">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=mac" onclick="return addfhfilter('mac');">
			
				<img src="//a.fsdn.com/sd/topics/mac_64.png" width="64" height="64" alt="Desktops (Apple)" title="Desktops (Apple)">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=iphone" onclick="return addfhfilter('iphone');">
			
				<img src="//a.fsdn.com/sd/topics/iphone_64.png" width="64" height="64" alt="Iphone" title="Iphone">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=os" onclick="return addfhfilter('os');">
			
				<img src="//a.fsdn.com/sd/topics/os_64.png" width="64" height="64" alt="Operating Systems" title="Operating Systems">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=software" onclick="return addfhfilter('software');">
			
				<img src="//a.fsdn.com/sd/topics/software_64.png" width="64" height="64" alt="Software" title="Software">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=apple" onclick="return addfhfilter('apple');">
			
				<img src="//a.fsdn.com/sd/topics/apple_64.png" width="64" height="64" alt="Apple" title="Apple">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-96725977" class="story-title"> <a   href="//it.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug">'Text Bomb' Is Latest Apple Bug</a> <span class=" no extlnk"><a class="story-sourcelnk" href="http://www.bbc.com/news/technology-42728336"  title="External link - http://www.bbc.com/news/technology-42728336" target="_blank"> (bbc.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-96725977" >46</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//it.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug#comments" title="">46</a></span>
		
	</h2>
	<div class="details" id="details-96725977">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  <a href="https://twitter.com/BeauHD" rel="nofollow">BeauHD</a>
			
		
		

		
		
		<time id="fhtime-96725977" datetime="on Thursday January 18, 2018 @05:03PM">on Thursday January 18, 2018 @05:03PM</time>
		
		
			 from the <span class="dept-text">headache-inducing</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-96725977">
	
		
	

	
		
		<div id="text-96725977" class="p">
			
		 	
				An anonymous reader quotes a report from the BBC: <i>A new "text bomb" affecting Apple's iPhone and Mac computers has been discovered. Abraham Masri, a software developer, tweeted about the flaw which typically <a href="http://www.bbc.com/news/technology-42728336">causes an iPhone to crash and in some cases restart</a>. Simply sending a message containing a link which pointed to Mr Masri's code on programming site GitHub would be enough to activate the bug -- even if the recipient did not click the link itself. Mr Masri said he "always reports bugs" before releasing them. Apple has not yet commented on the issue. On a Mac, the bug reportedly makes the Safari browser crash, and causes other slowdowns. Security expert Graham Cluley <a href="https://www.grahamcluley.com/chaios-bug-crash-ios-macos-messages/">wrote on his blog</a> that the bug does not present anything to be particularly worried about -- it's merely very annoying. After the link did the rounds on social media, Mr Masri removed the code from GitHub, therefore disabling the "attack" unless someone was to replicate the code elsewhere.</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-96725977" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://it.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug"
								  data-janrain-title="'Text Bomb' Is Latest Apple Bug"
								  data-janrain-message="'Text Bomb' Is Latest Apple Bug @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-96725977" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/apple" target="_blank">apple</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/bug" target="_blank">bug</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/iphone" target="_blank">iphone</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//yro.slashdot.org/story/18/01/18/1925225/bitcoins-fluctuations-are-too-much-for-even-ransomware-cybercriminals?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>You may like to read:</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//tech.slashdot.org/story/18/01/18/2054205/wine-30-released?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//yro.slashdot.org/story/18/01/18/1925225/bitcoins-fluctuations-are-too-much-for-even-ransomware-cybercriminals?sdsrc=prev">Bitcoin's Fluctuations Are Too Much For Even Ransomware Cybercriminals </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
									
									
									
									

																				<h2><a href="//it.slashdot.org/story/17/08/06/1836220/google-engineers-leaked-gender-diversity-essay-draws-massive-response?sdsrc=popbyskid">Google Engineer's Leaked 'Gender Diversity' Essay Draws Massive Response</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/08/18/1626219/developer-accidentally-deletes-three-month-of-work-with-visual-studio-code?sdsrc=popbyskid">Developer Accidentally Deletes Three-Month of Work With Visual Studio Code</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/05/20/0519258/the-working-dead-which-it-jobs-are-bound-for-extinction?sdsrc=popbyskid">The Working Dead: Which IT Jobs Are Bound For Extinction?</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/03/25/1729223/after-healthcare-defeat-can-the-trump-administration-fix-americas-h-1b-visa-program?sdsrc=popbyskid">After Healthcare Defeat, Can The Trump Administration Fix America's H-1B Visa Program?</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/03/16/202251/20000-worldclass-university-lectures-made-illegal-so-we-irrevocably-mirrored-them?sdsrc=popbyskid">20,000 Worldclass University Lectures Made Illegal, So We Irrevocably Mirrored Them</a><br></h2>
									
								
								
									<h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//it.slashdot.org/submission/7818087/text-bomb-is-latest-apple-bug?sdsrc=rel" href="#">Submission: 'Text Bomb' Is Latest Apple Bug</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//tech.slashdot.org/story/18/01/18/2054205/wine-30-released?sdsrc=next">Wine 3.0 Released</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug" title="Back to Article - 'Text Bomb' Is Latest Apple Bug">'Text Bomb' Is Latest Apple Bug</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//it.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - 'Text Bomb' Is Latest Apple Bug" href="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug">'Text Bomb' Is Latest Apple Bug</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//it.slashdot.org/search.pl?op=comments&amp;sid=11630975" class="btn">Search <span class="totalcommentcnt">46</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//it.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//it.slashdot.org/comments.pl?sid=11630975">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//it.slashdot.org/search.pl?op=comments&amp;sid=11630975" class="ui-icon search_comments">Search <span class="totalcommentcnt">46</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//it.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/18/218245/text-bomb-is-latest-apple-bug/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?38debda35a274e8c" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_55956091" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956091" class="commentstatus"></div>
<div id="comment_55956091" class="cw">
</div>

<div id="replyto_55956091"></div>

<ul id="group_55956091">
	<li id="hiddens_55956091" class="hide"></li>
</ul>

</li><li id="tree_55956093" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956093" class="commentstatus"></div>
<div id="comment_55956093" class="cw">
	<div id="comment_top_55956093" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956093" name="comment_link_55956093" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956093" onclick="return D2.setFocusComment(55956093)" >Where's the video?</a>


		 	<span id="comment_score_55956093" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956093); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bogaboga">bogaboga</a>  <span class="uid"><a href="//slashdot.org/~bogaboga">( 793279 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956093"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956093"><p><div class="quote"><p> causes an iPhone to crash and in some cases restart. Simply sending a message containing a link which pointed to Mr Masri's code on programming site GitHub would be enough to activate the bug -- even if the recipient did not click the link itself. Mr Masri said he "always reports bugs" before releasing them.</p> </div><p>I usually love seeing such bugs in action. Anyone can point us to the video?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956093">

</div>
</div>

<div id="replyto_55956093"></div>

<ul id="group_55956093">
	<li id="hiddens_55956093" class="hide"></li>
</ul>

<ul id="commtree_55956093"><li id="tree_55956163" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956163" class="commentstatus"></div>
<div id="comment_55956163" class="cw">
	<div id="comment_top_55956163" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956163" name="comment_link_55956163" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956163" onclick="return D2.setFocusComment(55956163)" >Re:</a>


		 	<span id="comment_score_55956163" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956163); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~FFOMelchior">FFOMelchior</a>  <span class="uid"><a href="//slashdot.org/~FFOMelchior">( 979131 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956163"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956163">Hopefully Computerphile does a vid on it.  They did a great one on Effective Power: <a href="https://www.youtube.com/watch?v=hJLMSllzoLA" title="youtube.com">https://www.youtube.com/watch?...</a> [youtube.com]</div>
	</div>

	<div class="commentSub" id="comment_sub_55956163">

</div>
</div>

<div id="replyto_55956163"></div>

<ul id="group_55956163">
	<li id="hiddens_55956163" class="hide"></li>
</ul>

</li><li id="tree_55956185" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956185" class="commentstatus"></div>
<div id="comment_55956185" class="cw">
</div>

<div id="replyto_55956185"></div>

<ul id="group_55956185">
	<li id="hiddens_55956185" class="hide"></li>
</ul>

<ul id="commtree_55956185"><li id="tree_55956475" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956475" class="commentstatus"></div>
<div id="comment_55956475" class="cw">
	<div id="comment_top_55956475" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956475" name="comment_link_55956475" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956475" onclick="return D2.setFocusComment(55956475)" >Re:</a>


		 	<span id="comment_score_55956475" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956475); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sexconker">sexconker</a>  <span class="uid"><a href="//slashdot.org/~sexconker">( 1179573 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956475"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956475"><p>Bump it up to coffee stirrer the next time your post this.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956475">

</div>
</div>

<div id="replyto_55956475"></div>

<ul id="group_55956475">
	<li id="hiddens_55956475" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55956093"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956093">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956113" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956113" class="commentstatus"></div>
<div id="comment_55956113" class="cw">
</div>

<div id="replyto_55956113"></div>

<ul id="group_55956113">
	<li id="hiddens_55956113" class="hide"></li>
</ul>

<ul id="commtree_55956113"><li id="tree_55956269" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956269" class="commentstatus"></div>
<div id="comment_55956269" class="cw">
	<div id="comment_top_55956269" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956269" name="comment_link_55956269" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956269" onclick="return D2.setFocusComment(55956269)" >Re:</a>


		 	<span id="comment_score_55956269" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956269); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Narcocide">Narcocide</a>  <span class="uid"><a href="//slashdot.org/~Narcocide">( 102829 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956269"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956269"><p>This seems underrated to me.  Maybe ditching the CEO is going a bit too far, but they definitely need to get serious about software QA.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956269">

</div>
</div>

<div id="replyto_55956269"></div>

<ul id="group_55956269">
	<li id="hiddens_55956269" class="hide"></li>
</ul>

<ul id="commtree_55956269"><li id="tree_55956669" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956669" class="commentstatus"></div>
<div id="comment_55956669" class="cw">
	<div id="comment_top_55956669" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956669" name="comment_link_55956669" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956669" onclick="return D2.setFocusComment(55956669)" >Re:</a>


		 	<span id="comment_score_55956669" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956669); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hal_Porter">Hal_Porter</a>  <span class="uid"><a href="//slashdot.org/~Hal_Porter">( 817932 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956669"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956669"><p>The free market demands a blood sacrifice in order for Apple to have <a href="https://www.youtube.com/watch?v=bWX37Jj2eF4" title="youtube.com">expiation</a> [youtube.com]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956669">

</div>
</div>

<div id="replyto_55956669"></div>

<ul id="group_55956669">
	<li id="hiddens_55956669" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55956333" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956333" class="commentstatus"></div>
<div id="comment_55956333" class="cw">
</div>

<div id="replyto_55956333"></div>

<ul id="group_55956333">
	<li id="hiddens_55956333" class="hide"></li>
</ul>

</li><li id="tree_55956615" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956615" class="commentstatus"></div>
<div id="comment_55956615" class="cw">
</div>

<div id="replyto_55956615"></div>

<ul id="group_55956615">
	<li id="hiddens_55956615" class="hide"></li>
</ul>

<ul id="commtree_55956615"><li id="tree_55957005" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55957005" class="commentstatus"></div>
<div id="comment_55957005" class="cw">
</div>

<div id="replyto_55957005"></div>

<ul id="group_55957005">
	<li id="hiddens_55957005" class="hide"></li>
</ul>

<ul id="commtree_55957005"><li id="tree_55958387" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55958387" class="commentstatus"></div>
<div id="comment_55958387" class="cw">
</div>

<div id="replyto_55958387"></div>

<ul id="group_55958387">
	<li id="hiddens_55958387" class="hide"></li>
</ul>

</li><li id="hidestring_55957005"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55957005">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55956615"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956615">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55957471" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55957471" class="commentstatus"></div>
<div id="comment_55957471" class="cw">
	<div id="comment_top_55957471" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55957471" name="comment_link_55957471" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55957471" onclick="return D2.setFocusComment(55957471)" >Re:</a>


		 	<span id="comment_score_55957471" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55957471); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucm">lucm</a>  <span class="uid"><a href="//slashdot.org/~lucm">( 889690 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55957471"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55957471"><p><div class="quote"><p>once I don't need it for my iPhone anymore, that will be it, and I will unApplify my life.  I'll probably get a dumb-phone, and go back to the days when I navigated for myself, etc., and not rely on the increasingly unreliable kludgey crap coming from Apple nowadays.</p></div><p>You don't need to switch to a dumb-phone to be free of Apple junkware. Do yourself a favor, try a Samsung S8 and discover what a great experience it can be to use a truly high-end smartphone, with a gorgeous screen, conveniently expandable storage and a headphone jack. The best part is that you can achieve that without bending over for another Big Brother, you can use excellent open-source software from F-Droid.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55957471">

</div>
</div>

<div id="replyto_55957471"></div>

<ul id="group_55957471">
	<li id="hiddens_55957471" class="hide"></li>
</ul>

</li><li id="hidestring_55956113"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956113">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956121" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956121" class="commentstatus"></div>
<div id="comment_55956121" class="cw">
</div>

<div id="replyto_55956121"></div>

<ul id="group_55956121">
	<li id="hiddens_55956121" class="hide"></li>
</ul>

<ul id="commtree_55956121"><li id="tree_55956429" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956429" class="commentstatus"></div>
<div id="comment_55956429" class="cw">
</div>

<div id="replyto_55956429"></div>

<ul id="group_55956429">
	<li id="hiddens_55956429" class="hide"></li>
</ul>

</li><li id="hidestring_55956121"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956121">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956123" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956123" class="commentstatus"></div>
<div id="comment_55956123" class="cw">
	<div id="comment_top_55956123" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956123" name="comment_link_55956123" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956123" onclick="return D2.setFocusComment(55956123)" >Text?</a>


		 	<span id="comment_score_55956123" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956123); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956123"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956123"><p>Link?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956123">

</div>
</div>

<div id="replyto_55956123"></div>

<ul id="group_55956123">
	<li id="hiddens_55956123" class="hide"></li>
</ul>

</li><li id="tree_55956127" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956127" class="commentstatus"></div>
<div id="comment_55956127" class="cw">
</div>

<div id="replyto_55956127"></div>

<ul id="group_55956127">
	<li id="hiddens_55956127" class="hide"></li>
</ul>

<ul id="commtree_55956127"><li id="tree_55956423" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956423" class="commentstatus"></div>
<div id="comment_55956423" class="cw">
</div>

<div id="replyto_55956423"></div>

<ul id="group_55956423">
	<li id="hiddens_55956423" class="hide"></li>
</ul>

<ul id="commtree_55956423"><li id="tree_55957419" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55957419" class="commentstatus"></div>
<div id="comment_55957419" class="cw">
	<div id="comment_top_55957419" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55957419" name="comment_link_55957419" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55957419" onclick="return D2.setFocusComment(55957419)" >Re:</a>


		 	<span id="comment_score_55957419" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55957419); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucm">lucm</a>  <span class="uid"><a href="//slashdot.org/~lucm">( 889690 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55957419"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55957419"><p>There's nothing wrong with being new and nothing wrong with bitching about old news. There is however something wrong with telling people to go away.</p><p>Also 4chan is not a "shitsite". The internet is a beautiful mosaic and 4chan is a colorful part of it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55957419">

</div>
</div>

<div id="replyto_55957419"></div>

<ul id="group_55957419">
	<li id="hiddens_55957419" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55956127"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956127">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956141" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956141" class="commentstatus"></div>
<div id="comment_55956141" class="cw">
</div>

<div id="replyto_55956141"></div>

<ul id="group_55956141">
	<li id="hiddens_55956141" class="hide"></li>
</ul>

<ul id="commtree_55956141"><li id="tree_55956241" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956241" class="commentstatus"></div>
<div id="comment_55956241" class="cw">
	<div id="comment_top_55956241" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956241" name="comment_link_55956241" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956241" onclick="return D2.setFocusComment(55956241)" >Re:</a>


		 	<span id="comment_score_55956241" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956241); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Anubis+IV">Anubis IV</a>  <span class="uid"><a href="//slashdot.org/~Anubis+IV">( 1279820 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956241"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956241"><p>The Messages app's default behavior has it load a preview of the linked-to content, hence why the linked-to content can&mdash;and in this case did&mdash;cause problems.</p><p>Anyway, previews can be toggled on or off in settings, it's possible to delete the offending messages via settings if Messages becomes inaccessible, and messages from unknown senders are by default shunted into a separate section in Messages from those sent by contacts, so the issue was always going to be minimal in scope and impact. Even so,<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956241">

</div>
</div>

<div id="replyto_55956241"></div>

<ul id="group_55956241">
	<li id="hiddens_55956241" class="hide"></li>
</ul>

<ul id="commtree_55956241"><li id="tree_55957377" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55957377" class="commentstatus"></div>
<div id="comment_55957377" class="cw">
	<div id="comment_top_55957377" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55957377" name="comment_link_55957377" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55957377" onclick="return D2.setFocusComment(55957377)" >Re:</a>


		 	<span id="comment_score_55957377" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55957377); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucm">lucm</a>  <span class="uid"><a href="//slashdot.org/~lucm">( 889690 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55957377"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55957377"><p><div class="quote"><p>Even so, it's nice to see that they were able to accomplish some initial mitigation prior to the full fix coming next week.</p></div><p>It's not "nice", it's a bare minimum.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55957377">

</div>
</div>

<div id="replyto_55957377"></div>

<ul id="group_55957377">
	<li id="hiddens_55957377" class="hide"></li>
</ul>

</li><li id="tree_55958559" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55958559" class="commentstatus"></div>
<div id="comment_55958559" class="cw">
	<div id="comment_top_55958559" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55958559" name="comment_link_55958559" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55958559" onclick="return D2.setFocusComment(55958559)" >Re:</a>


		 	<span id="comment_score_55958559" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55958559); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Jeremi">Jeremi</a>  <span class="uid"><a href="//slashdot.org/~Jeremi">( 14640 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55958559"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55958559"><p>The bug itself is understandable -- the space of all possible Unicode text strings is infinite, and the behavior of a universal text renderer is more subtle than most programmers would imagine.  I think most programmers would be susceptible to not handling every use case in every language correctly.</p><p>What's disconcerting is that the fault appears to crash the entire OS, not just the one buggy application.  Shouldn't memory protection and process segmentation prevent that?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55958559">

</div>
</div>

<div id="replyto_55958559"></div>

<ul id="group_55958559">
	<li id="hiddens_55958559" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55956455" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956455" class="commentstatus"></div>
<div id="comment_55956455" class="cw">
	<div id="comment_top_55956455" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956455" name="comment_link_55956455" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956455" onclick="return D2.setFocusComment(55956455)" >Re:</a>


		 	<span id="comment_score_55956455" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956455); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956455"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956455">Re "the content of the link itself, not the linked-to content."<br>
Its all part of building on search features <a href="https://www.wired.com/2014/10/how-to-fix-os-x-yosemite-search/" title="wired.com">https://www.wired.com/2014/10/...</a> [wired.com] (10.20.14)<nobr> <wbr></nobr>.</div>
	</div>

	<div class="commentSub" id="comment_sub_55956455">

</div>
</div>

<div id="replyto_55956455"></div>

<ul id="group_55956455">
	<li id="hiddens_55956455" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55956179" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956179" class="commentstatus"></div>
<div id="comment_55956179" class="cw">
	<div id="comment_top_55956179" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956179" name="comment_link_55956179" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956179" onclick="return D2.setFocusComment(55956179)" >Is it really a bug though??</a>


		 	<span id="comment_score_55956179" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956179); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956179"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956179"><p>I don't know about all of you, but I'm getting really excited just waiting to see how SuperKendall will enlighten us all as to how this is a feature that benefits each and every disciple of the Apple world. This is gonna be good.</p><p>+1 troll</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956179">

</div>
</div>

<div id="replyto_55956179"></div>

<ul id="group_55956179">
	<li id="hiddens_55956179" class="hide"></li>
</ul>

<ul id="commtree_55956179"><li id="tree_55956217" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956217" class="commentstatus"></div>
<div id="comment_55956217" class="cw">
</div>

<div id="replyto_55956217"></div>

<ul id="group_55956217">
	<li id="hiddens_55956217" class="hide"></li>
</ul>

</li><li id="hidestring_55956179"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956179">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956225" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956225" class="commentstatus"></div>
<div id="comment_55956225" class="cw">
	<div id="comment_top_55956225" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956225" name="comment_link_55956225" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956225" onclick="return D2.setFocusComment(55956225)" >Slowdowns?  </a>


		 	<span id="comment_score_55956225" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956225); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956225"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956225">As part of that crash and other slowdowns result is the user's password getting revealed in plain text again?</div>
	</div>

	<div class="commentSub" id="comment_sub_55956225">

</div>
</div>

<div id="replyto_55956225"></div>

<ul id="group_55956225">
	<li id="hiddens_55956225" class="hide"></li>
</ul>

<ul id="commtree_55956225"><li id="tree_55956377" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956377" class="commentstatus"></div>
<div id="comment_55956377" class="cw">
</div>

<div id="replyto_55956377"></div>

<ul id="group_55956377">
	<li id="hiddens_55956377" class="hide"></li>
</ul>

</li><li id="hidestring_55956225"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956225">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956277" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55956277" class="commentstatus"></div>
<div id="comment_55956277" class="cw">
	<div id="comment_top_55956277" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956277" name="comment_link_55956277" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956277" onclick="return D2.setFocusComment(55956277)" >Ban unicode</a>


		 	<span id="comment_score_55956277" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956277); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RightwingNutjob">RightwingNutjob</a>  <span class="uid"><a href="//slashdot.org/~RightwingNutjob">( 1302813 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956277">		
		on Thursday January 18, 2018 @05:35PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956277">#55956277</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956277">If it can't be expressed in ASCII, it's not worth writing.</div>
	</div>

	<div class="commentSub" id="comment_sub_55956277">
<span class="ind"></span><a id="reply_link_55956277" class="btn link" href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55956277" onclick="D2.replyTo(55956277); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Ban unicode by RightwingNutjob @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=11630975&cid=55956277" data-title="Ban unicode">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Ban unicode by RightwingNutjob" data-url="https://it.slashdot.org/comments.pl?sid=11630975&cid=55956277" data-title="Ban unicode">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Ban unicode by RightwingNutjob" data-url="https://it.slashdot.org/comments.pl?sid=11630975&cid=55956277" data-title="Ban unicode">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=11630975%26cid=55956277" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55956277" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55956277" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55956277"></div>

<ul id="group_55956277">
	<li id="hiddens_55956277" class="hide"></li>
</ul>

<ul id="commtree_55956277"><li id="tree_55956327" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956327" class="commentstatus"></div>
<div id="comment_55956327" class="cw">
	<div id="comment_top_55956327" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956327" name="comment_link_55956327" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956327" onclick="return D2.setFocusComment(55956327)" >Re:</a>


		 	<span id="comment_score_55956327" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956327); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956327"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956327"><p>Is all of ASCII really needed?  My ASR-33 teletype does a fine job with just the seven bit character set.  It doesn't even have lower case.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956327">

</div>
</div>

<div id="replyto_55956327"></div>

<ul id="group_55956327">
	<li id="hiddens_55956327" class="hide"></li>
</ul>

<ul id="commtree_55956327"><li id="tree_55956559" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956559" class="commentstatus"></div>
<div id="comment_55956559" class="cw">
</div>

<div id="replyto_55956559"></div>

<ul id="group_55956559">
	<li id="hiddens_55956559" class="hide"></li>
</ul>

</li><li id="hidestring_55956327"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956327">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956345" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956345" class="commentstatus"></div>
<div id="comment_55956345" class="cw">
</div>

<div id="replyto_55956345"></div>

<ul id="group_55956345">
	<li id="hiddens_55956345" class="hide"></li>
</ul>

</li><li id="tree_55956727" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956727" class="commentstatus"></div>
<div id="comment_55956727" class="cw">
	<div id="comment_top_55956727" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956727" name="comment_link_55956727" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956727" onclick="return D2.setFocusComment(55956727)" >Re:</a>


		 	<span id="comment_score_55956727" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956727); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jareth-0205">jareth-0205</a>  <span class="uid"><a href="//slashdot.org/~jareth-0205">( 525594 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956727"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956727"><p><div class="quote"><p>If it can't be expressed in ASCII, it's not worth writing.</p></div><p>No other languages exist in the world.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956727">

</div>
</div>

<div id="replyto_55956727"></div>

<ul id="group_55956727">
	<li id="hiddens_55956727" class="hide"></li>
</ul>

<ul id="commtree_55956727"><li id="tree_55956765" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956765" class="commentstatus"></div>
<div id="comment_55956765" class="cw">
</div>

<div id="replyto_55956765"></div>

<ul id="group_55956765">
	<li id="hiddens_55956765" class="hide"></li>
</ul>

</li><li id="tree_55957259" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55957259" class="commentstatus"></div>
<div id="comment_55957259" class="cw">
	<div id="comment_top_55957259" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55957259" name="comment_link_55957259" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55957259" onclick="return D2.setFocusComment(55957259)" >Re:</a>


		 	<span id="comment_score_55957259" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55957259); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RightwingNutjob">RightwingNutjob</a>  <span class="uid"><a href="//slashdot.org/~RightwingNutjob">( 1302813 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55957259"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55957259">They do, but that's irrelevant; the barbarians can learn to use Latin script like civilized people.</div>
	</div>

	<div class="commentSub" id="comment_sub_55957259">

</div>
</div>

<div id="replyto_55957259"></div>

<ul id="group_55957259">
	<li id="hiddens_55957259" class="hide"></li>
</ul>

</li><li id="hidestring_55956727"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956727">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55956277"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956277">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956299" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956299" class="commentstatus"></div>
<div id="comment_55956299" class="cw">
</div>

<div id="replyto_55956299"></div>

<ul id="group_55956299">
	<li id="hiddens_55956299" class="hide"></li>
</ul>

<ul id="commtree_55956299"><li id="tree_55956437" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956437" class="commentstatus"></div>
<div id="comment_55956437" class="cw">
</div>

<div id="replyto_55956437"></div>

<ul id="group_55956437">
	<li id="hiddens_55956437" class="hide"></li>
</ul>

<ul id="commtree_55956437"><li id="tree_55956461" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956461" class="commentstatus"></div>
<div id="comment_55956461" class="cw">
</div>

<div id="replyto_55956461"></div>

<ul id="group_55956461">
	<li id="hiddens_55956461" class="hide"></li>
</ul>

<ul id="commtree_55956461"><li id="tree_55956483" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956483" class="commentstatus"></div>
<div id="comment_55956483" class="cw">
	<div id="comment_top_55956483" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956483" name="comment_link_55956483" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956483" onclick="return D2.setFocusComment(55956483)" >Re:</a>


		 	<span id="comment_score_55956483" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956483); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lunix+Nutcase">Lunix Nutcase</a>  <span class="uid"><a href="//slashdot.org/~Lunix+Nutcase">( 1092239 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956483"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956483"><p>Oh so you mean like the stagefright bug for android?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956483">

</div>
</div>

<div id="replyto_55956483"></div>

<ul id="group_55956483">
	<li id="hiddens_55956483" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55956437"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956437">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956495" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55956495" class="commentstatus"></div>
<div id="comment_55956495" class="cw">
</div>

<div id="replyto_55956495"></div>

<ul id="group_55956495">
	<li id="hiddens_55956495" class="hide"></li>
</ul>

</li><li id="hidestring_55956299"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55956299">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55956459" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55956459" class="commentstatus"></div>
<div id="comment_55956459" class="cw">
	<div id="comment_top_55956459" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956459" name="comment_link_55956459" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956459" onclick="return D2.setFocusComment(55956459)" >Had this on an old Nokia phone</a>


		 	<span id="comment_score_55956459" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956459); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~whoever57">whoever57</a>  <span class="uid"><a href="//slashdot.org/~whoever57">( 658626 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956459">		
		on Thursday January 18, 2018 @06:06PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956459">#55956459</a>)
		<small><a href="//slashdot.org/~whoever57/journal/" title="Thursday September 30, 2004 @01:33AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956459"><p>Some text messages would reliably cause the phone to reboot on delivery of the message.</p><p>This would cause an almost endless reboot cycle, until the server gave up attempting to deliver the text message (around 10-20 reboots).</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956459">
<span class="ind"></span><a id="reply_link_55956459" class="btn link" href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55956459" onclick="D2.replyTo(55956459); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Had this on an old Nokia phone by whoever57 @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=11630975&cid=55956459" data-title="Had this on an old Nokia phone">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Had this on an old Nokia phone by whoever57" data-url="https://it.slashdot.org/comments.pl?sid=11630975&cid=55956459" data-title="Had this on an old Nokia phone">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Had this on an old Nokia phone by whoever57" data-url="https://it.slashdot.org/comments.pl?sid=11630975&cid=55956459" data-title="Had this on an old Nokia phone">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=11630975%26cid=55956459" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55956459" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55956459" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55956459"></div>

<ul id="group_55956459">
	<li id="hiddens_55956459" class="hide"></li>
</ul>

</li><li id="tree_55956871" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55956871" class="commentstatus"></div>
<div id="comment_55956871" class="cw">
	<div id="comment_top_55956871" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55956871" name="comment_link_55956871" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55956871" onclick="return D2.setFocusComment(55956871)" >Unicode!</a>


		 	<span id="comment_score_55956871" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55956871); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nmb3000">nmb3000</a>  <span class="uid"><a href="//slashdot.org/~nmb3000">( 741169 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55956871"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55956871"><p>This is exactly why Unicode support is unsafe and dangerous!  Thankfully Slashdot will always be a safe haven from such shenanigans.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55956871">

</div>
</div>

<div id="replyto_55956871"></div>

<ul id="group_55956871">
	<li id="hiddens_55956871" class="hide"></li>
</ul>

</li><li id="tree_55957047" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55957047" class="commentstatus"></div>
<div id="comment_55957047" class="cw">
</div>

<div id="replyto_55957047"></div>

<ul id="group_55957047">
	<li id="hiddens_55957047" class="hide"></li>
</ul>

</li><li id="tree_55957683" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55957683" class="commentstatus"></div>
<div id="comment_55957683" class="cw">
</div>

<div id="replyto_55957683"></div>

<ul id="group_55957683">
	<li id="hiddens_55957683" class="hide"></li>
</ul>

</li><li id="tree_55958235" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55958235" class="commentstatus"></div>
<div id="comment_55958235" class="cw">
	<div id="comment_top_55958235" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55958235" name="comment_link_55958235" href="//it.slashdot.org/comments.pl?sid=11630975&amp;cid=55958235" onclick="return D2.setFocusComment(55958235)" >It's still easy to find...</a>


		 	<span id="comment_score_55958235" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55958235); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~brendan.robert">Brendan Robert</a> <span class="socialbadge"><a class="g" href="#" title="From Google"></a></span> <span class="uid"><a href="//slashdot.org/~brendan.robert">( 2820681 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55958235"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55958235">Try the Wayback machine.  I found it pretty easily.  Really interesting trick.  He made a simple HTML file with a link in it, and the HREF of that link has all kinds of crazy garbage in it (unicode characters) which cause the webkit engine to spaz out.  Even copying the source out of chrome and pasting into Notepad++ made the text editor freak out a little bit.</div>
	</div>

	<div class="commentSub" id="comment_sub_55958235">

</div>
</div>

<div id="replyto_55958235"></div>

<ul id="group_55958235">
	<li id="hiddens_55958235" class="hide"></li>
</ul>

<ul id="commtree_55958235"><li id="tree_55958627" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55958627" class="commentstatus"></div>
<div id="comment_55958627" class="cw">
</div>

<div id="replyto_55958627"></div>

<ul id="group_55958627">
	<li id="hiddens_55958627" class="hide"></li>
</ul>

</li><li id="hidestring_55958235"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55958235">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11630975&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">8 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//it.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 24;
		D2.currents()['full']     = 2;
		D2.currents()['oneline']  = 20;
		// D2.currents_total(46);

		D2.abbrev_comments({55956241:522});
		D2.noshow_comments([55956091,55956185,55956113,55956333,55956615,55957005,55958387,55956121,55956429,55956127,55956423,55956141,55956217,55956377,55956559,55956345,55956765,55956299,55956437,55956461,55956495,55957047,55957683,55958627]);
		D2.pieces_comments([55956093,55956163,55956475,55956269,55956669,55957471,55956123,55957419,55956241,55957377,55958559,55956455,55956179,55956225,55956327,55956727,55957259,55956483,55956871,55958235]);
		D2.init_hiddens([55956093,55957005,55956615,55956113,55956121,55956127,55956179,55956225,55956327,55956727,55956277,55956437,55956299,55958235,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(336271);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1122<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/08/06/1836220/google-engineers-leaked-gender-diversity-essay-draws-massive-response?sdsrc=popbyskidbtmprev">Google Engineer's Leaked 'Gender Diversity' Essay Draws Massive Response</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>765<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/08/18/1626219/developer-accidentally-deletes-three-month-of-work-with-visual-studio-code?sdsrc=popbyskidbtmprev">Developer Accidentally Deletes Three-Month of Work With Visual Studio Code</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>581<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/05/20/0519258/the-working-dead-which-it-jobs-are-bound-for-extinction?sdsrc=popbyskidbtmprev">The Working Dead: Which IT Jobs Are Bound For Extinction?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>566<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/03/25/1729223/after-healthcare-defeat-can-the-trump-administration-fix-americas-h-1b-visa-program?sdsrc=popbyskidbtmprev">After Healthcare Defeat, Can The Trump Administration Fix America's H-1B Visa Program?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>555<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/03/16/202251/20000-worldclass-university-lectures-made-illegal-so-we-irrevocably-mirrored-them?sdsrc=popbyskidbtmprev">20,000 Worldclass University Lectures Made Illegal, So We Irrevocably Mirrored Them</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/18/01/18/2054205/wine-30-released?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/wine_64.png" width="64" height="64" alt="Wine"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/18/01/18/2054205/wine-30-released?sdsrc=nextbtmprev">Wine 3.0 Released</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>92<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//yro.slashdot.org/story/18/01/18/1925225/bitcoins-fluctuations-are-too-much-for-even-ransomware-cybercriminals?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/bitcoin_64.png" width="64" height="64" alt="Bitcoin"></span>
	    
					<p class="grid_12"><a href="//yro.slashdot.org/story/18/01/18/1925225/bitcoins-fluctuations-are-too-much-for-even-ransomware-cybercriminals?sdsrc=prevbtmprev">Bitcoin's Fluctuations Are Too Much For Even Ransomware Cybercriminals</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>55<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//it.slashdot.org/comments.pl?sid=11630975&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">44</span> of <span class="totalcommentcnt">44</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>If you're not part of the solution, you're part of the precipitate.</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2018 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?737">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?818">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->