<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '176230028971934167',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>MacOS High Sierra Bug Allows Login As Root With No Password - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="An anonymous reader quotes a report from The Register: A trivial-to-exploit flaw in macOS High Sierra, aka macOS 10.13, allows users to gain admin rights, or log in as root, without a password. The security bug is triggered via the authentication dialog box in Apple's operating system, which prompts...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="it.slashdot.org">
		<meta property="og:url" content="https://it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password">
	    
		<meta property="og:title" content="MacOS High Sierra Bug Allows Login As Root With No Password - Slashdot">
		<meta property="og:description" content="An anonymous reader quotes a report from The Register: A trivial-to-exploit flaw in macOS High Sierra, aka macOS 10.13, allows users to gain admin rights, or log in as root, without a password. The security bug is triggered via the authentication dialog box in Apple's operating system, which prompts...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/bug_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/334225" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?acf4e08ef95906a6" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?acf4e08ef95906a6" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?acf4e08ef95906a6" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?acf4e08ef95906a6">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?acf4e08ef95906a6"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?acf4e08ef95906a6" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//it.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotIt" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //it.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Become a fan of Slashdot on <a href="http://www.facebook.com/pages/Slashdotorg/267995220856">Facebook</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 CYBER MONDAY DEAL: Encrypt all of your data and surf the web safely with a lifetime of <strong><a href="https://deals.slashdot.org/sales/vpnsecure-lifetime-3?utm_source=slashdot&utm_medium=announcement-bar&utm_campaign=vpnsecure-lifetime-3">VPNSecure for $24</a></strong> with coupon code "CYBER40"
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-95570999" data-fhid="95570999" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">95570999</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-95570999">
			<a href="//it.slashdot.org/index2.pl?fhfilter=bug" onclick="return addfhfilter('bug');">
			
				<img src="//a.fsdn.com/sd/topics/bug_64.png" width="64" height="64" alt="Bug" title="Bug">
			
		</a>
		
	
		
		
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=macosx" onclick="return addfhfilter('macosx');">
			
				<img src="//a.fsdn.com/sd/topics/macosx_64.png" width="64" height="64" alt="OS X" title="OS X">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=os" onclick="return addfhfilter('os');">
			
				<img src="//a.fsdn.com/sd/topics/os_64.png" width="64" height="64" alt="Operating Systems" title="Operating Systems">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=mac" onclick="return addfhfilter('mac');">
			
				<img src="//a.fsdn.com/sd/topics/mac_64.png" width="64" height="64" alt="Desktops (Apple)" title="Desktops (Apple)">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=macbook" onclick="return addfhfilter('macbook');">
			
				<img src="//a.fsdn.com/sd/topics/applelaptop_64.png" width="64" height="64" alt="Portables (Apple)" title="Portables (Apple)">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=privacy" onclick="return addfhfilter('privacy');">
			
				<img src="//a.fsdn.com/sd/topics/privacy_64.png" width="64" height="64" alt="Privacy" title="Privacy">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=apple" onclick="return addfhfilter('apple');">
			
				<img src="//a.fsdn.com/sd/topics/apple_64.png" width="64" height="64" alt="Apple" title="Apple">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=technology" onclick="return addfhfilter('technology');">
			
				<img src="//a.fsdn.com/sd/topics/technology_64.png" width="64" height="64" alt="Technology" title="Technology">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-95570999" class="story-title"> <a   href="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password">MacOS High Sierra Bug Allows Login As Root With No Password</a> <span class=" no extlnk"><a class="story-sourcelnk" href="http://www.theregister.co.uk/2017/11/28/root_access_bypass_macos_high_sierra/"  title="External link - http://www.theregister.co.uk/2017/11/28/root_access_bypass_macos_high_sierra/" target="_blank"> (theregister.co.uk) </a></span></span>

		
		
		<!--<span class="comments commentcnt-95570999" >65</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password#comments" title="">65</a></span>
		
	</h2>
	<div class="details" id="details-95570999">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  <a href="https://twitter.com/BeauHD" rel="nofollow">BeauHD</a>
			
		
		

		
		
		<time id="fhtime-95570999" datetime="on Tuesday November 28, 2017 @05:00PM">on Tuesday November 28, 2017 @05:00PM</time>
		
		
			 from the <span class="dept-text">trivial-to-exploit</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-95570999">
	
		
	

	
		
		<div id="text-95570999" class="p">
			
		 	
				An anonymous reader quotes a report from The Register: <i>A trivial-to-exploit flaw in macOS High Sierra, aka macOS 10.13, <a href="http://www.theregister.co.uk/2017/11/28/root_access_bypass_macos_high_sierra/">allows users to gain admin rights, or log in as root, without a password</a>. The security bug is triggered via the authentication dialog box in Apple's operating system, which prompts you for an administrator's username and password when you need to do stuff like configure privacy and network settings. If you type in "root" as the username, leave the password box blank, hit "enter" and then click on unlock a few times, the prompt disappears and, congrats, you now have admin rights. You can do this from the user login screen. The vulnerability effectively allows someone with physical access to the machine to log in, cause extra mischief, install malware, and so on. You should not leave your vulnerable Mac unattended until you can fix the problem. And while obviously this situation is not the end of the world -- it's certainly far from a remote hole or a disk decryption technique -- it's just really, really sad to see megabucks Apple drop the ball like this.</i> Developer Lemi Orhan Ergan was the <a href="https://twitter.com/lemiorhan/status/935581020774117381?ref_src=twsrc%5Etfw&amp;ref_url=https%3A%2F%2Fwww.theregister.co.uk%2F2017%2F11%2F28%2Froot_access_bypass_macos_high_sierra%2F">first to alert the world</a> to the flaw. The Register notes: "If you have a root account enabled and a password for it set, the black password trick will not work. So, keep the account enabled and set a root password right now..."<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-95570999" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password"
								  data-janrain-title="MacOS High Sierra Bug Allows Login As Root With No Password"
								  data-janrain-message="MacOS High Sierra Bug Allows Login As Root With No Password @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-95570999" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/apple" target="_blank">apple</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/bug" target="_blank">bug</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/mac" target="_blank">mac</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//yro.slashdot.org/story/17/11/28/2016226/uber-trained-employees-on-how-to-impede-obstruct-or-influence-ongoing-legal-investigations-ex-employee-says?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>You may like to read:</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//tech.slashdot.org/story/17/11/28/2217254/after-two-months-of-quiet-north-korea-launches-another-ballistic-missile?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//yro.slashdot.org/story/17/11/28/2016226/uber-trained-employees-on-how-to-impede-obstruct-or-influence-ongoing-legal-investigations-ex-employee-says?sdsrc=prev">Uber Trained Employees on How To 'Impede, Obstruct or Influence' Ongoing Legal Investigations, Ex-employee Says </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
									
									
									
									

																				<h2><a href="//it.slashdot.org/story/17/08/06/1836220/google-engineers-leaked-gender-diversity-essay-draws-massive-response?sdsrc=popbyskid">Google Engineer's Leaked 'Gender Diversity' Essay Draws Massive Response</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/08/18/1626219/developer-accidentally-deletes-three-month-of-work-with-visual-studio-code?sdsrc=popbyskid">Developer Accidentally Deletes Three-Month of Work With Visual Studio Code</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/05/20/0519258/the-working-dead-which-it-jobs-are-bound-for-extinction?sdsrc=popbyskid">The Working Dead: Which IT Jobs Are Bound For Extinction?</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/03/25/1729223/after-healthcare-defeat-can-the-trump-administration-fix-americas-h-1b-visa-program?sdsrc=popbyskid">After Healthcare Defeat, Can The Trump Administration Fix America's H-1B Visa Program?</a><br></h2>
																				<h2><a href="//it.slashdot.org/story/17/03/16/202251/20000-worldclass-university-lectures-made-illegal-so-we-irrevocably-mirrored-them?sdsrc=popbyskid">20,000 Worldclass University Lectures Made Illegal, So We Irrevocably Mirrored Them</a><br></h2>
									
								
								
									<h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//it.slashdot.org/submission/7652623/macos-high-sierra-bug-allows-login-as-root-with-no-password?sdsrc=rel" href="#">Submission: MacOS High Sierra Bug Allows Login As Root With No Password</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//tech.slashdot.org/story/17/11/28/2217254/after-two-months-of-quiet-north-korea-launches-another-ballistic-missile?sdsrc=next">After Two Months of Quiet, North Korea Launches Another Ballistic Missile</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password" title="Back to Article - MacOS High Sierra Bug Allows Login As Root With No Password">MacOS High Sierra Bug Allows Login As Root With No Password</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//it.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - MacOS High Sierra Bug Allows Login As Root With No Password" href="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password">MacOS High Sierra Bug Allows Login As Root With No Password</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//it.slashdot.org/search.pl?op=comments&amp;sid=11415167" class="btn">Search <span class="totalcommentcnt">65</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//it.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//it.slashdot.org/comments.pl?sid=11415167">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//it.slashdot.org/search.pl?op=comments&amp;sid=11415167" class="ui-icon search_comments">Search <span class="totalcommentcnt">65</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//it.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/17/11/28/2135236/macos-high-sierra-bug-allows-login-as-root-with-no-password/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?acf4e08ef95906a6" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_55639453" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639453" class="commentstatus"></div>
<div id="comment_55639453" class="cw">
</div>

<div id="replyto_55639453"></div>

<ul id="group_55639453">
	<li id="hiddens_55639453" class="hide"></li>
</ul>

</li><li id="tree_55639477" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639477" class="commentstatus"></div>
<div id="comment_55639477" class="cw">
	<div id="comment_top_55639477" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639477" name="comment_link_55639477" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639477" onclick="return D2.setFocusComment(55639477)" >Am i missing something here?</a>


		 	<span id="comment_score_55639477" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639477); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lisandro">Lisandro</a>  <span class="uid"><a href="//slashdot.org/~Lisandro">( 799651 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639477"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639477"><p>So, logging as root without password works on High Sierra if there's a root account without password?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639477">

</div>
</div>

<div id="replyto_55639477"></div>

<ul id="group_55639477">
	<li id="hiddens_55639477" class="hide"></li>
</ul>

<ul id="commtree_55639477"><li id="tree_55639501" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639501" class="commentstatus"></div>
<div id="comment_55639501" class="cw">
</div>

<div id="replyto_55639501"></div>

<ul id="group_55639501">
	<li id="hiddens_55639501" class="hide"></li>
</ul>

<ul id="commtree_55639501"><li id="tree_55639521" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639521" class="commentstatus"></div>
<div id="comment_55639521" class="cw">
	<div id="comment_top_55639521" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639521" name="comment_link_55639521" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639521" onclick="return D2.setFocusComment(55639521)" >Re:</a>


		 	<span id="comment_score_55639521" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639521); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lisandro">Lisandro</a>  <span class="uid"><a href="//slashdot.org/~Lisandro">( 799651 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639521"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639521"><p><div class="quote"><p>How can you possibly have a root account without a password?</p></div><p>You certainly can, at least on most *nix flavors. Not the greatest idea though.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639521">

</div>
</div>

<div id="replyto_55639521"></div>

<ul id="group_55639521">
	<li id="hiddens_55639521" class="hide"></li>
</ul>

<ul id="commtree_55639521"><li id="tree_55640025" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640025" class="commentstatus"></div>
<div id="comment_55640025" class="cw">
	<div id="comment_top_55640025" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640025" name="comment_link_55640025" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640025" onclick="return D2.setFocusComment(55640025)" >Re:</a>


		 	<span id="comment_score_55640025" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640025); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ShanghaiBill">ShanghaiBill</a>  <span class="uid"><a href="//slashdot.org/~ShanghaiBill">( 739463 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640025"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640025"><p>Is no root password a requirement for this "bug"?  My Macbook has a root password.  I followed the directions in the summary, and it did NOT give me root.  I tried several variations.  Nothing worked.  So as far as I can see there is no bug.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55640025">

</div>
</div>

<div id="replyto_55640025"></div>

<ul id="group_55640025">
	<li id="hiddens_55640025" class="hide"></li>
</ul>

<ul id="commtree_55640025"><li id="tree_55640125" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55640125" class="commentstatus"></div>
<div id="comment_55640125" class="cw">
</div>

<div id="replyto_55640125"></div>

<ul id="group_55640125">
	<li id="hiddens_55640125" class="hide"></li>
</ul>

</li><li id="hidestring_55640025"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55640025">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55639555" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639555" class="commentstatus"></div>
<div id="comment_55639555" class="cw">
</div>

<div id="replyto_55639555"></div>

<ul id="group_55639555">
	<li id="hiddens_55639555" class="hide"></li>
</ul>

</li><li id="tree_55639823" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639823" class="commentstatus"></div>
<div id="comment_55639823" class="cw">
	<div id="comment_top_55639823" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639823" name="comment_link_55639823" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639823" onclick="return D2.setFocusComment(55639823)" >Re:</a>


		 	<span id="comment_score_55639823" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639823); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mrsquid0">mrsquid0</a>  <span class="uid"><a href="//slashdot.org/~mrsquid0">( 1335303 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639823"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639823"><p>One can have anything if one has Courage.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639823">

</div>
</div>

<div id="replyto_55639823"></div>

<ul id="group_55639823">
	<li id="hiddens_55639823" class="hide"></li>
</ul>

</li><li id="hidestring_55639501"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639501">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55639503" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639503" class="commentstatus"></div>
<div id="comment_55639503" class="cw">
</div>

<div id="replyto_55639503"></div>

<ul id="group_55639503">
	<li id="hiddens_55639503" class="hide"></li>
</ul>

</li><li id="tree_55639511" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55639511" class="commentstatus"></div>
<div id="comment_55639511" class="cw">
	<div id="comment_top_55639511" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639511" name="comment_link_55639511" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639511" onclick="return D2.setFocusComment(55639511)" >Re:Am i missing something here?</a>


		 	<span id="comment_score_55639511" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639511); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639511">		
		on Tuesday November 28, 2017 @05:09PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639511">#55639511</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639511"><p>By default, there's no root account. Attempting to log in as root with no password multiple times creates a root account with no password.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639511">
<span class="ind"></span><a id="reply_link_55639511" class="btn link" href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55639511" onclick="D2.replyTo(55639511); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55639477" onclick="return D2.selectParent(55639477)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Am i missing something here? by Anonymous Coward @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=11415167&cid=55639511" data-title="Re:Am i missing something here?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Am i missing something here? by Anonymous Coward" data-url="https://it.slashdot.org/comments.pl?sid=11415167&cid=55639511" data-title="Re:Am i missing something here?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Am i missing something here? by Anonymous Coward" data-url="https://it.slashdot.org/comments.pl?sid=11415167&cid=55639511" data-title="Re:Am i missing something here?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=11415167%26cid=55639511" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55639511" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55639511" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55639511"></div>

<ul id="group_55639511">
	<li id="hiddens_55639511" class="hide"></li>
</ul>

<ul id="commtree_55639511"><li id="tree_55639531" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639531" class="commentstatus"></div>
<div id="comment_55639531" class="cw">
	<div id="comment_top_55639531" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639531" name="comment_link_55639531" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639531" onclick="return D2.setFocusComment(55639531)" >Re:</a>


		 	<span id="comment_score_55639531" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639531); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lisandro">Lisandro</a>  <span class="uid"><a href="//slashdot.org/~Lisandro">( 799651 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639531"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639531"><p>That makes sense, thanks. Both the story and the linked article weren't really clear.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639531">

</div>
</div>

<div id="replyto_55639531"></div>

<ul id="group_55639531">
	<li id="hiddens_55639531" class="hide"></li>
</ul>

<ul id="commtree_55639531"><li id="tree_55639911" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639911" class="commentstatus"></div>
<div id="comment_55639911" class="cw">
</div>

<div id="replyto_55639911"></div>

<ul id="group_55639911">
	<li id="hiddens_55639911" class="hide"></li>
</ul>

</li><li id="hidestring_55639531"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639531">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55639529" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639529" class="commentstatus"></div>
<div id="comment_55639529" class="cw">
</div>

<div id="replyto_55639529"></div>

<ul id="group_55639529">
	<li id="hiddens_55639529" class="hide"></li>
</ul>

</li><li id="tree_55639539" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639539" class="commentstatus"></div>
<div id="comment_55639539" class="cw">
	<div id="comment_top_55639539" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639539" name="comment_link_55639539" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639539" onclick="return D2.setFocusComment(55639539)" >Re:</a>


		 	<span id="comment_score_55639539" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639539); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RhettLivingston">RhettLivingston</a>  <span class="uid"><a href="//slashdot.org/~RhettLivingston">( 544140 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639539"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639539">You're missing that it works if there is a <b>disabled</b> root account without a password too. Many people just give their own account admin access or create an admin account that isn't named root and disable the "root" account. You'd think that would be safe. It isn't.</div>
	</div>

	<div class="commentSub" id="comment_sub_55639539">

</div>
</div>

<div id="replyto_55639539"></div>

<ul id="group_55639539">
	<li id="hiddens_55639539" class="hide"></li>
</ul>

</li><li id="tree_55639547" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639547" class="commentstatus"></div>
<div id="comment_55639547" class="cw">
</div>

<div id="replyto_55639547"></div>

<ul id="group_55639547">
	<li id="hiddens_55639547" class="hide"></li>
</ul>

<ul id="commtree_55639547"><li id="tree_55639735" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639735" class="commentstatus"></div>
<div id="comment_55639735" class="cw">
	<div id="comment_top_55639735" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639735" name="comment_link_55639735" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639735" onclick="return D2.setFocusComment(55639735)" >Re:</a>


		 	<span id="comment_score_55639735" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639735); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Software">Software</a>  <span class="uid"><a href="//slashdot.org/~Software">( 179033 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639735"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639735">Why the quotes around exploit?</div>
	</div>

	<div class="commentSub" id="comment_sub_55639735">

</div>
</div>

<div id="replyto_55639735"></div>

<ul id="group_55639735">
	<li id="hiddens_55639735" class="hide"></li>
</ul>

<ul id="commtree_55639735"><li id="tree_55640143" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55640143" class="commentstatus"></div>
<div id="comment_55640143" class="cw">
</div>

<div id="replyto_55640143"></div>

<ul id="group_55640143">
	<li id="hiddens_55640143" class="hide"></li>
</ul>

</li><li id="hidestring_55639735"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639735">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55639625" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639625" class="commentstatus"></div>
<div id="comment_55639625" class="cw">
</div>

<div id="replyto_55639625"></div>

<ul id="group_55639625">
	<li id="hiddens_55639625" class="hide"></li>
</ul>

<ul id="commtree_55639625"><li id="tree_55639705" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639705" class="commentstatus"></div>
<div id="comment_55639705" class="cw">
</div>

<div id="replyto_55639705"></div>

<ul id="group_55639705">
	<li id="hiddens_55639705" class="hide"></li>
</ul>

</li><li id="tree_55639749" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639749" class="commentstatus"></div>
<div id="comment_55639749" class="cw">
</div>

<div id="replyto_55639749"></div>

<ul id="group_55639749">
	<li id="hiddens_55639749" class="hide"></li>
</ul>

</li><li id="tree_55639827" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639827" class="commentstatus"></div>
<div id="comment_55639827" class="cw">
	<div id="comment_top_55639827" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639827" name="comment_link_55639827" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639827" onclick="return D2.setFocusComment(55639827)" >Re:</a>


		 	<span id="comment_score_55639827" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639827); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aaarrrgggh">aaarrrgggh</a>  <span class="uid"><a href="//slashdot.org/~aaarrrgggh">( 9205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639827"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639827"><p>You first have to be logged in, presumably as an admin user, then try to do anything like change login settings where the user/password authentication pops up.  Log in root / no password.  It will let you complete the current task... and subsequently log in.</p><p>Someone needs to be fired at Apple.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639827">

</div>
</div>

<div id="replyto_55639827"></div>

<ul id="group_55639827">
	<li id="hiddens_55639827" class="hide"></li>
</ul>

<ul id="commtree_55639827"><li id="tree_55639939" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639939" class="commentstatus"></div>
<div id="comment_55639939" class="cw">
</div>

<div id="replyto_55639939"></div>

<ul id="group_55639939">
	<li id="hiddens_55639939" class="hide"></li>
</ul>

</li><li id="hidestring_55639827"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639827">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55639625"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639625">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55639781" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639781" class="commentstatus"></div>
<div id="comment_55639781" class="cw">
	<div id="comment_top_55639781" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639781" name="comment_link_55639781" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639781" onclick="return D2.setFocusComment(55639781)" >Re:</a>


		 	<span id="comment_score_55639781" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639781); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~elistan">elistan</a>  <span class="uid"><a href="//slashdot.org/~elistan">( 578864 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639781"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639781">From what I can gather, the bug is that a non-admin account can <i>create</i> an enabled root account without a password if there exists a disabled root account, regardless of the existing root account's password. And by default, a High Sierra install's root account is disabled, I think.</div>
	</div>

	<div class="commentSub" id="comment_sub_55639781">

</div>
</div>

<div id="replyto_55639781"></div>

<ul id="group_55639781">
	<li id="hiddens_55639781" class="hide"></li>
</ul>

</li><li id="tree_55639785" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639785" class="commentstatus"></div>
<div id="comment_55639785" class="cw">
	<div id="comment_top_55639785" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639785" name="comment_link_55639785" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639785" onclick="return D2.setFocusComment(55639785)" >Re:</a>


		 	<span id="comment_score_55639785" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639785); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~farble1670">farble1670</a>  <span class="uid"><a href="//slashdot.org/~farble1670">( 803356 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639785"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639785"><p><div class="quote"><p>So, logging as root without password works on High Sierra if there's a root account without password?</p></div><p>Just works with whatever is the default user configuration. I never modified anything other than creating an OSX user for myself.</p><p>What's even better is that if you have remote desktop turned on, anyone can connect and login as root.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639785">

</div>
</div>

<div id="replyto_55639785"></div>

<ul id="group_55639785">
	<li id="hiddens_55639785" class="hide"></li>
</ul>

</li><li id="hidestring_55639477"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639477">5 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55639485" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639485" class="commentstatus"></div>
<div id="comment_55639485" class="cw">
	<div id="comment_top_55639485" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639485" name="comment_link_55639485" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639485" onclick="return D2.setFocusComment(55639485)" >Apple deserves a geek at the top</a>


		 	<span id="comment_score_55639485" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639485); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~axettone">axettone</a>  <span class="uid"><a href="//slashdot.org/~axettone">( 1168915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639485"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639485">Tim Cook, please leave. Give us back a decent OS. Give us back good laptops/computers. Go sell shoes back again.</div>
	</div>

	<div class="commentSub" id="comment_sub_55639485">

</div>
</div>

<div id="replyto_55639485"></div>

<ul id="group_55639485">
	<li id="hiddens_55639485" class="hide"></li>
</ul>

<ul id="commtree_55639485"><li id="tree_55639709" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639709" class="commentstatus"></div>
<div id="comment_55639709" class="cw">
	<div id="comment_top_55639709" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639709" name="comment_link_55639709" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639709" onclick="return D2.setFocusComment(55639709)" >Re:</a>


		 	<span id="comment_score_55639709" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639709); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Megol">Megol</a>  <span class="uid"><a href="//slashdot.org/~Megol">( 3135005 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639709"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639709"><p>Yes this is obviously the fault of Tim Cook. Forcing the poor programmers to insert security holes is indeed his MO as should be obvious from this article:<br><a href="http://www.theregister.co.uk/2017/11/28/root_access_bypass_macos_high_sierra/" title="theregister.co.uk">http://www.theregister.co.uk/2...</a> [theregister.co.uk]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639709">

</div>
</div>

<div id="replyto_55639709"></div>

<ul id="group_55639709">
	<li id="hiddens_55639709" class="hide"></li>
</ul>

<ul id="commtree_55639709"><li id="tree_55639813" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639813" class="commentstatus"></div>
<div id="comment_55639813" class="cw">
	<div id="comment_top_55639813" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639813" name="comment_link_55639813" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639813" onclick="return D2.setFocusComment(55639813)" >Re:</a>


		 	<span id="comment_score_55639813" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639813); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639813"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639813"><p><div class="quote"><p>Yes this is obviously the fault of Tim Cook. Forcing the poor programmers to insert security holes is indeed his MO as should be obvious from this article:
<a href="http://www.theregister.co.uk/2017/11/28/root_access_bypass_macos_high_sierra/" title="theregister.co.uk" rel="nofollow">http://www.theregister.co.uk/2...</a> [theregister.co.uk] </p></div><p>Or maybe under Tim Cooks leadership the overall quality of Apples software and hardware has noticeably declined.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639813">

</div>
</div>

<div id="replyto_55639813"></div>

<ul id="group_55639813">
	<li id="hiddens_55639813" class="hide"></li>
</ul>

<ul id="commtree_55639813"><li id="tree_55640169" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55640169" class="commentstatus"></div>
<div id="comment_55640169" class="cw">
</div>

<div id="replyto_55640169"></div>

<ul id="group_55640169">
	<li id="hiddens_55640169" class="hide"></li>
</ul>

</li><li id="hidestring_55639813"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639813">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55639843" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639843" class="commentstatus"></div>
<div id="comment_55639843" class="cw">
	<div id="comment_top_55639843" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639843" name="comment_link_55639843" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639843" onclick="return D2.setFocusComment(55639843)" >Re:</a>


		 	<span id="comment_score_55639843" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639843); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PoopJuggler">PoopJuggler</a>  <span class="uid"><a href="//slashdot.org/~PoopJuggler">( 688445 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639843"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639843">Srsly, dude? Mac OSX is pretty much the slickest thing out there. Which OS, specifically, do you want Tim Cook to give you back? System 7? System 8? Because those were so much better..?</div>
	</div>

	<div class="commentSub" id="comment_sub_55639843">

</div>
</div>

<div id="replyto_55639843"></div>

<ul id="group_55639843">
	<li id="hiddens_55639843" class="hide"></li>
</ul>

<ul id="commtree_55639843"><li id="tree_55640229" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55640229" class="commentstatus"></div>
<div id="comment_55640229" class="cw">
</div>

<div id="replyto_55640229"></div>

<ul id="group_55640229">
	<li id="hiddens_55640229" class="hide"></li>
</ul>

</li><li id="hidestring_55639843"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639843">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55639509" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639509" class="commentstatus"></div>
<div id="comment_55639509" class="cw">
</div>

<div id="replyto_55639509"></div>

<ul id="group_55639509">
	<li id="hiddens_55639509" class="hide"></li>
</ul>

</li><li id="tree_55639537" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639537" class="commentstatus"></div>
<div id="comment_55639537" class="cw">
</div>

<div id="replyto_55639537"></div>

<ul id="group_55639537">
	<li id="hiddens_55639537" class="hide"></li>
</ul>

<ul id="commtree_55639537"><li id="tree_55639839" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639839" class="commentstatus"></div>
<div id="comment_55639839" class="cw">
	<div id="comment_top_55639839" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639839" name="comment_link_55639839" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639839" onclick="return D2.setFocusComment(55639839)" >Re:</a>


		 	<span id="comment_score_55639839" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639839); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Falos">Falos</a>  <span class="uid"><a href="//slashdot.org/~Falos">( 2905315 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639839"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639839"><p>The correct response, as always, is for people to chime in with Mine Works Fine/I've Never Had A Problem posts.</p><p>Seems like a pointless thing to show up and say, but tradition is as tradition does.</p><p>This isn't an apple-exclusive phenomenon, but they are the masters of it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639839">

</div>
</div>

<div id="replyto_55639839"></div>

<ul id="group_55639839">
	<li id="hiddens_55639839" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55639549" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639549" class="commentstatus"></div>
<div id="comment_55639549" class="cw">
</div>

<div id="replyto_55639549"></div>

<ul id="group_55639549">
	<li id="hiddens_55639549" class="hide"></li>
</ul>

<ul id="commtree_55639549"><li id="tree_55640091" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640091" class="commentstatus"></div>
<div id="comment_55640091" class="cw">
	<div id="comment_top_55640091" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640091" name="comment_link_55640091" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640091" onclick="return D2.setFocusComment(55640091)" >Re: Lenny is that you?</a>


		 	<span id="comment_score_55640091" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640091); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640091"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640091">This is literally nothing like that issue. To "exploit" that issue you already have to have root access.  It is the typical "OMFG, if you are root you can get root privs!" cry of the moron without a clue.</div>
	</div>

	<div class="commentSub" id="comment_sub_55640091">

</div>
</div>

<div id="replyto_55640091"></div>

<ul id="group_55640091">
	<li id="hiddens_55640091" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55639589" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639589" class="commentstatus"></div>
<div id="comment_55639589" class="cw">
	<div id="comment_top_55639589" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639589" name="comment_link_55639589" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639589" onclick="return D2.setFocusComment(55639589)" >All it requires...</a>


		 	<span id="comment_score_55639589" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639589); return false"><span class=opt>Score:</span>2</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~x0ra">x0ra</a>  <span class="uid"><a href="//slashdot.org/~x0ra">( 1249540 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639589"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639589">is "courage" to go beyond the heteronormative system of power and privileges. Why would you require privileges in a progressist society where everybody is equal.<br> <br>
USER LIVES MATTERS !</div>
	</div>

	<div class="commentSub" id="comment_sub_55639589">

</div>
</div>

<div id="replyto_55639589"></div>

<ul id="group_55639589">
	<li id="hiddens_55639589" class="hide"></li>
</ul>

<ul id="commtree_55639589"><li id="tree_55639725" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639725" class="commentstatus"></div>
<div id="comment_55639725" class="cw">
	<div id="comment_top_55639725" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639725" name="comment_link_55639725" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639725" onclick="return D2.setFocusComment(55639725)" >Re:</a>


		 	<span id="comment_score_55639725" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639725); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lisandro">Lisandro</a>  <span class="uid"><a href="//slashdot.org/~Lisandro">( 799651 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639725"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639725"><p>So you're saying this is revolutionary?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639725">

</div>
</div>

<div id="replyto_55639725"></div>

<ul id="group_55639725">
	<li id="hiddens_55639725" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55639619" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639619" class="commentstatus"></div>
<div id="comment_55639619" class="cw">
	<div id="comment_top_55639619" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639619" name="comment_link_55639619" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639619" onclick="return D2.setFocusComment(55639619)" >My Macintosh runs eunichs!</a>


		 	<span id="comment_score_55639619" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639619); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639619"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639619"><p>And no, not my SE/30 that runs NetBSD.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639619">

</div>
</div>

<div id="replyto_55639619"></div>

<ul id="group_55639619">
	<li id="hiddens_55639619" class="hide"></li>
</ul>

</li><li id="tree_55639647" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639647" class="commentstatus"></div>
<div id="comment_55639647" class="cw">
</div>

<div id="replyto_55639647"></div>

<ul id="group_55639647">
	<li id="hiddens_55639647" class="hide"></li>
</ul>

<ul id="commtree_55639647"><li id="tree_55639893" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639893" class="commentstatus"></div>
<div id="comment_55639893" class="cw">
	<div id="comment_top_55639893" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639893" name="comment_link_55639893" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639893" onclick="return D2.setFocusComment(55639893)" >Re:</a>


		 	<span id="comment_score_55639893" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639893); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DontBeAMoran">DontBeAMoran</a>  <span class="uid"><a href="//slashdot.org/~DontBeAMoran">( 4843879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639893"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639893"><p>I have both a return key and an enter key on my Apple aluminium wired keyboard.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639893">

</div>
</div>

<div id="replyto_55639893"></div>

<ul id="group_55639893">
	<li id="hiddens_55639893" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55639675" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639675" class="commentstatus"></div>
<div id="comment_55639675" class="cw">
	<div id="comment_top_55639675" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639675" name="comment_link_55639675" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639675" onclick="return D2.setFocusComment(55639675)" >Work-around</a>


		 	<span id="comment_score_55639675" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639675); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MAXOMENOS">MAXOMENOS</a>  <span class="uid"><a href="//slashdot.org/~MAXOMENOS">( 9802 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639675"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639675"><p>Set the root password to something long and hard to guess (32 chars of mixed-case alphanumeric should do). Do this by running as an administrator:</p><p>sudo passwd -u root</p><p>This should do until Apple releases a real fix.</p><p> <a href="https://twitter.com/colourmeamused_/status/935603805449678848" title="twitter.com">Source</a> [twitter.com] </p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639675">

</div>
</div>

<div id="replyto_55639675"></div>

<ul id="group_55639675">
	<li id="hiddens_55639675" class="hide"></li>
</ul>

<ul id="commtree_55639675"><li id="tree_55639743" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639743" class="commentstatus"></div>
<div id="comment_55639743" class="cw">
</div>

<div id="replyto_55639743"></div>

<ul id="group_55639743">
	<li id="hiddens_55639743" class="hide"></li>
</ul>

</li><li id="tree_55639849" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639849" class="commentstatus"></div>
<div id="comment_55639849" class="cw">
	<div id="comment_top_55639849" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639849" name="comment_link_55639849" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639849" onclick="return D2.setFocusComment(55639849)" >Re:</a>


		 	<span id="comment_score_55639849" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639849); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aaarrrgggh">aaarrrgggh</a>  <span class="uid"><a href="//slashdot.org/~aaarrrgggh">( 9205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639849"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639849"><p>...but make sure you write down that 32 character password since you won't be able to sudo without it!</p><p>Just curious what this will break...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639849">

</div>
</div>

<div id="replyto_55639849"></div>

<ul id="group_55639849">
	<li id="hiddens_55639849" class="hide"></li>
</ul>

<ul id="commtree_55639849"><li id="tree_55639895" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639895" class="commentstatus"></div>
<div id="comment_55639895" class="cw">
	<div id="comment_top_55639895" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639895" name="comment_link_55639895" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639895" onclick="return D2.setFocusComment(55639895)" >Re:</a>


		 	<span id="comment_score_55639895" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639895); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BronsCon">BronsCon</a>  <span class="uid"><a href="//slashdot.org/~BronsCon">( 927697 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639895"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639895">sudo uses your user password...</div>
	</div>

	<div class="commentSub" id="comment_sub_55639895">

</div>
</div>

<div id="replyto_55639895"></div>

<ul id="group_55639895">
	<li id="hiddens_55639895" class="hide"></li>
</ul>

</li><li id="tree_55640029" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640029" class="commentstatus"></div>
<div id="comment_55640029" class="cw">
	<div id="comment_top_55640029" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640029" name="comment_link_55640029" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640029" onclick="return D2.setFocusComment(55640029)" >Re:</a>


		 	<span id="comment_score_55640029" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640029); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~XparXnoiaX">XparXnoiaX</a>  <span class="uid"><a href="//slashdot.org/~XparXnoiaX">( 4714613 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640029"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640029">Another workaround is to not let anyone touch your computer (unless you trust them) because you need to have access before doing anything. This is a ridiculous bug, but it's not easy to exploit remotely.</div>
	</div>

	<div class="commentSub" id="comment_sub_55640029">

</div>
</div>

<div id="replyto_55640029"></div>

<ul id="group_55640029">
	<li id="hiddens_55640029" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55639675"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639675">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55639697" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639697" class="commentstatus"></div>
<div id="comment_55639697" class="cw">
</div>

<div id="replyto_55639697"></div>

<ul id="group_55639697">
	<li id="hiddens_55639697" class="hide"></li>
</ul>

</li><li id="tree_55639717" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639717" class="commentstatus"></div>
<div id="comment_55639717" class="cw">
</div>

<div id="replyto_55639717"></div>

<ul id="group_55639717">
	<li id="hiddens_55639717" class="hide"></li>
</ul>

</li><li id="tree_55639723" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639723" class="commentstatus"></div>
<div id="comment_55639723" class="cw">
	<div id="comment_top_55639723" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639723" name="comment_link_55639723" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639723" onclick="return D2.setFocusComment(55639723)" >Be courageous. Eat the worm.</a>


		 	<span id="comment_score_55639723" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639723); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fyngyrz">fyngyrz</a>  <span class="uid"><a href="//slashdot.org/~fyngyrz">( 762201 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639723"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639723"><blockquote><div><p>it's just really, really sad to see megabucks Apple drop the ball like this.</p></div></blockquote><p>Apple drops the ball constantly. Sometimes they don't pick it back up, either. They leave routinely leave known, reported bugs in versions of the OS that are still in common use (in fact, they <i>force</i> them to be in common use by not letting some perfectly capable machines, even high end, expensive ones, upgrade to a later OS.) Then there are major screwups like "app nap" they stab us with, and the constant churn of "feature in, featur<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639723">

</div>
</div>

<div id="replyto_55639723"></div>

<ul id="group_55639723">
	<li id="hiddens_55639723" class="hide"></li>
</ul>

<ul id="commtree_55639723"><li id="tree_55639859" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639859" class="commentstatus"></div>
<div id="comment_55639859" class="cw">
	<div id="comment_top_55639859" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639859" name="comment_link_55639859" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639859" onclick="return D2.setFocusComment(55639859)" >Re:</a>


		 	<span id="comment_score_55639859" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639859); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PoopJuggler">PoopJuggler</a>  <span class="uid"><a href="//slashdot.org/~PoopJuggler">( 688445 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639859"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639859">And you never ship bugs? Ever? Shit happens, get over it.</div>
	</div>

	<div class="commentSub" id="comment_sub_55639859">

</div>
</div>

<div id="replyto_55639859"></div>

<ul id="group_55639859">
	<li id="hiddens_55639859" class="hide"></li>
</ul>

<ul id="commtree_55639859"><li id="tree_55639965" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639965" class="commentstatus"></div>
<div id="comment_55639965" class="cw">
	<div id="comment_top_55639965" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639965" name="comment_link_55639965" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639965" onclick="return D2.setFocusComment(55639965)" >Re:</a>


		 	<span id="comment_score_55639965" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639965); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fyngyrz">fyngyrz</a>  <span class="uid"><a href="//slashdot.org/~fyngyrz">( 762201 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639965"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639965"><blockquote><div><p>And you never ship bugs? Ever? Shit happens, get over it.</p></div></blockquote><p>First of all, when I ship bugs, I <b>fix them</b> if it's within my abilities to do so. Which is usually is. And I will tell you flat out that if I had <i>billions of dollars in the bank</i>, I'd be able to fix <b>every one that was found</b>, because there are people I could hire that are <i>way</i> smarter than me, and I could hire a <i>lot</i> of them without feeling any pain at all.</p><p>My problem with Apple isn't that they ship bugs anyway... it's that <i>they leave serious bugs in place<span class="substr"> </span></i></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639965">

</div>
</div>

<div id="replyto_55639965"></div>

<ul id="group_55639965">
	<li id="hiddens_55639965" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_55639727" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55639727" class="commentstatus"></div>
<div id="comment_55639727" class="cw">
	<div id="comment_top_55639727" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639727" name="comment_link_55639727" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639727" onclick="return D2.setFocusComment(55639727)" >Why/how though?</a>


		 	<span id="comment_score_55639727" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639727); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xuranova">Xuranova</a>  <span class="uid"><a href="//slashdot.org/~Xuranova">( 160813 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639727">		
		on Tuesday November 28, 2017 @05:33PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639727">#55639727</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639727"><p>I can understand if it let you in after hitting enter once, because then it's just ignoring something. If it denies entry the first few times and then lets you in, what do the *nix gurus think is happening after the first few denials to have it change its 'mind?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639727">
<span class="ind"></span><a id="reply_link_55639727" class="btn link" href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55639727" onclick="D2.replyTo(55639727); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Why/how though? by Xuranova @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=11415167&cid=55639727" data-title="Why/how though?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Why/how though? by Xuranova" data-url="https://it.slashdot.org/comments.pl?sid=11415167&cid=55639727" data-title="Why/how though?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Why/how though? by Xuranova" data-url="https://it.slashdot.org/comments.pl?sid=11415167&cid=55639727" data-title="Why/how though?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=11415167%26cid=55639727" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55639727" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55639727" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55639727"></div>

<ul id="group_55639727">
	<li id="hiddens_55639727" class="hide"></li>
</ul>

<ul id="commtree_55639727"><li id="tree_55639869" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639869" class="commentstatus"></div>
<div id="comment_55639869" class="cw">
</div>

<div id="replyto_55639869"></div>

<ul id="group_55639869">
	<li id="hiddens_55639869" class="hide"></li>
</ul>

</li><li id="tree_55639929" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639929" class="commentstatus"></div>
<div id="comment_55639929" class="cw">
	<div id="comment_top_55639929" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639929" name="comment_link_55639929" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639929" onclick="return D2.setFocusComment(55639929)" >Tests made sure it works. Garbage in, garbage out</a>


		 	<span id="comment_score_55639929" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639929); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~raymorris">raymorris</a>  <span class="uid"><a href="//slashdot.org/~raymorris">( 2726007 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639929"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639929"><p>My educated guess from 20 years in computer security:</p><p>The graphical UI it gives up after a few tries, which is reasonable. Unit tests tested that you can login that way and maybe tested that it gives up.</p><p>Separately, on the underlying Unix side they may have tested that part well - if you enter a correct password you get in, an incorrect password doesn't get you in.</p><p>In Integration testing UI designers made sure it WORKS - you can log in that way. They didn't test crazy shit like entering a million-character pas<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639929">

</div>
</div>

<div id="replyto_55639929"></div>

<ul id="group_55639929">
	<li id="hiddens_55639929" class="hide"></li>
</ul>

</li><li id="tree_55640023" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640023" class="commentstatus"></div>
<div id="comment_55640023" class="cw">
	<div id="comment_top_55640023" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640023" name="comment_link_55640023" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640023" onclick="return D2.setFocusComment(55640023)" >Re:</a>


		 	<span id="comment_score_55640023" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640023); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~XparXnoiaX">XparXnoiaX</a>  <span class="uid"><a href="//slashdot.org/~XparXnoiaX">( 4714613 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640023"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640023">It's a strong indication that the code they are using to manage login is too complex and needs to be simplified.</div>
	</div>

	<div class="commentSub" id="comment_sub_55640023">

</div>
</div>

<div id="replyto_55640023"></div>

<ul id="group_55640023">
	<li id="hiddens_55640023" class="hide"></li>
</ul>

</li><li id="hidestring_55639727"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55639727">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55639753" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639753" class="commentstatus"></div>
<div id="comment_55639753" class="cw">
	<div id="comment_top_55639753" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639753" name="comment_link_55639753" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639753" onclick="return D2.setFocusComment(55639753)" >User chethan177 was actually first to report</a>


		 	<span id="comment_score_55639753" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639753); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639753"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639753"><p>https://forums.developer.apple.com/thread/79235</p><p>'course, this post may not have been reported directly to security folks. it was something that they should have found while monitoring the beta forums, though.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639753">

</div>
</div>

<div id="replyto_55639753"></div>

<ul id="group_55639753">
	<li id="hiddens_55639753" class="hide"></li>
</ul>

<ul id="commtree_55639753"><li id="tree_55640093" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640093" class="commentstatus"></div>
<div id="comment_55640093" class="cw">
	<div id="comment_top_55640093" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640093" name="comment_link_55640093" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640093" onclick="return D2.setFocusComment(55640093)" >Re:</a>


		 	<span id="comment_score_55640093" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640093); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ecuador">Ecuador</a>  <span class="uid"><a href="//slashdot.org/~Ecuador">( 740021 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640093"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640093"><p>This is very funny, he actually found the biggest user escalation exploit in recent memory and he just nonchalantly posts it as an answer to a thread about someone who had his admin accounts turned to standard, with his only comment being "Solution 2 worked for me. No idea how or why. Hope this helps.".</p><p>Unless he did not stumble upon it, but read it elsewhere and that is why he is so "business as usual"...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55640093">

</div>
</div>

<div id="replyto_55640093"></div>

<ul id="group_55640093">
	<li id="hiddens_55640093" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55639835" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55639835" class="commentstatus"></div>
<div id="comment_55639835" class="cw">
	<div id="comment_top_55639835" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55639835" name="comment_link_55639835" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55639835" onclick="return D2.setFocusComment(55639835)" >Windows 10 ...</a>


		 	<span id="comment_score_55639835" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55639835); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CaptainDork">CaptainDork</a>  <span class="uid"><a href="//slashdot.org/~CaptainDork">( 3678879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55639835"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55639835"><p>... does not have this problem and that's why I don't use Mac OS so the real solution is to configure systemd and get a Linux box and dance to distro duck while unixifying the baseline adoptive parameters of the dilbertized root account.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55639835">

</div>
</div>

<div id="replyto_55639835"></div>

<ul id="group_55639835">
	<li id="hiddens_55639835" class="hide"></li>
</ul>

</li><li id="tree_55639865" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639865" class="commentstatus"></div>
<div id="comment_55639865" class="cw">
</div>

<div id="replyto_55639865"></div>

<ul id="group_55639865">
	<li id="hiddens_55639865" class="hide"></li>
</ul>

</li><li id="tree_55639867" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639867" class="commentstatus"></div>
<div id="comment_55639867" class="cw">
</div>

<div id="replyto_55639867"></div>

<ul id="group_55639867">
	<li id="hiddens_55639867" class="hide"></li>
</ul>

</li><li id="tree_55639905" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639905" class="commentstatus"></div>
<div id="comment_55639905" class="cw">
</div>

<div id="replyto_55639905"></div>

<ul id="group_55639905">
	<li id="hiddens_55639905" class="hide"></li>
</ul>

</li><li id="tree_55639967" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639967" class="commentstatus"></div>
<div id="comment_55639967" class="cw">
</div>

<div id="replyto_55639967"></div>

<ul id="group_55639967">
	<li id="hiddens_55639967" class="hide"></li>
</ul>

</li><li id="tree_55639973" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55639973" class="commentstatus"></div>
<div id="comment_55639973" class="cw">
</div>

<div id="replyto_55639973"></div>

<ul id="group_55639973">
	<li id="hiddens_55639973" class="hide"></li>
</ul>

</li><li id="tree_55640059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640059" class="commentstatus"></div>
<div id="comment_55640059" class="cw">
	<div id="comment_top_55640059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640059" name="comment_link_55640059" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640059" onclick="return D2.setFocusComment(55640059)" >Best reponse on the twitter feed:</a>


		 	<span id="comment_score_55640059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640059); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~julian67">julian67</a>  <span class="uid"><a href="//slashdot.org/~julian67">( 1022593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640059">It takes a lot of #courage to ship root without a password...</div>
	</div>

	<div class="commentSub" id="comment_sub_55640059">

</div>
</div>

<div id="replyto_55640059"></div>

<ul id="group_55640059">
	<li id="hiddens_55640059" class="hide"></li>
</ul>

</li><li id="tree_55640111" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55640111" class="commentstatus"></div>
<div id="comment_55640111" class="cw">
</div>

<div id="replyto_55640111"></div>

<ul id="group_55640111">
	<li id="hiddens_55640111" class="hide"></li>
</ul>

</li><li id="tree_55640135" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55640135" class="commentstatus"></div>
<div id="comment_55640135" class="cw">
	<div id="comment_top_55640135" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55640135" name="comment_link_55640135" href="//it.slashdot.org/comments.pl?sid=11415167&amp;cid=55640135" onclick="return D2.setFocusComment(55640135)" >Thanks for stealing my submission</a>


		 	<span id="comment_score_55640135" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55640135); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ryanmc1">ryanmc1</a>  <span class="uid"><a href="//slashdot.org/~ryanmc1">( 682957 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55640135"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55640135">I submitted this a couple hours before it was posted on the front page. Why does it say an anonymous reader posted it?
<a href="https://slashdot.org/submission/7652635/you-can-log-into-macos-high-sierra-as-root-with-no-password" title="slashdot.org">https://slashdot.org/submissio...</a> [slashdot.org]</div>
	</div>

	<div class="commentSub" id="comment_sub_55640135">

</div>
</div>

<div id="replyto_55640135"></div>

<ul id="group_55640135">
	<li id="hiddens_55640135" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=11415167&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">13 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//it.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 29;
		D2.currents()['full']     = 2;
		D2.currents()['oneline']  = 34;
		// D2.currents_total(65);

		D2.abbrev_comments({55639929:536,55639965:602,55639723:565});
		D2.noshow_comments([55639453,55639501,55640125,55639555,55639503,55639911,55639529,55639547,55640143,55639625,55639705,55639749,55639939,55640169,55640229,55639509,55639537,55639549,55639647,55639743,55639697,55639717,55639869,55639865,55639867,55639905,55639967,55639973,55640111]);
		D2.pieces_comments([55639477,55639521,55640025,55639823,55639531,55639539,55639735,55639827,55639781,55639785,55639485,55639709,55639813,55639843,55639839,55640091,55639589,55639725,55639619,55639893,55639675,55639849,55639895,55640029,55639723,55639859,55639965,55639929,55640023,55639753,55640093,55639835,55640059,55640135]);
		D2.init_hiddens([55640025,55639501,55639531,55639735,55639827,55639625,55639477,55639813,55639843,55639675,55639727,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(334225);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1122<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/08/06/1836220/google-engineers-leaked-gender-diversity-essay-draws-massive-response?sdsrc=popbyskidbtmprev">Google Engineer's Leaked 'Gender Diversity' Essay Draws Massive Response</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>765<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/08/18/1626219/developer-accidentally-deletes-three-month-of-work-with-visual-studio-code?sdsrc=popbyskidbtmprev">Developer Accidentally Deletes Three-Month of Work With Visual Studio Code</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>581<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/05/20/0519258/the-working-dead-which-it-jobs-are-bound-for-extinction?sdsrc=popbyskidbtmprev">The Working Dead: Which IT Jobs Are Bound For Extinction?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>566<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/03/25/1729223/after-healthcare-defeat-can-the-trump-administration-fix-americas-h-1b-visa-program?sdsrc=popbyskidbtmprev">After Healthcare Defeat, Can The Trump Administration Fix America's H-1B Visa Program?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>555<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/17/03/16/202251/20000-worldclass-university-lectures-made-illegal-so-we-irrevocably-mirrored-them?sdsrc=popbyskidbtmprev">20,000 Worldclass University Lectures Made Illegal, So We Irrevocably Mirrored Them</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/17/11/28/2217254/after-two-months-of-quiet-north-korea-launches-another-ballistic-missile?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/military_64.png" width="64" height="64" alt="The Military"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/17/11/28/2217254/after-two-months-of-quiet-north-korea-launches-another-ballistic-missile?sdsrc=nextbtmprev">After Two Months of Quiet, North Korea Launches Another Ballistic Missile</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>31<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//yro.slashdot.org/story/17/11/28/2016226/uber-trained-employees-on-how-to-impede-obstruct-or-influence-ongoing-legal-investigations-ex-employee-says?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses"></span>
	    
					<p class="grid_12"><a href="//yro.slashdot.org/story/17/11/28/2016226/uber-trained-employees-on-how-to-impede-obstruct-or-influence-ongoing-legal-investigations-ex-employee-says?sdsrc=prevbtmprev">Uber Trained Employees on How To 'Impede, Obstruct or Influence' Ongoing Legal Investigations, Ex-employee Says</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>29<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//it.slashdot.org/comments.pl?sid=11415167&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">66</span> of <span class="totalcommentcnt">66</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>"Poor man... he was like an employee to me."
-- The police commisioner on "Sledge Hammer" laments the death of his bodyguard</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?301">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?603">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->