<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '26052543763912714',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Does Code Reuse Endanger Secure Software Development? - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="msm1267 quotes ThreatPost: The amount of insecure software tied to reused third-party libraries and lingering in applications long after patches have been deployed is staggering. It's a habitual problem perpetuated by developers failing to vet third-party code for vulnerabilities, and some repositor...">
		<meta itemprop="name" content="Does Code Reuse Endanger Secure Software Development? - Slashdot">
		<meta itemprop="description" content="msm1267 quotes ThreatPost: The amount of insecure software tied to reused third-party libraries and lingering in applications long after patches have been deployed is staggering. It's a habitual problem perpetuated by developers failing to vet third-party code for vulnerabilities, and some repositor...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/security_64.png">
	
	
		<link rel="canonical" href="https://it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/320147" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?release_20161213" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?release_20161213" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?release_20161213" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?release_20161213">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: bug security developers programming
  
  var backend_tpc = [[ "bug", "programming", "developers", "security", "it" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?release_20161213"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?release_20161213" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//it.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotIt" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //it.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Catch up on stories from the past week (and beyond) at the <a href="//slashdot.org/archive.pl">Slashdot story archive</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="adwrap">
				
				<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
				<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 internet speed test!</a></strong> No Flash necessary and runs on all devices.
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-87982661" data-fhid="87982661" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">87982661</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-87982661">
			<a href="//it.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		
	
		
		
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=bug" onclick="return addfhfilter('bug');">
			
				<img src="//a.fsdn.com/sd/topics/bug_64.png" width="64" height="64" alt="Bug" title="Bug">
			
		</a>
		
	
		
		

		
		<a href="//it.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-87982661" class="story-title"> <a   href="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development">Does Code Reuse Endanger Secure Software Development?</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://threatpost.com/code-reuse-a-peril-for-secure-software-development/122476/"  title="External link - https://threatpost.com/code-reuse-a-peril-for-secure-software-development/122476/" target="_blank"> (threatpost.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-87982661" >148</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development#comments" title="">148</a></span>
		
	</h2>
	<div class="details" id="details-87982661">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-87982661" datetime="on Saturday December 17, 2016 @07:34PM">on Saturday December 17, 2016 @07:34PM</time>
		
		
			 from the <span class="dept-text">does-code-reuse-endanger-secure-software-development</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-87982661">
	
		
	

	
		
		<div id="text-87982661" class="p">
			
		 	
				<a href="/~msm1267">msm1267</a> quotes ThreatPost: <i>The amount of insecure software tied to <a href="https://threatpost.com/code-reuse-a-peril-for-secure-software-development/122476/">reused third-party libraries</a> and lingering in applications long after patches have been deployed is staggering. It's a habitual problem perpetuated by developers failing to vet third-party code for vulnerabilities, and some repositories taking a hands-off approach with the code they host. This scenario allows attackers to target one overlooked component flaw used in millions of applications instead of focusing on a single application security vulnerability. <br> <br>The real-world consequences have been demonstrated in the past few years with <a href="https://it.slashdot.org/story/14/05/09/1240238/one-month-later-300000-servers-remain-vulnerable-to-heartbleed">the Heartbleed vulnerability in OpenSSL</a>, <a href="https://apple.slashdot.org/story/14/09/27/0222222/apple-yet-to-push-patch-for-shellshock-bug">Shellshock in GNU Bash</a>, and a deserialization vulnerability exploited in <a href="https://developers.slashdot.org/story/16/11/29/2242217/muni-system-hacker-hit-others-by-scanning-for-year-old-java-vulnerability">a recent high-profile attack against the San Francisco Municipal Transportation Agency</a>. These are three instances where developers reuse libraries and frameworks that contain unpatched flaws in production applications... According to security experts, the problem is two-fold. On one hand, developers use reliable code that at a later date is found to have a vulnerability. Second, insecure code is used by a developer who doesn't exercise due diligence on the software libraries used in their project.</i> <br>
That seems like a one-sided take, so I'm curious what Slashdot readers think.  Does code reuse endanger secure software development?<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-87982661" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development"
								  data-janrain-title="Does Code Reuse Endanger Secure Software Development?"
								  data-janrain-message="Does Code Reuse Endanger Secure Software Development? @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-87982661" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/bug" target="_blank">bug</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/security" target="_blank">security</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/developers" target="_blank">developers</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//it.slashdot.org/story/16/12/17/1925238/massive-mirai-botnet-hides-its-control-servers-on-tor?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//hardware.slashdot.org/story/16/12/17/1851218/the-un-will-consider-banning-killer-robots?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//it.slashdot.org/story/16/12/17/1925238/massive-mirai-botnet-hides-its-control-servers-on-tor?sdsrc=prev">Massive Mirai Botnet Hides Its Control Servers On Tor </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/08/07/19/146236/reusing-and-recycling-code?sdsrc=rel">Reusing and Recycling Code</a></h3><h3><a href="//it.slashdot.org/story/14/04/11/2056234/nsa-allegedly-exploited-heartbleed?sdsrc=rel">NSA Allegedly Exploited Heartbleed</a></h3><h3><a href="//it.slashdot.org/story/14/05/09/1240238/one-month-later-300000-servers-remain-vulnerable-to-heartbleed?sdsrc=rel">One Month Later: 300,000 Servers Remain Vulnerable To Heartbleed</a></h3><h3><a href="//apple.slashdot.org/story/14/09/27/0222222/apple-yet-to-push-patch-for-shellshock-bug?sdsrc=rel">Apple Yet To Push Patch For "Shellshock" Bug</a></h3><h3><a href="//politics.slashdot.org/story/16/03/14/1246252/obama-administration-supports-recycling-code-and-open-source?sdsrc=rel">Obama Administration Supports Recycling Code and Open Source</a></h3><h3><a href="//news.slashdot.org/story/16/11/27/1819205/ransomware-compromises-san-franciscos-mass-transit-system?sdsrc=rel">Ransomware Compromises San Francisco's Mass Transit System </a></h3><h3><a href="//developers.slashdot.org/story/16/11/29/2242217/muni-system-hacker-hit-others-by-scanning-for-year-old-java-vulnerability?sdsrc=rel">Muni System Hacker Hit Others By Scanning For Year-Old Java Vulnerability</a></h3><h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//it.slashdot.org/submission/6577913/code-reuse-a-peril-for-secure-software-development?sdsrc=rel" href="#">Submission: Code Reuse a Peril for Secure Software Development</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//hardware.slashdot.org/story/16/12/17/1851218/the-un-will-consider-banning-killer-robots?sdsrc=next">The UN Will Consider Banning Killer Robots</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="railad">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development" title="Back to Article - Does Code Reuse Endanger Secure Software Development?">Does Code Reuse Endanger Secure Software Development?</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//it.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Does Code Reuse Endanger Secure Software Development?" href="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development">Does Code Reuse Endanger Secure Software Development?</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//it.slashdot.org/search.pl?op=comments&amp;sid=10008949" class="btn">Search <span class="totalcommentcnt">148</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//it.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//it.slashdot.org/comments.pl?sid=10008949">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//it.slashdot.org/search.pl?op=comments&amp;sid=10008949" class="ui-icon search_comments">Search <span class="totalcommentcnt">148</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//it.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//it.slashdot.org/story/16/12/17/1751234/does-code-reuse-endanger-secure-software-development/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?release_20161213" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_53505583" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505583" class="commentstatus"></div>
<div id="comment_53505583" class="cw">
</div>

<div id="replyto_53505583"></div>

<ul id="group_53505583">
	<li id="hiddens_53505583" class="hide"></li>
</ul>

<ul id="commtree_53505583"><li id="tree_53505653" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505653" class="commentstatus"></div>
<div id="comment_53505653" class="cw">
	<div id="comment_top_53505653" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505653" name="comment_link_53505653" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505653" onclick="return D2.setFocusComment(53505653)" >Re:No.</a>


		 	<span id="comment_score_53505653" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505653); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Doub">Doub</a>  <span class="uid"><a href="//slashdot.org/~Doub">( 784854 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505653">		
		on Saturday December 17, 2016 @07:55PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505653">#53505653</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505653">Don't you think some code that has been run 10 times might be more secure than code that has been run 10 million times? After all it's less worn out.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505653">
<span class="ind"></span><a id="reply_link_53505653" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505653" onclick="D2.replyTo(53505653); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505583" onclick="return D2.selectParent(53505583)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:No. by Doub @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505653" data-title="Re:No.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:No. by Doub" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505653" data-title="Re:No.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:No. by Doub" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505653" data-title="Re:No.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505653" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505653" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505653" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505653"></div>

<ul id="group_53505653">
	<li id="hiddens_53505653" class="hide"></li>
</ul>

<ul id="commtree_53505653"><li id="tree_53505807" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505807" class="commentstatus"></div>
<div id="comment_53505807" class="cw">
	<div id="comment_top_53505807" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505807" name="comment_link_53505807" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505807" onclick="return D2.setFocusComment(53505807)" >Re:</a>


		 	<span id="comment_score_53505807" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505807); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~infernalC">infernalC</a>  <span class="uid"><a href="//slashdot.org/~infernalC">( 51228 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505807"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505807">Geting users to patch quickly to the latest version of your software can be really hard, but if you link to libraries that they are getting automatic security updates to anyway, you're probably in a much better place.

Take, for example, TLS. If I code against Schannel, and Schannel has a bug that causes a serious vulnerability, Microsoft is almost certainly going to update Schannel without changing the interface in a way that will break my code. Same goes for OpenSSL. If I link against OpenSSL and choose t</div>
	</div>

	<div class="commentSub" id="comment_sub_53505807">

</div>
</div>

<div id="replyto_53505807"></div>

<ul id="group_53505807">
	<li id="hiddens_53505807" class="hide"></li>
</ul>

<ul id="commtree_53505807"><li id="tree_53506639" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506639" class="commentstatus"></div>
<div id="comment_53506639" class="cw">
	<div id="comment_top_53506639" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506639" name="comment_link_53506639" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506639" onclick="return D2.setFocusComment(53506639)" >Re:</a>


		 	<span id="comment_score_53506639" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506639); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506639"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506639"><p>Unless you have a package that's statically linked or you attach the old library in your installation to ensure that the tested version of the DLL/so is linked to your code and not something newer.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506639">

</div>
</div>

<div id="replyto_53506639"></div>

<ul id="group_53506639">
	<li id="hiddens_53506639" class="hide"></li>
</ul>

<ul id="commtree_53506639"><li id="tree_53507039" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53507039" class="commentstatus"></div>
<div id="comment_53507039" class="cw">
</div>

<div id="replyto_53507039"></div>

<ul id="group_53507039">
	<li id="hiddens_53507039" class="hide"></li>
</ul>

<ul id="commtree_53507039"><li id="tree_53509135" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509135" class="commentstatus"></div>
<div id="comment_53509135" class="cw">
	<div id="comment_top_53509135" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509135" name="comment_link_53509135" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509135" onclick="return D2.setFocusComment(53509135)" >Re:</a>


		 	<span id="comment_score_53509135" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509135); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Half-pint+HAL">Half-pint HAL</a>  <span class="uid"><a href="//slashdot.org/~Half-pint+HAL">( 718102 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509135"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509135"><p><div class="quote"><p>Yes, but doing that isn't "code reuse". It is copy-pasting code, just that you do it after compilation at the linking stage. It has some advantage to the programmer, but for the binary the end-result is the same.
Copy-paste is NOT what good programmers consider code reuse.</p></div><p>It is code reuse, and to suggest otherwise is a bit baffling. To say it's not best practice is different. It's also ignoring that at least one major software platform doesn't allow dynamic linking except to OS-provided library functions: iOS.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53509135">

</div>
</div>

<div id="replyto_53509135"></div>

<ul id="group_53509135">
	<li id="hiddens_53509135" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="tree_53506083" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506083" class="commentstatus"></div>
<div id="comment_53506083" class="cw">
	<div id="comment_top_53506083" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506083" name="comment_link_53506083" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506083" onclick="return D2.setFocusComment(53506083)" >Re:</a>


		 	<span id="comment_score_53506083" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506083); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Darinbob">Darinbob</a>  <span class="uid"><a href="//slashdot.org/~Darinbob">( 1142669 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506083"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506083"><p>Reuse has to be done *right*.  Most of the people with religious fervour about code reuse do not necessarily do it right.  Doing it right means you must review the code and know what it does, know if it fits into your design, know how to fix it when it breaks (and it will), and so forth.  Cutting and pasting is dangerous.  For a larger piece of code you want long term support that is stable without a constantly changing API, but do not expect to actually get support unless you're a giant company.  I see so<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506083">

</div>
</div>

<div id="replyto_53506083"></div>

<ul id="group_53506083">
	<li id="hiddens_53506083" class="hide"></li>
</ul>

</li><li id="tree_53507507" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507507" class="commentstatus"></div>
<div id="comment_53507507" class="cw">
	<div id="comment_top_53507507" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507507" name="comment_link_53507507" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507507" onclick="return D2.setFocusComment(53507507)" >Re:No... but....</a>


		 	<span id="comment_score_53507507" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507507); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jafiwam">jafiwam</a>  <span class="uid"><a href="//slashdot.org/~jafiwam">( 310805 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507507"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507507"><p><div class="quote"><p>Glad we got that resolved.</p></div><p>But it WILL give democrats an excuse to say they were hacked by Russians.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507507">

</div>
</div>

<div id="replyto_53507507"></div>

<ul id="group_53507507">
	<li id="hiddens_53507507" class="hide"></li>
</ul>

</li><li id="tree_53508913" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53508913" class="commentstatus"></div>
<div id="comment_53508913" class="cw">
	<div id="comment_top_53508913" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53508913" name="comment_link_53508913" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53508913" onclick="return D2.setFocusComment(53508913)" >No, and here's one reason why</a>


		 	<span id="comment_score_53508913" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53508913); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~davecb">davecb</a>  <span class="uid"><a href="//slashdot.org/~davecb">( 6526 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53508913"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53508913">In a previous life (several, in fact), we followed the "write once" rule. If you needed a queue, you looked to see if there was one, made sure it did what you wanted, and used it. If it didn't, you filed a bug and a patch, <i>then</i> you used it.  Reuse tended to cause code review, at least enough to make sure it wasn't going to fail in the new use, and additional testing.  As a result, the quality slowly increased with each additional use.</div>
	</div>

	<div class="commentSub" id="comment_sub_53508913">

</div>
</div>

<div id="replyto_53508913"></div>

<ul id="group_53508913">
	<li id="hiddens_53508913" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505589" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505589" class="commentstatus"></div>
<div id="comment_53505589" class="cw">
	<div id="comment_top_53505589" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505589" name="comment_link_53505589" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505589" onclick="return D2.setFocusComment(53505589)" >On the balance, most likely not.</a>


		 	<span id="comment_score_53505589" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505589); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Place+a+name+here">Place a name here</a>  <span class="uid"><a href="//slashdot.org/~Place+a+name+here">( 4508093 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505589">		
		on Saturday December 17, 2016 @07:41PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505589">#53505589</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505589">If you use a third-party library that has a bug in it, you'll be exposed to the same bugs that everybody else using that library are. On the other hand, if you go at it alone, your implementation will have bugs of its own. And if the library is well-maintained, it'll have fewer bugs than the thing you make from scratch.<br> <br>

Implementing the common functionality from scratch can easily become another kind of "not exercising due diligence", particularly when dealing with complex code. Or to put it another way: code reuse may endanger secure software development, but not reusing code may also endanger secure software development.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505589">
<span class="ind"></span><a id="reply_link_53505589" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505589" onclick="D2.replyTo(53505589); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="On the balance, most likely not. by Place a name here @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505589" data-title="On the balance, most likely not.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="On the balance, most likely not. by Place a name here" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505589" data-title="On the balance, most likely not.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="On the balance, most likely not. by Place a name here" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505589" data-title="On the balance, most likely not.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505589" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505589" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505589" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505589"></div>

<ul id="group_53505589">
	<li id="hiddens_53505589" class="hide"></li>
</ul>

<ul id="commtree_53505589"><li id="tree_53505613" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505613" class="commentstatus"></div>
<div id="comment_53505613" class="cw">
</div>

<div id="replyto_53505613"></div>

<ul id="group_53505613">
	<li id="hiddens_53505613" class="hide"></li>
</ul>

<ul id="commtree_53505613"><li id="tree_53505657" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505657" class="commentstatus"></div>
<div id="comment_53505657" class="cw">
	<div id="comment_top_53505657" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505657" name="comment_link_53505657" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505657" onclick="return D2.setFocusComment(53505657)" >Re:</a>


		 	<span id="comment_score_53505657" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505657); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505657"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505657">Hardly impossible especially if you avoid C and limit yourself to some useful subset of functionality, for example. Whether it's worth the hassle is another question.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505657">

</div>
</div>

<div id="replyto_53505657"></div>

<ul id="group_53505657">
	<li id="hiddens_53505657" class="hide"></li>
</ul>

<ul id="commtree_53505657"><li id="tree_53505853" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505853" class="commentstatus"></div>
<div id="comment_53505853" class="cw">
	<div id="comment_top_53505853" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505853" name="comment_link_53505853" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505853" onclick="return D2.setFocusComment(53505853)" >Re:</a>


		 	<span id="comment_score_53505853" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505853); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Narcocide">Narcocide</a>  <span class="uid"><a href="//slashdot.org/~Narcocide">( 102829 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505853"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505853"><p>You're like one of those people who thinks Java was written with more Java and its just Java all the way down, aren't you?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505853">

</div>
</div>

<div id="replyto_53505853"></div>

<ul id="group_53505853">
	<li id="hiddens_53505853" class="hide"></li>
</ul>

<ul id="commtree_53505853"><li id="tree_53506155" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506155" class="commentstatus"></div>
<div id="comment_53506155" class="cw">
	<div id="comment_top_53506155" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506155" name="comment_link_53506155" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506155" onclick="return D2.setFocusComment(53506155)" >Re:</a>


		 	<span id="comment_score_53506155" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506155); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506155"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506155">Some implementations were indeed designed like that. If Java is what you want...</div>
	</div>

	<div class="commentSub" id="comment_sub_53506155">

</div>
</div>

<div id="replyto_53506155"></div>

<ul id="group_53506155">
	<li id="hiddens_53506155" class="hide"></li>
</ul>

</li><li id="tree_53507059" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53507059" class="commentstatus"></div>
<div id="comment_53507059" class="cw">
</div>

<div id="replyto_53507059"></div>

<ul id="group_53507059">
	<li id="hiddens_53507059" class="hide"></li>
</ul>

<ul id="commtree_53507059"><li id="tree_53508283" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53508283" class="commentstatus"></div>
<div id="comment_53508283" class="cw">
</div>

<div id="replyto_53508283"></div>

<ul id="group_53508283">
	<li id="hiddens_53508283" class="hide"></li>
</ul>

<ul id="commtree_53508283"><li id="tree_53509435" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509435" class="commentstatus"></div>
<div id="comment_53509435" class="cw">
	<div id="comment_top_53509435" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509435" name="comment_link_53509435" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509435" onclick="return D2.setFocusComment(53509435)" >Re:</a>


		 	<span id="comment_score_53509435" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509435); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509435"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509435"><p><div class="quote"><p>Ah, but C was written that way.</p></div><p>So was Jikes RVM, Squeak, all Oberons, half of Lisps...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53509435">

</div>
</div>

<div id="replyto_53509435"></div>

<ul id="group_53509435">
	<li id="hiddens_53509435" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_53506145" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53506145" class="commentstatus"></div>
<div id="comment_53506145" class="cw">
	<div id="comment_top_53506145" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506145" name="comment_link_53506145" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506145" onclick="return D2.setFocusComment(53506145)" >Re:uh, no</a>


		 	<span id="comment_score_53506145" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506145); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rholtzjr">rholtzjr</a>  <span class="uid"><a href="//slashdot.org/~rholtzjr">( 928771 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506145">		
		on Saturday December 17, 2016 @10:57PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506145">#53506145</a>)
		<small><a href="//slashdot.org/~rholtzjr/journal/" title="Sunday October 26, 2014 @03:04AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506145">How about avoid C common mistakes instead of avoid C would be a better statement.  C done right is a solid language to use depending on the project.</div>
	</div>

	<div class="commentSub" id="comment_sub_53506145">
<span class="ind"></span><a id="reply_link_53506145" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506145" onclick="D2.replyTo(53506145); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505657" onclick="return D2.selectParent(53505657)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:uh, no by rholtzjr @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506145" data-title="Re:uh, no">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:uh, no by rholtzjr" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506145" data-title="Re:uh, no">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:uh, no by rholtzjr" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506145" data-title="Re:uh, no">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53506145" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53506145" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506145" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53506145"></div>

<ul id="group_53506145">
	<li id="hiddens_53506145" class="hide"></li>
</ul>

<ul id="commtree_53506145"><li id="tree_53506157" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506157" class="commentstatus"></div>
<div id="comment_53506157" class="cw">
	<div id="comment_top_53506157" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506157" name="comment_link_53506157" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506157" onclick="return D2.setFocusComment(53506157)" >Re:</a>


		 	<span id="comment_score_53506157" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506157); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506157"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506157">It's great on microcontrollers!</div>
	</div>

	<div class="commentSub" id="comment_sub_53506157">

</div>
</div>

<div id="replyto_53506157"></div>

<ul id="group_53506157">
	<li id="hiddens_53506157" class="hide"></li>
</ul>

<ul id="commtree_53506157"><li id="tree_53506213" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53506213" class="commentstatus"></div>
<div id="comment_53506213" class="cw">
</div>

<div id="replyto_53506213"></div>

<ul id="group_53506213">
	<li id="hiddens_53506213" class="hide"></li>
</ul>

<ul id="commtree_53506213"><li id="tree_53506257" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506257" class="commentstatus"></div>
<div id="comment_53506257" class="cw">
	<div id="comment_top_53506257" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506257" name="comment_link_53506257" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506257" onclick="return D2.setFocusComment(53506257)" >Re:</a>


		 	<span id="comment_score_53506257" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506257); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506257"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506257">How is assembly bad, for that matter?</div>
	</div>

	<div class="commentSub" id="comment_sub_53506257">

</div>
</div>

<div id="replyto_53506257"></div>

<ul id="group_53506257">
	<li id="hiddens_53506257" class="hide"></li>
</ul>

<ul id="commtree_53506257"><li id="tree_53506279" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506279" class="commentstatus"></div>
<div id="comment_53506279" class="cw">
	<div id="comment_top_53506279" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506279" name="comment_link_53506279" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506279" onclick="return D2.setFocusComment(53506279)" >Re:</a>


		 	<span id="comment_score_53506279" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506279); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~meerling">meerling</a>  <span class="uid"><a href="//slashdot.org/~meerling">( 1487879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506279"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506279">assembly is a low level language, and as such there are fewer people that can program in it, and it tends to take more resources to write anything. (Yes, time is a resource, especially if there are bean counters or marketing weasels around)<br><span class="substr"> </span> <br>Of course, like anything else, it has both advantages and disadvantages. The advantages of Assembly is the compiled code, if written well, is smaller and faster than other code that does the same thing. The disadvantage, less programmers available, harder to understand, t</div>
	</div>

	<div class="commentSub" id="comment_sub_53506279">

</div>
</div>

<div id="replyto_53506279"></div>

<ul id="group_53506279">
	<li id="hiddens_53506279" class="hide"></li>
</ul>

<ul id="commtree_53506279"><li id="tree_53506649" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506649" class="commentstatus"></div>
<div id="comment_53506649" class="cw">
	<div id="comment_top_53506649" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506649" name="comment_link_53506649" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506649" onclick="return D2.setFocusComment(53506649)" >Re:</a>


		 	<span id="comment_score_53506649" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506649); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~darkain">darkain</a>  <span class="uid"><a href="//slashdot.org/~darkain">( 749283 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506649"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506649"><p>You forgot the other major advantage of ASM code. Access to instructions other than basic logical program flow instructions, such as instructions for manipulating hardware or accessing memory mapped devices. One of my favorite things about writing a micro-kernel for an ARM platform over a decade ago was being able to drop in some inline ASM code into C/C++ libraries and manipulate the CPU in ways otherwise not possible, such as tweaking how instruction and data cache worked.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506649">

</div>
</div>

<div id="replyto_53506649"></div>

<ul id="group_53506649">
	<li id="hiddens_53506649" class="hide"></li>
</ul>

<ul id="commtree_53506649"><li id="tree_53509499" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509499" class="commentstatus"></div>
<div id="comment_53509499" class="cw">
	<div id="comment_top_53509499" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509499" name="comment_link_53509499" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509499" onclick="return D2.setFocusComment(53509499)" >Re:</a>


		 	<span id="comment_score_53509499" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509499); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509499"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509499">You don't technically need assembly for this. <a href="https://github.com/sbcl/sbcl/blob/master/contrib/sb-rotate-byte/x86-64-vm.lisp" title="github.com">Extensible compilers</a> [github.com] with <a href="https://github.com/sbcl/sbcl/blob/master/contrib/sb-rotate-byte/compiler.lisp" title="github.com">programmer-defined transformation rules</a> [github.com] can generate any instructions you want, including special-casing normal code for the use of such instructions when these are available and applicable.</div>
	</div>

	<div class="commentSub" id="comment_sub_53509499">

</div>
</div>

<div id="replyto_53509499"></div>

<ul id="group_53509499">
	<li id="hiddens_53509499" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506911" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506911" class="commentstatus"></div>
<div id="comment_53506911" class="cw">
	<div id="comment_top_53506911" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506911" name="comment_link_53506911" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506911" onclick="return D2.setFocusComment(53506911)" >Re:</a>


		 	<span id="comment_score_53506911" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506911); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Anne+Thwacks">Anne Thwacks</a>  <span class="uid"><a href="//slashdot.org/~Anne+Thwacks">( 531696 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506911"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506911"><i> bean counters or marketing weasels </i> <p>
- hah - these are the <b>real</b> source of insecurity!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506911">

</div>
</div>

<div id="replyto_53506911"></div>

<ul id="group_53506911">
	<li id="hiddens_53506911" class="hide"></li>
</ul>

<ul id="commtree_53506911"><li id="tree_53507665" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507665" class="commentstatus"></div>
<div id="comment_53507665" class="cw">
	<div id="comment_top_53507665" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507665" name="comment_link_53507665" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507665" onclick="return D2.setFocusComment(53507665)" >Re:</a>


		 	<span id="comment_score_53507665" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507665); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ol+Olsoc">Ol Olsoc</a>  <span class="uid"><a href="//slashdot.org/~Ol+Olsoc">( 1175323 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507665"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507665"><p><div class="quote"><p> <i> bean counters or marketing weasels </i> </p><p>
- hah - these are the <b>real</b> source of insecurity!</p></div><p>This truth is sitting here at only +2?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507665">

</div>
</div>

<div id="replyto_53507665"></div>

<ul id="group_53507665">
	<li id="hiddens_53507665" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53509417" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509417" class="commentstatus"></div>
<div id="comment_53509417" class="cw">
	<div id="comment_top_53509417" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509417" name="comment_link_53509417" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509417" onclick="return D2.setFocusComment(53509417)" >Re:</a>


		 	<span id="comment_score_53509417" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509417); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509417"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509417"><p><div class="quote"><p>assembly is a low level language, and as such there are fewer people that can program in it, and it tends to take more resources to write anything.</p> </div><p>So is C, compared to such things as Go or D, for example.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53509417">

</div>
</div>

<div id="replyto_53509417"></div>

<ul id="group_53509417">
	<li id="hiddens_53509417" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53506647" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506647" class="commentstatus"></div>
<div id="comment_53506647" class="cw">
	<div id="comment_top_53506647" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506647" name="comment_link_53506647" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506647" onclick="return D2.setFocusComment(53506647)" >Re:</a>


		 	<span id="comment_score_53506647" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506647); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506647"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506647"><p>Depends on the case - a language with built-in bounds checking is less prone to buffer overflow issues than C, but it may be cumbersome to do some stuff that's easy in C.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506647">

</div>
</div>

<div id="replyto_53506647"></div>

<ul id="group_53506647">
	<li id="hiddens_53506647" class="hide"></li>
</ul>

</li><li id="tree_53508403" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53508403" class="commentstatus"></div>
<div id="comment_53508403" class="cw">
	<div id="comment_top_53508403" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53508403" name="comment_link_53508403" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53508403" onclick="return D2.setFocusComment(53508403)" >Re:</a>


		 	<span id="comment_score_53508403" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53508403); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mollymoo">mollymoo</a>  <span class="uid"><a href="//slashdot.org/~mollymoo">( 202721 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53508403"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53508403">The "if used correctly" bit is the problem. People aren't perfect. Even the really good, really experienced, really careful ones make mistakes. It's easier to avoid certain kinds of mistakes in other languages than in C.

You can, of course, write perfect, secure code in C. You can do the same programming machine code using toggle switches too. It's just harder and takes more effort, which makes it more difficult to avoid mistakes.</div>
	</div>

	<div class="commentSub" id="comment_sub_53508403">

</div>
</div>

<div id="replyto_53508403"></div>

<ul id="group_53508403">
	<li id="hiddens_53508403" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_53506551" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53506551" class="commentstatus"></div>
<div id="comment_53506551" class="cw">
	<div id="comment_top_53506551" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506551" name="comment_link_53506551" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506551" onclick="return D2.setFocusComment(53506551)" >Re:uh, no</a>


		 	<span id="comment_score_53506551" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506551); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ewanm89">ewanm89</a>  <span class="uid"><a href="//slashdot.org/~ewanm89">( 1052822 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506551">		
		on Sunday December 18, 2016 @01:06AM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506551">#53506551</a>)
		<small><a href="http://ewanm89.co.uk/" title="http://ewanm89.co.uk/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506551"><p>I suppose you know how timing side channel attacks are done?  All those layers of abstraction make it possible to accurately predict and alter code path length? Oh, and they do automatically handle things like proper memory scrubbing of keys when no-longer valid? Right?</p><p>These things need low level hardware access to manage, and are hard even then where there is less in the way screwing with it. It is nearly impossible to handle properly on highly abstracted languages running in managed virtual environments like Java and C#.</p><p>Yes those abstractions help avoid specific classes of vulnerabilities, but can open a whole host of just as bad context specific ones when talking about security stuff like encryption. This is why we should only let specialists in that specific field do such implementations and have them vet each others code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506551">
<span class="ind"></span><a id="reply_link_53506551" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506551" onclick="D2.replyTo(53506551); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505657" onclick="return D2.selectParent(53505657)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:uh, no by ewanm89 @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506551" data-title="Re:uh, no">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:uh, no by ewanm89" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506551" data-title="Re:uh, no">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:uh, no by ewanm89" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506551" data-title="Re:uh, no">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53506551" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53506551" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506551" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53506551"></div>

<ul id="group_53506551">
	<li id="hiddens_53506551" class="hide"></li>
</ul>

<ul id="commtree_53506551"><li id="tree_53509411" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509411" class="commentstatus"></div>
<div id="comment_53509411" class="cw">
	<div id="comment_top_53509411" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509411" name="comment_link_53509411" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509411" onclick="return D2.setFocusComment(53509411)" >Re:</a>


		 	<span id="comment_score_53509411" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509411); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509411"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509411">Yes, that may be a problem (in certain environments). But such side channels are not solely due to the "highly abstracted languages". If I'm not mistaken, you often get side channels because of highly abstracted hardware as well. As far as such things as scrubbing keys etc. are involved, well, you're facing similar problems as with managing other resources. The abstractions often help, like C++ destructors, Lisp's UNWIND-PROTECT, or whatever other feature your language of choice gives you for managing these</div>
	</div>

	<div class="commentSub" id="comment_sub_53509411">

</div>
</div>

<div id="replyto_53509411"></div>

<ul id="group_53509411">
	<li id="hiddens_53509411" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53505769" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505769" class="commentstatus"></div>
<div id="comment_53505769" class="cw">
	<div id="comment_top_53505769" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505769" name="comment_link_53505769" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505769" onclick="return D2.setFocusComment(53505769)" >Re:</a>


		 	<span id="comment_score_53505769" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505769); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BarbaraHudson">BarbaraHudson</a>  <span class="uid"><a href="//slashdot.org/~BarbaraHudson">( 3785311 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505769"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505769"><p><div class="quote"><p>Because you could certainly code up a more secure implementation of SSL yourself. That's probably the funniest thing I've seen on slashsot, ever.</p></div><p>It will be the most secure implementation of SSL ever. It won't work, and terminate whatever process is trying to use it. Same as if he builds an airplane, it will be super safe because it will never get off the ground<nobr> <wbr></nobr>:-)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505769">

</div>
</div>

<div id="replyto_53505769"></div>

<ul id="group_53505769">
	<li id="hiddens_53505769" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505633" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505633" class="commentstatus"></div>
<div id="comment_53505633" class="cw">
	<div id="comment_top_53505633" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505633" name="comment_link_53505633" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505633" onclick="return D2.setFocusComment(53505633)" >Re:On the balance, most likely not.</a>


		 	<span id="comment_score_53505633" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505633); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~beelsebob">beelsebob</a>  <span class="uid"><a href="//slashdot.org/~beelsebob">( 529313 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505633">		
		on Saturday December 17, 2016 @07:50PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505633">#53505633</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505633"><p>The issue isn't even "using 3rd party code", it's "static linking 3rd party code".  If people learned to dynamic link libraries, rather than compile them in, then this wouldn't be a problem at all.  If the OpenSSL guys learned that distributing only as a static library is a bad thing, and learned to make their ABI stable, then heart bleed would be a lot less of an issue.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505633">
<span class="ind"></span><a id="reply_link_53505633" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505633" onclick="D2.replyTo(53505633); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505589" onclick="return D2.selectParent(53505589)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:On the balance, most likely not. by beelsebob @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505633" data-title="Re:On the balance, most likely not.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:On the balance, most likely not. by beelsebob" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505633" data-title="Re:On the balance, most likely not.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:On the balance, most likely not. by beelsebob" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505633" data-title="Re:On the balance, most likely not.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505633" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505633" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505633" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505633"></div>

<ul id="group_53505633">
	<li id="hiddens_53505633" class="hide"></li>
</ul>

<ul id="commtree_53505633"><li id="tree_53505673" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505673" class="commentstatus"></div>
<div id="comment_53505673" class="cw">
</div>

<div id="replyto_53505673"></div>

<ul id="group_53505673">
	<li id="hiddens_53505673" class="hide"></li>
</ul>

<ul id="commtree_53505673"><li id="tree_53505821" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505821" class="commentstatus"></div>
<div id="comment_53505821" class="cw">
	<div id="comment_top_53505821" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505821" name="comment_link_53505821" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505821" onclick="return D2.setFocusComment(53505821)" >Re:</a>


		 	<span id="comment_score_53505821" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505821); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Narcocide">Narcocide</a>  <span class="uid"><a href="//slashdot.org/~Narcocide">( 102829 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505821"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505821"><p>He's most likely confusing some or another sysadmin or distro maintainer's transient mistake or error in judgement for an officially sanctioned action by the OpenSSL maintainers themselves.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505821">

</div>
</div>

<div id="replyto_53505821"></div>

<ul id="group_53505821">
	<li id="hiddens_53505821" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506087" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506087" class="commentstatus"></div>
<div id="comment_53506087" class="cw">
	<div id="comment_top_53506087" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506087" name="comment_link_53506087" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506087" onclick="return D2.setFocusComment(53506087)" >Re:</a>


		 	<span id="comment_score_53506087" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506087); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Darinbob">Darinbob</a>  <span class="uid"><a href="//slashdot.org/~Darinbob">( 1142669 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506087"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506087"><p>Many environments you can't dynamically link.  Small embedded systems for instance.  Library makers MUST make APIs and ABIs stable, because the difficulty of adapting to changing libraries means that projects will be slow to update to newer versions.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506087">

</div>
</div>

<div id="replyto_53506087"></div>

<ul id="group_53506087">
	<li id="hiddens_53506087" class="hide"></li>
</ul>

<ul id="commtree_53506087"><li id="tree_53506659" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506659" class="commentstatus"></div>
<div id="comment_53506659" class="cw">
	<div id="comment_top_53506659" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506659" name="comment_link_53506659" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506659" onclick="return D2.setFocusComment(53506659)" >Re:</a>


		 	<span id="comment_score_53506659" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506659); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506659"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506659"><p>A lot of small home routers falls into this category. Whenever you look at them they are usually built on a very old kernel with busybox and some quickly thrown together web interface with questionable security.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506659">

</div>
</div>

<div id="replyto_53506659"></div>

<ul id="group_53506659">
	<li id="hiddens_53506659" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_53505633"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53505633">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53507167" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507167" class="commentstatus"></div>
<div id="comment_53507167" class="cw">
	<div id="comment_top_53507167" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507167" name="comment_link_53507167" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507167" onclick="return D2.setFocusComment(53507167)" >Re:</a>


		 	<span id="comment_score_53507167" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507167); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kjella">Kjella</a>  <span class="uid"><a href="//slashdot.org/~Kjella">( 173770 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507167"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507167"><p><div class="quote"><p>If you use a third-party library that has a bug in it, you'll be exposed to the same bugs that everybody else using that library are. On the other hand, if you go at it alone, your implementation will have bugs of its own.</p></div><p>But the value of the target will be proportional too, the value of compromising "every server using OpenSSL" is huge compared to a custom hack that only works for your little company because of your home grown library. It's no doubt that the main reason you use libraries is because of resource constraints, not security. If you're small enough to not matter, spending a man year re-implementing what's already done is a no-go. If you have the resources to seriously consider going it alone you're probably big e<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507167">

</div>
</div>

<div id="replyto_53507167"></div>

<ul id="group_53507167">
	<li id="hiddens_53507167" class="hide"></li>
</ul>

</li><li id="hidestring_53505589"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53505589">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53505599" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505599" class="commentstatus"></div>
<div id="comment_53505599" class="cw">
	<div id="comment_top_53505599" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505599" name="comment_link_53505599" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505599" onclick="return D2.setFocusComment(53505599)" >The problem is often maintenance</a>


		 	<span id="comment_score_53505599" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505599); return false"><span class=opt>Score:</span>4</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~guruevi">guruevi</a>  <span class="uid"><a href="//slashdot.org/~guruevi">( 827432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505599">		 &lt;<a href="mailto:evi.smokingcube%40be">evi.smokingcube@be</a>&gt;
		on Saturday December 17, 2016 @07:43PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505599">#53505599</a>)
		<small><a href="http://pandorafms.org/" title="http://pandorafms.org/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505599"><p>Most people just install software like they would a washing machine, once it's in, they don't touch it anymore except to run it, after all, a washing machine has a strong motor, some controls, valves and a belt, there is virtually no maintenance necessary and if it ever does, it's cheap enough and long-lasting enough you can just throw it out and replace it.</p><p>Maintenance is a necessary part of anything that is a very complex machine and is not protected. A car is a good example, it sits outside so it needs to be protected against burglary but also against the elements, salt and accidents as well as regular maintenance to replace worn and outdated parts.</p><p>Computer systems are as complex and vulnerable as cars, they sit 'outside' on the Internet, where they have to be protected against 'bad people' and just regular outdatedness but often they are considered as dumb appliances (if not actually called that by a vendor).</p><p>People need to pay more attention and fund their "computer-mechanics", not just the manufacturers of their "car" and demand that they are able to inspect and repair their own stuff regardless of who invented it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505599">
<span class="ind"></span><a id="reply_link_53505599" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505599" onclick="D2.replyTo(53505599); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="The problem is often maintenance by guruevi @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505599" data-title="The problem is often maintenance">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="The problem is often maintenance by guruevi" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505599" data-title="The problem is often maintenance">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="The problem is often maintenance by guruevi" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505599" data-title="The problem is often maintenance">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505599" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505599" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505599" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505599"></div>

<ul id="group_53505599">
	<li id="hiddens_53505599" class="hide"></li>
</ul>

<ul id="commtree_53505599"><li id="tree_53505647" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505647" class="commentstatus"></div>
<div id="comment_53505647" class="cw">
	<div id="comment_top_53505647" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505647" name="comment_link_53505647" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505647" onclick="return D2.setFocusComment(53505647)" >Re:The problem is often maintenance</a>


		 	<span id="comment_score_53505647" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505647); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~murdocj">murdocj</a>  <span class="uid"><a href="//slashdot.org/~murdocj">( 543661 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505647">		
		on Saturday December 17, 2016 @07:54PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505647">#53505647</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505647"><p>The problem is that if software is working, and you "upgrade" it, two things can happen: it can continue to work, or it can fail, often mysteriously.  Given that, it's not shocking that people tend to leave software alone if it is currently functioning.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505647">
<span class="ind"></span><a id="reply_link_53505647" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505647" onclick="D2.replyTo(53505647); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505599" onclick="return D2.selectParent(53505599)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:The problem is often maintenance by murdocj @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505647" data-title="Re:The problem is often maintenance">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:The problem is often maintenance by murdocj" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505647" data-title="Re:The problem is often maintenance">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:The problem is often maintenance by murdocj" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505647" data-title="Re:The problem is often maintenance">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505647" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505647" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505647" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505647"></div>

<ul id="group_53505647">
	<li id="hiddens_53505647" class="hide"></li>
</ul>

<ul id="commtree_53505647"><li id="tree_53505855" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505855" class="commentstatus"></div>
<div id="comment_53505855" class="cw">
	<div id="comment_top_53505855" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505855" name="comment_link_53505855" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505855" onclick="return D2.setFocusComment(53505855)" >Re:</a>


		 	<span id="comment_score_53505855" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505855); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~guruevi">guruevi</a>  <span class="uid"><a href="//slashdot.org/~guruevi">( 827432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505855"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505855"><p>Same goes for a car, you can try fixing it yourself and often you end up with a problem that your car doesn't start 'mysteriously' because you left the spark plugs out or something stupid like that. Even mechanics at garages have this problem, although less often and are able to fix it quicker.</p><p>If you absolutely need a car when it needs fixing, rent one or get a second one and don't try to fix it yourself if you don't know what you're doing. Would you leave your car without an oil change just because you can<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505855">

</div>
</div>

<div id="replyto_53505855"></div>

<ul id="group_53505855">
	<li id="hiddens_53505855" class="hide"></li>
</ul>

<ul id="commtree_53505855"><li id="tree_53506925" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506925" class="commentstatus"></div>
<div id="comment_53506925" class="cw">
	<div id="comment_top_53506925" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506925" name="comment_link_53506925" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506925" onclick="return D2.setFocusComment(53506925)" >Re:</a>


		 	<span id="comment_score_53506925" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506925); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Anne+Thwacks">Anne Thwacks</a>  <span class="uid"><a href="//slashdot.org/~Anne+Thwacks">( 531696 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506925"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506925"><i>Same goes for a car, you can try fixing it yourself and often you end up with a problem that your car doesn't start 'mysteriously' because you left the spark plugs out or something stupid like that.</i> <p>

Speak for yourself. If I service my car, I know what I need to do, and I find out what is likely to be needed in the near future. If the dealer services the car, I find out which jobs are easiest and/or most profitable. Why would I leave my car with a mechanic for an oil change when I can do it myself in less<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506925">

</div>
</div>

<div id="replyto_53506925"></div>

<ul id="group_53506925">
	<li id="hiddens_53506925" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53507743" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507743" class="commentstatus"></div>
<div id="comment_53507743" class="cw">
	<div id="comment_top_53507743" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507743" name="comment_link_53507743" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507743" onclick="return D2.setFocusComment(53507743)" >Re:</a>


		 	<span id="comment_score_53507743" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507743); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ol+Olsoc">Ol Olsoc</a>  <span class="uid"><a href="//slashdot.org/~Ol+Olsoc">( 1175323 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507743"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507743"><p><div class="quote"><p>The problem is that if software is working, and you "upgrade" it, two things can happen: it can continue to work, or it can fail, often mysteriously.  Given that, it's not shocking that people tend to leave software alone if it is currently functioning.</p></div><p>This! It is a huge issue for both vendors, writers, and users.  One OS vendor with a track record of updates breaking systems that led to many people refusing to update recently went no choice on us.  With predictable bad results, which just reinforces the idea of not updating if it works. </p><p>

I did a data transfer on a computer a couple years ago that had a never updated Windows XP OS on it. It was in use every day, and it was not updated once. Not the OS, not the Flash, not the browser,  nothing. What broug<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507743">

</div>
</div>

<div id="replyto_53507743"></div>

<ul id="group_53507743">
	<li id="hiddens_53507743" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506021" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53506021" class="commentstatus"></div>
<div id="comment_53506021" class="cw">
	<div id="comment_top_53506021" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506021" name="comment_link_53506021" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506021" onclick="return D2.setFocusComment(53506021)" >Re:The problem is often maintenance</a>


		 	<span id="comment_score_53506021" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506021); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nmb3000">nmb3000</a>  <span class="uid"><a href="//slashdot.org/~nmb3000">( 741169 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506021">		 &lt;<a href="mailto:nmb3000%40that-google-mail-site.com">nmb3000@that-google-mail-site.com</a>&gt;
		on Saturday December 17, 2016 @10:18PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506021">#53506021</a>)
		<small><a href="//slashdot.org/~nmb3000/journal/" title="Thursday October 22, 2009 @08:22PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506021"><p>Disagree.  Software is not a washing machine nor a car.  It does not break down over time, it is not susceptible to the elements, and it does not age in any notable way.  There is literally no reason a program written and working in 1970 cannot continue to execute as well today as the day it was written.  And it does!  Industrial control systems, ancient government and finance mainframes, and primitive vehicle control systems all do it every day.  Software doesn't rust and bit-rot is not a thing.  Telling people that they need to keep their programs polished to prevent tarnish sounds like something a sketchy Geek Squad-esque computer shop might do to squeeze a hundred bucks out naive customers.</p><p>I update my software sparingly and with caution.  Generally speaking, it's much more likely that usability to be lost or features broken than a serious security issue fixed.  If it's a mobile app, it's much more likely that ads were added or made worse, or a feature I've used for 2 years was removed or horribly changed, or increased permissions are requested so that my personal info can be sent away to some third party than any features I actually want were added or bugs fixed.</p><p>Today's model of always-updated has some advantages but every single one is counterbalanced by the negatives.  Auto-updating browsers help prevent the mire of zombies that was IE6, but it also means you're at the mercy of Microsoft, Mozilla, and Google when it comes to feature removal and their incessant need to screw around with the UI for no valid reason.  Or that addon you really like and rely on suddenly stopped working because the author hasn't updated it yet.</p><p>Yes, updates to address security problems is an important topic, but all too often those updates are bundled up with all sorts of crap that few people want.  It would be real nice if software companies would keep the two separate, and make it clear just what has changed between versions.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506021">
<span class="ind"></span><a id="reply_link_53506021" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506021" onclick="D2.replyTo(53506021); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505599" onclick="return D2.selectParent(53505599)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:The problem is often maintenance by nmb3000 @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506021" data-title="Re:The problem is often maintenance">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:The problem is often maintenance by nmb3000" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506021" data-title="Re:The problem is often maintenance">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:The problem is often maintenance by nmb3000" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506021" data-title="Re:The problem is often maintenance">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53506021" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53506021" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506021" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53506021"></div>

<ul id="group_53506021">
	<li id="hiddens_53506021" class="hide"></li>
</ul>

<ul id="commtree_53506021"><li id="tree_53506147" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506147" class="commentstatus"></div>
<div id="comment_53506147" class="cw">
	<div id="comment_top_53506147" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506147" name="comment_link_53506147" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506147" onclick="return D2.setFocusComment(53506147)" >Re:</a>


		 	<span id="comment_score_53506147" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506147); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~guruevi">guruevi</a>  <span class="uid"><a href="//slashdot.org/~guruevi">( 827432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506147"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506147"><p>This doesn't mean that software updates aren't necessary.</p><p>Your mainframe software is probably rife with bugs and issues and would be very insecure if it were connected to the Internet in the same way it was in the 1970's. Back then, we "knew" the person (often by name) who was responsible simply based on IP address and thus vandalism/criminal intent wasn't as much as an issue. The bits don't age indeed but the methods, underlying hardware platforms and security models behind it do.</p><p>The only reason we have cod<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506147">

</div>
</div>

<div id="replyto_53506147"></div>

<ul id="group_53506147">
	<li id="hiddens_53506147" class="hide"></li>
</ul>

<ul id="commtree_53506147"><li id="tree_53507765" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507765" class="commentstatus"></div>
<div id="comment_53507765" class="cw">
	<div id="comment_top_53507765" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507765" name="comment_link_53507765" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507765" onclick="return D2.setFocusComment(53507765)" >Re:</a>


		 	<span id="comment_score_53507765" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507765); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ol+Olsoc">Ol Olsoc</a>  <span class="uid"><a href="//slashdot.org/~Ol+Olsoc">( 1175323 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507765"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507765"><p><div class="quote"><p>This doesn't mean that software updates aren't necessary.</p><p>Your mainframe software is probably rife with bugs and issues and would be very insecure if it were connected to the Internet in the same way it was in the 1970's. </p></div><p>Ahh, the 1970's internet. Those were good times, were they not?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507765">

</div>
</div>

<div id="replyto_53507765"></div>

<ul id="group_53507765">
	<li id="hiddens_53507765" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506197" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53506197" class="commentstatus"></div>
<div id="comment_53506197" class="cw">
	<div id="comment_top_53506197" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506197" name="comment_link_53506197" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506197" onclick="return D2.setFocusComment(53506197)" >Re:The problem is often maintenance</a>


		 	<span id="comment_score_53506197" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506197); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dutch+Gun">Dutch Gun</a>  <span class="uid"><a href="//slashdot.org/~Dutch+Gun">( 899105 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506197">		
		on Saturday December 17, 2016 @11:11PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506197">#53506197</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506197"><p>I want to agree with you in theory (especially about how apps often get made worse for no good reason), but practice, it's simply not practical to leave most software alone - at least, not if you want it to have any sort of reasonable lifetime.  The difference is that modern software rarely lives in isolation.  The ecosystem on which it runs... the OS, it's system libraries, third party libraries, the tools on which the software was developed... these are all moving forward in time.</p><p>If you leave a piece of software alone, it experiences "bit rot" NOT because it's changing, but because everything around it is probably changing.  More importantly, the more time occurs between updates, the more difficult those updates tend to be, until it becomes easier to actually rewrite the damned thing, since the original development system on which it was written may not even exist in the same state anymore.  You may argue that software shouldn't always be changing, but you might as well ask for the Earth to stop spinning.  Security issues alone will force a minimal level of change will occur.</p><p>Updating continuously has its pain points, but any issues that come up tend to be smaller issues, and can be dealt with more quickly.  For example, just the other day I realized MacOS's system Cocoa libraries slightly changed something which broke my code in a number of places, even though I wasn't doing anything sketchy with the API.  But a slight change in definition meant I needed to cast some interfaces explicitly, and add new interface functions to retrieve those explicit interfaces.  It was a bit of work to track this down and solve it, even for the relatively small amount of code I was dealing with.</p><p>I saw one person on StackExchange say they "solved" it by linking their project against the older version of the library.  That "solution" just stacked some technical dept on some poor future programmer, even though it 100% works for now.  It may even allow such code to propagate in the future, making the eventual conversion even worse when it happens.</p><p>Moreover, leaving functionality alone and patching only security issues becomes a game of maintaining a *very* long history of supported versions of software.  How long does support last?  Yes, this is the correct answer for some software, but remember that companies generally pay very well for these long-term support versions, even for Linux, because maintaining a current build is expensive (I have some recent experience with this).  For most consumers, the simplest and most economical option is just to keep everything up to date, and yeah, that means taking the bad with the good.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506197">
<span class="ind"></span><a id="reply_link_53506197" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506197" onclick="D2.replyTo(53506197); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53506021" onclick="return D2.selectParent(53506021)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:The problem is often maintenance by Dutch Gun @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506197" data-title="Re:The problem is often maintenance">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:The problem is often maintenance by Dutch Gun" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506197" data-title="Re:The problem is often maintenance">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:The problem is often maintenance by Dutch Gun" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53506197" data-title="Re:The problem is often maintenance">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53506197" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53506197" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53506197" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53506197"></div>

<ul id="group_53506197">
	<li id="hiddens_53506197" class="hide"></li>
</ul>

</li><li id="tree_53506943" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506943" class="commentstatus"></div>
<div id="comment_53506943" class="cw">
	<div id="comment_top_53506943" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506943" name="comment_link_53506943" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506943" onclick="return D2.setFocusComment(53506943)" >Re:</a>


		 	<span id="comment_score_53506943" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506943); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Anne+Thwacks">Anne Thwacks</a>  <span class="uid"><a href="//slashdot.org/~Anne+Thwacks">( 531696 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506943"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506943"><i>bit-rot is not a thing</i> <p>
Bit-rot does happen. You are obviously not a Windows user, and never experienced DOS 4.1 or even early versions of the extX file systems. I have also had hard disks that seem to lose bits over a period of years. </p><p>
Having said that, I have run OpenBSD on Sparc machines (not Internet connected) for over 5 years without an update of any kind (aside from down-time to clean the air filters annually). </p><p>
I totally agree that auto-update is a festering can of worms, and bundling makes it worse<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506943">

</div>
</div>

<div id="replyto_53506943"></div>

<ul id="group_53506943">
	<li id="hiddens_53506943" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53505603" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505603" class="commentstatus"></div>
<div id="comment_53505603" class="cw">
	<div id="comment_top_53505603" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505603" name="comment_link_53505603" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505603" onclick="return D2.setFocusComment(53505603)" >They can't be serious.</a>


		 	<span id="comment_score_53505603" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505603); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mthamil">mthamil</a>  <span class="uid"><a href="//slashdot.org/~mthamil">( 1166787 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505603">		
		on Saturday December 17, 2016 @07:44PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505603">#53505603</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505603">The alternative, which is everyone writing their own mostly terrible implementations, is far worse.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505603">
<span class="ind"></span><a id="reply_link_53505603" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505603" onclick="D2.replyTo(53505603); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="They can't be serious. by mthamil @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505603" data-title="They can't be serious.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="They can't be serious. by mthamil" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505603" data-title="They can't be serious.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="They can't be serious. by mthamil" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505603" data-title="They can't be serious.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505603" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505603" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505603" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505603"></div>

<ul id="group_53505603">
	<li id="hiddens_53505603" class="hide"></li>
</ul>

<ul id="commtree_53505603"><li id="tree_53505773" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505773" class="commentstatus"></div>
<div id="comment_53505773" class="cw">
	<div id="comment_top_53505773" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505773" name="comment_link_53505773" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505773" onclick="return D2.setFocusComment(53505773)" >Re:They can't be serious.</a>


		 	<span id="comment_score_53505773" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505773); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BarbaraHudson">BarbaraHudson</a>  <span class="uid"><a href="//slashdot.org/~BarbaraHudson">( 3785311 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505773">		 &lt;<a href="mailto:barbarahudsonNO%40SPAMgmail.com">barbarahudsonNO@SPAMgmail.com</a>&gt;
		on Saturday December 17, 2016 @08:43PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505773">#53505773</a>)
		<small><a href="//slashdot.org/~BarbaraHudson/journal/" title="Thursday December 15, 2016 @07:29PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505773">If it means that it would be impossible to create stuff like Twitter, perhaps the positives outweigh the negatives.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505773">
<span class="ind"></span><a id="reply_link_53505773" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505773" onclick="D2.replyTo(53505773); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53505603" onclick="return D2.selectParent(53505603)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:They can't be serious. by BarbaraHudson @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505773" data-title="Re:They can't be serious.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:They can't be serious. by BarbaraHudson" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505773" data-title="Re:They can't be serious.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:They can't be serious. by BarbaraHudson" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505773" data-title="Re:They can't be serious.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505773" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505773" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505773" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505773"></div>

<ul id="group_53505773">
	<li id="hiddens_53505773" class="hide"></li>
</ul>

</li><li id="tree_53505909" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505909" class="commentstatus"></div>
<div id="comment_53505909" class="cw">
</div>

<div id="replyto_53505909"></div>

<ul id="group_53505909">
	<li id="hiddens_53505909" class="hide"></li>
</ul>

<ul id="commtree_53505909"><li id="tree_53505933" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505933" class="commentstatus"></div>
<div id="comment_53505933" class="cw">
	<div id="comment_top_53505933" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505933" name="comment_link_53505933" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505933" onclick="return D2.setFocusComment(53505933)" >I write the hacking scripts, and that's misinforme</a>


		 	<span id="comment_score_53505933" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505933); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~raymorris">raymorris</a>  <span class="uid"><a href="//slashdot.org/~raymorris">( 2726007 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505933"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505933"><p>I understand your logic. You're not being stupid, but you are misinformed.</p><p>&gt;   hacking scripts will become useless since every system will have different vulnerabilities</p><p>The fact is, over 90% of the CVEs are the SAME 12 or so vulnerabilities - hard-coded default passwords, SQL injection, etc. I can and do write scripts that find "new" vulnerabilities in software we've never seen before.  One-off, custom software, especially web applications will pretty reliably have one or more of a gew specific vulnerabil<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505933">

</div>
</div>

<div id="replyto_53505933"></div>

<ul id="group_53505933">
	<li id="hiddens_53505933" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505863" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505863" class="commentstatus"></div>
<div id="comment_53505863" class="cw">
</div>

<div id="replyto_53505863"></div>

<ul id="group_53505863">
	<li id="hiddens_53505863" class="hide"></li>
</ul>

<ul id="commtree_53505863"><li id="tree_53506519" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506519" class="commentstatus"></div>
<div id="comment_53506519" class="cw">
	<div id="comment_top_53506519" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506519" name="comment_link_53506519" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506519" onclick="return D2.setFocusComment(53506519)" >Re:</a>


		 	<span id="comment_score_53506519" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506519); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506519"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506519"><p><div class="quote"><p>The bugs in version 1.0 have a much lower chance of making it into version 2.0 if it's all new code.</p></div><p>A lot of "bugs" are actually design deficiencies that are later patched up in code.  These patches rarely make it back into the design documents, if there even are any.  Rewrites are very likely to make the same exact mistakes, because it was not obvious a mistake was made until the code was put into production.</p><p>Or in other words, old code contains wisdom.  People need to learn to read code, not just write it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506519">

</div>
</div>

<div id="replyto_53506519"></div>

<ul id="group_53506519">
	<li id="hiddens_53506519" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53505629" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505629" class="commentstatus"></div>
<div id="comment_53505629" class="cw">
	<div id="comment_top_53505629" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505629" name="comment_link_53505629" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505629" onclick="return D2.setFocusComment(53505629)" >Code reuse is a good thing</a>


		 	<span id="comment_score_53505629" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505629); return false"><span class=opt>Score:</span>3</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~davidwr">davidwr</a>  <span class="uid"><a href="//slashdot.org/~davidwr">( 791652 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505629">		
		on Saturday December 17, 2016 @07:50PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505629">#53505629</a>)
		<small><a href="http://slashdot.org/~davidwr/journal/" title="http://slashdot.org/~davidwr/journal/" class="user_homepage_display" rel="nofollow">Homepage</a>
<a href="//slashdot.org/~davidwr/journal/" title="Wednesday February 11, 2015 @10:52AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505629"><p>Granted, if it's closed-source you have to trust the library vendor.  If it's open-source, you either have to do due dilligence or trust someone else who claims to have done so.</p><p>I assume we are talking about re-using source code, linking with staticly-linked libraries, and using and "private copies" of shared libraries binaries (e.g.<nobr> <wbr></nobr>/usr/local/bin/applicationname/lib/lib1.so or C:\Program Files\Application\DLLs\MyDll.dll).  With "public" shared binaries (/usr/lib/sharedlib.so or C:\Windows\...\MSDLL.DLL), you are relying on the library or OS vendor to keep things patched.</p><p>Here's an example:</p><p>I know of a popular product that uses its own private copy of Java.  If the vendor doesn't update their customer's versions of Java on a regular basis, an attacker can exploit it, even if the user is updating the "Oracle" version of Java on a regular basis.  That's bad.  On the other hand, they would probably be in a worse of a position of the vendor re-wrote the functionality of Java in-house, as that code would have its own set of bugs and it would likely NOT be as maintined as Java is.  The solution is to use the "Oracle" version of Java instead of a private copy, OR push out updates to the private copy within a day or two of Oracle pushing out their updates.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505629">
<span class="ind"></span><a id="reply_link_53505629" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505629" onclick="D2.replyTo(53505629); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Code reuse is a good thing by davidwr @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505629" data-title="Code reuse is a good thing">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Code reuse is a good thing by davidwr" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505629" data-title="Code reuse is a good thing">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Code reuse is a good thing by davidwr" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505629" data-title="Code reuse is a good thing">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505629" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505629" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505629" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505629"></div>

<ul id="group_53505629">
	<li id="hiddens_53505629" class="hide"></li>
</ul>

</li><li id="tree_53505631" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505631" class="commentstatus"></div>
<div id="comment_53505631" class="cw">
	<div id="comment_top_53505631" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505631" name="comment_link_53505631" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505631" onclick="return D2.setFocusComment(53505631)" >Yes ...</a>


		 	<span id="comment_score_53505631" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505631); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CaptainDork">CaptainDork</a>  <span class="uid"><a href="//slashdot.org/~CaptainDork">( 3678879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505631"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505631"><p>...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505631">

</div>
</div>

<div id="replyto_53505631"></div>

<ul id="group_53505631">
	<li id="hiddens_53505631" class="hide"></li>
</ul>

</li><li id="tree_53505637" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505637" class="commentstatus"></div>
<div id="comment_53505637" class="cw">
	<div id="comment_top_53505637" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505637" name="comment_link_53505637" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505637" onclick="return D2.setFocusComment(53505637)" >It depends...</a>


		 	<span id="comment_score_53505637" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505637); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~QuietLagoon">QuietLagoon</a>  <span class="uid"><a href="//slashdot.org/~QuietLagoon">( 813062 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505637"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505637">... upon whether or not the reused code is written in a manner that is proper and secure.   If insecure code is reused, well, all bets are off.  If secure code is properly reused, then the results can be good.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505637">

</div>
</div>

<div id="replyto_53505637"></div>

<ul id="group_53505637">
	<li id="hiddens_53505637" class="hide"></li>
</ul>

<ul id="commtree_53505637"><li id="tree_53505693" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505693" class="commentstatus"></div>
<div id="comment_53505693" class="cw">
	<div id="comment_top_53505693" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505693" name="comment_link_53505693" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505693" onclick="return D2.setFocusComment(53505693)" >Re:</a>


		 	<span id="comment_score_53505693" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505693); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Jeremi">Jeremi</a>  <span class="uid"><a href="//slashdot.org/~Jeremi">( 14640 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505693"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505693"><p>... and the problem there is, nobody can really tell whether a given library is secure or insecure (exception:  after an exploit is found, we can say with certainty that it was/is insecure<nobr> <wbr></nobr>;) ).</p><p>So the question becomes, how do we know which third party libraries we can afford to trust the security of our application to?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505693">

</div>
</div>

<div id="replyto_53505693"></div>

<ul id="group_53505693">
	<li id="hiddens_53505693" class="hide"></li>
</ul>

<ul id="commtree_53505693"><li id="tree_53506349" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506349" class="commentstatus"></div>
<div id="comment_53506349" class="cw">
	<div id="comment_top_53506349" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506349" name="comment_link_53506349" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506349" onclick="return D2.setFocusComment(53506349)" >Re:</a>


		 	<span id="comment_score_53506349" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506349); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~meerling">meerling</a>  <span class="uid"><a href="//slashdot.org/~meerling">( 1487879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506349"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506349">It's only 'secure' until someone finds a way to exploit it.<br><span class="substr"> </span> <br>Always assume that they will find a vulnerability eventually, but it's still your job to eliminate all of the vulnerabilities you can, and make it as hard as feasible for any attacker to get in.<br> <br>Of course there's the issue of resource to deal with. Sure if you had infinite time &amp; other resources to work on the software before release/implementation, you could get something that will take longer than the heat death of the universe to become vulner</div>
	</div>

	<div class="commentSub" id="comment_sub_53506349">

</div>
</div>

<div id="replyto_53506349"></div>

<ul id="group_53506349">
	<li id="hiddens_53506349" class="hide"></li>
</ul>

<ul id="commtree_53506349"><li id="tree_53506691" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506691" class="commentstatus"></div>
<div id="comment_53506691" class="cw">
	<div id="comment_top_53506691" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506691" name="comment_link_53506691" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506691" onclick="return D2.setFocusComment(53506691)" >Re:</a>


		 	<span id="comment_score_53506691" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506691); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ArtemaOne">ArtemaOne</a>  <span class="uid"><a href="//slashdot.org/~ArtemaOne">( 1300025 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506691"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506691">True, but I think the implied point is that once that exploit is discovered, then they have access to all software that uses it automatically.  If people wrote their own, the flaws would have to be individually discovered.  I'm not convinced on which is better.</div>
	</div>

	<div class="commentSub" id="comment_sub_53506691">

</div>
</div>

<div id="replyto_53506691"></div>

<ul id="group_53506691">
	<li id="hiddens_53506691" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_53505645" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505645" class="commentstatus"></div>
<div id="comment_53505645" class="cw">
	<div id="comment_top_53505645" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505645" name="comment_link_53505645" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505645" onclick="return D2.setFocusComment(53505645)" >Secure Software</a>


		 	<span id="comment_score_53505645" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505645); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ledow">ledow</a>  <span class="uid"><a href="//slashdot.org/~ledow">( 319597 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505645">		
		on Saturday December 17, 2016 @07:53PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505645">#53505645</a>)
		<small><a href="http://www.ledow.org.uk/" title="http://www.ledow.org.uk/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505645"><p>What's needed is better operating system management, not better development practices.</p><p>Once a piece of software is patched, the problem is fixed.  That's not the issue at hand.  The issue is that that fix then does not make it back to production systems in a decent time.</p><p>What's needed - and I've posited this a number of times for a number of things - is a central repository which lists which, say, linux packages are secure and which are not.  Which algorithms, hashes and cryptosystems are compromised or not.</p><p>Then there needs to be an API - running a production system live on the Internet?  It will check its version numbers and package hashes against the centralised "uncompromised" versions service.  If there's a discrepancy -a package that's been marked as potentially compromisable, but which has an updated or patched version available - the OS is tainted much like the kernel is tainted.  If MD5 is retired and any software on the machine still utilises it, the system is marked as tainted as soon as it checks into the centralised API.</p><p>We've needed this for hashs and crypto systems for a long time.  SHA-1 is retired, but how do you KNOW that?  And how do you know what uses that?  Nobody would recommend building a system using WEP or MD5 in this day and age but nowhere is that listed in a queryable manner.</p><p>And then you start saying "Why weren't Facebook checking their systems against the Secure Software Database?  Their own fault if they were compromised.", "Why did Yahoo not re-hash with a listed-good algorithm as soon as their existing hash was obsolete?", "Why were they compromised?  Because they turned off database checks and updates?  Idiots".</p><p>There needs to be a way for production systems to algorithmically say "This is no longer acceptable practice" and start making a fuss such that the system maintainers are forced to start upgrading, with specified timescales (the API could easily obsolete stuff on a set timescale, with warning enough to test changes to newer algorithms).</p><p>Then, if you're compromised because you ignored this, or because you hard-coded MD5 instead of using libraries, all the fault will be in the your third-party, unlisted libraries.  And then you might be able to actually start forcing vendors to publicly state "All our software uses the latest database-compatible algorithms, software and patches" rather than just hope that someone at Google isn't just running Slackware 2.0.</p><p>The software can be fixed in a trice.  The problem is getting that fix out to production systems in good time, and not being able to sufficiently shame those who don't manage their systems (it's easy to blame a hack on the software, rather than your lax update practices).</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505645">
<span class="ind"></span><a id="reply_link_53505645" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505645" onclick="D2.replyTo(53505645); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Secure Software by ledow @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505645" data-title="Secure Software">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Secure Software by ledow" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505645" data-title="Secure Software">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Secure Software by ledow" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505645" data-title="Secure Software">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505645" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505645" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505645" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505645"></div>

<ul id="group_53505645">
	<li id="hiddens_53505645" class="hide"></li>
</ul>

<ul id="commtree_53505645"><li id="tree_53506059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506059" class="commentstatus"></div>
<div id="comment_53506059" class="cw">
	<div id="comment_top_53506059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506059" name="comment_link_53506059" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506059" onclick="return D2.setFocusComment(53506059)" >I maintain *exactly* that system Monday-Friday</a>


		 	<span id="comment_score_53506059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506059); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~raymorris">raymorris</a>  <span class="uid"><a href="//slashdot.org/~raymorris">( 2726007 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506059"><p> &gt;  central repository which lists which, say, linux packages are secure and which are not. Which algorithms, hashes and cryptosystems are compromised or not.<br>&gt;<br>&gt; Then there needs to be an API - running a production system live on the Internet? It will check its version numbers and package hashes against the centralised "uncompromised" versions service</p><p>That's precisely what I spend 40 hours a week building and maintaining.  It's a very helpful part of a comprehensive security strategy.  Other good par<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506059">

</div>
</div>

<div id="replyto_53506059"></div>

<ul id="group_53506059">
	<li id="hiddens_53506059" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505669" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505669" class="commentstatus"></div>
<div id="comment_53505669" class="cw">
	<div id="comment_top_53505669" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505669" name="comment_link_53505669" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505669" onclick="return D2.setFocusComment(53505669)" >Of course not (with caveats)</a>


		 	<span id="comment_score_53505669" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505669); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bsDaemon">bsDaemon</a>  <span class="uid"><a href="//slashdot.org/~bsDaemon">( 87307 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505669">		
		on Saturday December 17, 2016 @07:59PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505669">#53505669</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505669"><p>Code reuse is a fundamental tenant of secure software development lifecycles. You reduce the chance that you introduce new vulnerabillities by limiting the amount of new code per project to the core business logic and leveraging existing modules for the support infrastructure.</p><p>That said, if the module you reuse has problems then you aren't necessarily better off. The modules need to be vetted and maintained appropriately. Code reuse isn't the problem so much as taking random crap from the internet that solves your problem without assessing its suitability for inclusion given your threat model or properly assessing it for vulnerabilities.</p><p>Monoculture can be an issue from certain perspectives -- flaws in the libssl portion of OpenSSL affect a huge percentage of the internet. However, they only need to be fixed once and consumers of the library can all receive the update, assuming proper patch management in the environment. If your company uses 15 different libraries to perform a specific software function across different product lines without a basis in engineering requirements constraints, you're doing it wrong.</p><p>Security being a subset of correctness, I think overall it is b.s. to say code reuse is a problem. You just need to make sure you are reusing correct, vetted and maintained code. I.e., don't take strange code from someone's github to use in your enterprise software without reviewing it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505669">
<span class="ind"></span><a id="reply_link_53505669" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505669" onclick="D2.replyTo(53505669); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Of course not (with caveats) by bsDaemon @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505669" data-title="Of course not (with caveats)">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Of course not (with caveats) by bsDaemon" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505669" data-title="Of course not (with caveats)">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Of course not (with caveats) by bsDaemon" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505669" data-title="Of course not (with caveats)">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505669" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505669" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505669" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505669"></div>

<ul id="group_53505669">
	<li id="hiddens_53505669" class="hide"></li>
</ul>

<ul id="commtree_53505669"><li id="tree_53505861" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505861" class="commentstatus"></div>
<div id="comment_53505861" class="cw">
	<div id="comment_top_53505861" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505861" name="comment_link_53505861" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505861" onclick="return D2.setFocusComment(53505861)" >Re:</a>


		 	<span id="comment_score_53505861" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505861); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505861"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505861"><p>Yes.  And that is why we (distro developers) fight so much "embedded library copies" in Linux distros: when one of those escape tracking, a supposedly fixed bug will linger on.</p><p>Developers cannot be trusted to keep their embedded libraries current. Ever.  They won't, it is not in their best interests to do so: it takes time, effort, and breaks their build, and it is uninteresting and dull.  Issues start in ecosystems where this kind of crap is the rule (the javascript scene, for example), and get truly ridicu<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505861">

</div>
</div>

<div id="replyto_53505861"></div>

<ul id="group_53505861">
	<li id="hiddens_53505861" class="hide"></li>
</ul>

</li><li id="tree_53506555" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506555" class="commentstatus"></div>
<div id="comment_53506555" class="cw">
	<div id="comment_top_53506555" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506555" name="comment_link_53506555" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506555" onclick="return D2.setFocusComment(53506555)" >Re:</a>


		 	<span id="comment_score_53506555" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506555); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506555"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506555"><p>This.  It also helps if codebases "do one thing and do it well" and when they feel mission creep seeping in, break off extra functionality into a well separated module.  That helps confine bugs to more easily audited units.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506555">

</div>
</div>

<div id="replyto_53506555"></div>

<ul id="group_53506555">
	<li id="hiddens_53506555" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505685" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505685" class="commentstatus"></div>
<div id="comment_53505685" class="cw">
	<div id="comment_top_53505685" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505685" name="comment_link_53505685" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505685" onclick="return D2.setFocusComment(53505685)" >Due diligence on the developer to follow packages.</a>


		 	<span id="comment_score_53505685" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505685); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Mal-2">Mal-2</a>  <span class="uid"><a href="//slashdot.org/~Mal-2">( 675116 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505685"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505685"><p>You're responsible for the code you write, and if you are using existing libraries, you are responsible for tracking the packages you use. If they update, and your installer includes it, you need to update your installer. You may not feel this justifies pushing updates, especially if the change is to functions you did not use, but the program really should be checking for library updates and asking the user if they should be updated &ndash; and sometimes there are reasons why they cannot. At that point, it<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505685">

</div>
</div>

<div id="replyto_53505685"></div>

<ul id="group_53505685">
	<li id="hiddens_53505685" class="hide"></li>
</ul>

</li><li id="tree_53505707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505707" class="commentstatus"></div>
<div id="comment_53505707" class="cw">
	<div id="comment_top_53505707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505707" name="comment_link_53505707" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505707" onclick="return D2.setFocusComment(53505707)" >No.</a>


		 	<span id="comment_score_53505707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505707); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Narcocide">Narcocide</a>  <span class="uid"><a href="//slashdot.org/~Narcocide">( 102829 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505707"><p>Dearth of independent audits endangers secure software development.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505707">

</div>
</div>

<div id="replyto_53505707"></div>

<ul id="group_53505707">
	<li id="hiddens_53505707" class="hide"></li>
</ul>

<ul id="commtree_53505707"><li id="tree_53506569" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506569" class="commentstatus"></div>
<div id="comment_53506569" class="cw">
	<div id="comment_top_53506569" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506569" name="comment_link_53506569" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506569" onclick="return D2.setFocusComment(53506569)" >Re:</a>


		 	<span id="comment_score_53506569" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506569); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506569"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506569"><p>Yup.  Everyone wants a philosophical fix for the security (and general QA) problem.  Nobody wants to admit the need for many hours of less-than-prestigious, methodical work.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506569">

</div>
</div>

<div id="replyto_53506569"></div>

<ul id="group_53506569">
	<li id="hiddens_53506569" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505709" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505709" class="commentstatus"></div>
<div id="comment_53505709" class="cw">
</div>

<div id="replyto_53505709"></div>

<ul id="group_53505709">
	<li id="hiddens_53505709" class="hide"></li>
</ul>

</li><li id="tree_53505737" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505737" class="commentstatus"></div>
<div id="comment_53505737" class="cw">
</div>

<div id="replyto_53505737"></div>

<ul id="group_53505737">
	<li id="hiddens_53505737" class="hide"></li>
</ul>

<ul id="commtree_53505737"><li id="tree_53505767" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505767" class="commentstatus"></div>
<div id="comment_53505767" class="cw">
	<div id="comment_top_53505767" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505767" name="comment_link_53505767" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505767" onclick="return D2.setFocusComment(53505767)" >Re: Writing software is risky.</a>


		 	<span id="comment_score_53505767" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505767); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bsDaemon">bsDaemon</a>  <span class="uid"><a href="//slashdot.org/~bsDaemon">( 87307 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505767"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505767"><p>There is no formal verification at EAL4. That is at 7. EAL4 is "methodical" design, testing and review. A lot of crap got EAL4, like Windows XP.</p><p>Besides, you can't get an EAL evaluation under NIAP anymore, it is Protection Profile only in the US.  Unless you take your stuff to Europe for CC certification you're out of luck (BSI loves EAL) if that's what you want.</p><p>The EAL system has a lot of holes in it that enable crap products to skirt the spirit. Not that the PP system doesn't, but it is harder to do (usual<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505767">

</div>
</div>

<div id="replyto_53505767"></div>

<ul id="group_53505767">
	<li id="hiddens_53505767" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53505765" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505765" class="commentstatus"></div>
<div id="comment_53505765" class="cw">
	<div id="comment_top_53505765" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505765" name="comment_link_53505765" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505765" onclick="return D2.setFocusComment(53505765)" >Stating the obvious, the opposite is...</a>


		 	<span id="comment_score_53505765" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505765); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~blibbo">blibbo</a>  <span class="uid"><a href="//slashdot.org/~blibbo">( 928752 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505765"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505765">..reinventing the wheel.  Which can easily be done badly.<br> <br>

Even for the most common search / sort algorithms, there's a good chance you won't code them perfectly first time.<br> <br>

Code re-use, code-from scratch.  Both have their place.  Both require intelligent thought.</div>
	</div>

	<div class="commentSub" id="comment_sub_53505765">

</div>
</div>

<div id="replyto_53505765"></div>

<ul id="group_53505765">
	<li id="hiddens_53505765" class="hide"></li>
</ul>

</li><li id="tree_53505771" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505771" class="commentstatus"></div>
<div id="comment_53505771" class="cw">
	<div id="comment_top_53505771" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505771" name="comment_link_53505771" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505771" onclick="return D2.setFocusComment(53505771)" >Extreme vetting: software style</a>


		 	<span id="comment_score_53505771" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505771); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jhoger">jhoger</a>  <span class="uid"><a href="//slashdot.org/~jhoger">( 519683 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505771"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505771"><p>"developers failing to vet third-party code for vulnerabilities"</p><p>LOL. What would you suggest? Code inspection by magically infallible developers who have their own work to do creating new features probably wouldn't recognize vulnerabilities in their own code?</p><p>Most companies and projects do not employ security researchers and specialists, not for their own code and certainly not for anyone else's, and they are not about to do so. And even if they could afford it, I wouldn't be too hopeful of the bugs actually<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505771">

</div>
</div>

<div id="replyto_53505771"></div>

<ul id="group_53505771">
	<li id="hiddens_53505771" class="hide"></li>
</ul>

<ul id="commtree_53505771"><li id="tree_53506951" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506951" class="commentstatus"></div>
<div id="comment_53506951" class="cw">
	<div id="comment_top_53506951" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506951" name="comment_link_53506951" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506951" onclick="return D2.setFocusComment(53506951)" >Re:</a>


		 	<span id="comment_score_53506951" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506951); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Anne+Thwacks">Anne Thwacks</a>  <span class="uid"><a href="//slashdot.org/~Anne+Thwacks">( 531696 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506951"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506951"><i>Code inspection by magically infallible developers </i> <p>
This<nobr> <wbr></nobr>... A thousand times this!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506951">

</div>
</div>

<div id="replyto_53506951"></div>

<ul id="group_53506951">
	<li id="hiddens_53506951" class="hide"></li>
</ul>

</li><li id="tree_53505845" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505845" class="commentstatus"></div>
<div id="comment_53505845" class="cw">
</div>

<div id="replyto_53505845"></div>

<ul id="group_53505845">
	<li id="hiddens_53505845" class="hide"></li>
</ul>

<ul id="commtree_53505845"><li id="tree_53505937" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505937" class="commentstatus"></div>
<div id="comment_53505937" class="cw">
	<div id="comment_top_53505937" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505937" name="comment_link_53505937" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505937" onclick="return D2.setFocusComment(53505937)" >Re:</a>


		 	<span id="comment_score_53505937" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505937); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rossz">rossz</a>  <span class="uid"><a href="//slashdot.org/~rossz">( 67331 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505937"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505937"><p>You are assuming that everyone who codes is competent to code review all types of code.  Some people are great programmers but have little or no experience with encryption.  They are going to have to trust that the people who specialize in encryption actually know what the hell they are doing.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505937">

</div>
</div>

<div id="replyto_53505937"></div>

<ul id="group_53505937">
	<li id="hiddens_53505937" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53505787" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505787" class="commentstatus"></div>
<div id="comment_53505787" class="cw">
	<div id="comment_top_53505787" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505787" name="comment_link_53505787" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505787" onclick="return D2.setFocusComment(53505787)" >Yes it does, and for many reasons...</a>


		 	<span id="comment_score_53505787" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505787); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~FlyingGuy">FlyingGuy</a>  <span class="uid"><a href="//slashdot.org/~FlyingGuy">( 989135 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505787">		 &lt;<a href="mailto:flyingguy+AT+gmail+DOT+com">flyingguy AT gmail DOT com</a>&gt;
		on Saturday December 17, 2016 @08:49PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505787">#53505787</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505787">Like:
<ul>
<li>
Developers who just say, "we have to use &gt; " because that is all they know how to use and they cannot take the time  to learn the basics of good software design principles.
</li><li>
Development Managers who could not code their way out of a wet paper bag, making decisions for the development team when they know very little about anything.
</li><li>
The coders who write "tools" so they can make databases look like Java then hate the DBA's when they point out that the database is a vertical beast and not a horizontal one. And yes I am speaking about the fools who who write Hibernate / Spring which is so old, so wrong, so wrong headed as to make it practically useless in the day of a modern DB engine.  Hibernate has been broken into more times then I can count.
</li><li>
SOFD, Software of the day...  So a guys writes something he thinks is cool, and some fool decides its great and uses it in a forward facing system.  It is never strenuously tested, and likely as not never developed further yet there it is in some critical code.
</li><li>
Using Libs or frameworks that are so badly coded that they include 10's of thousands lines of code that are never seen or tested because some 24 year old kid grabs a function that he thinks is going to save him an hour or two.
</li><li><p>
Because Java!  Not the worst programming language ever, but the problems that come from garbage collection and programmers who THINK they understand it.
</p></li><li>
Because JavaScript, which is the worst period, ever written period, kludged upon period,  ever written period!!
</li></ul><p>
We need to get off of the HTML/CSS/ crazy drunken bandwagon and get back to basics!  Re-boot and re-tool the the entire process because if we don't we are just screwed and more break ins will happen as the things become more and more complex.  You need to let DBA's build the database portions of things and secure access.  You need to let Systems people write HARDENED code.  Let web guys make things pretty.  You need to stop demanding a a single point tool and go back to individual inter working parts, written by competent coders, which are then put through a very severe hardening process.
</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505787">
<span class="ind"></span><a id="reply_link_53505787" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505787" onclick="D2.replyTo(53505787); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Yes it does, and for many reasons... by FlyingGuy @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505787" data-title="Yes it does, and for many reasons...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Yes it does, and for many reasons... by FlyingGuy" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505787" data-title="Yes it does, and for many reasons...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Yes it does, and for many reasons... by FlyingGuy" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505787" data-title="Yes it does, and for many reasons...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505787" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505787" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505787" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505787"></div>

<ul id="group_53505787">
	<li id="hiddens_53505787" class="hide"></li>
</ul>

</li><li id="tree_53505799" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505799" class="commentstatus"></div>
<div id="comment_53505799" class="cw">
	<div id="comment_top_53505799" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505799" name="comment_link_53505799" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505799" onclick="return D2.setFocusComment(53505799)" >Depends on the library</a>


		 	<span id="comment_score_53505799" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505799); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AuMatar">AuMatar</a>  <span class="uid"><a href="//slashdot.org/~AuMatar">( 183847 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505799">		
		on Saturday December 17, 2016 @08:53PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505799">#53505799</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505799"><p>A well known, maintained library such as OpenSSL?  You're far more secure using the open source library.  Not only do you need to be an expert to correctly and securely implement that level of cryptography, but it can contain all sort of subtle bugs you're unlikely to catch.</p><p>Now if you're talking about some random library you found on github because some guy on stackoverflow said to use it?  That makes you less secure.  Don't put random things you found on the internet into your program without reading the code, understanding what it does, and doing a full audit on it first.</p><p>And there's a special place in hell for anyone who uses gradle, nvm, or anything else that automatically downloads the library for them without specifying an exact version.  You're just asking to be screwed by a trojan horse.  Leftpad was about the best case scenario, imagine if leftpad had changed their code to be a backdoor instead?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505799">
<span class="ind"></span><a id="reply_link_53505799" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505799" onclick="D2.replyTo(53505799); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Depends on the library by AuMatar @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505799" data-title="Depends on the library">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Depends on the library by AuMatar" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505799" data-title="Depends on the library">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Depends on the library by AuMatar" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505799" data-title="Depends on the library">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505799" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505799" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505799" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505799"></div>

<ul id="group_53505799">
	<li id="hiddens_53505799" class="hide"></li>
</ul>

<ul id="commtree_53505799"><li id="tree_53506615" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506615" class="commentstatus"></div>
<div id="comment_53506615" class="cw">
	<div id="comment_top_53506615" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506615" name="comment_link_53506615" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506615" onclick="return D2.setFocusComment(53506615)" >Re:</a>


		 	<span id="comment_score_53506615" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506615); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506615"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506615"><p><div class="quote"><p>Don't put random things you found on the internet into your program without reading the code, understanding what it does, and doing a full audit on it first.</p></div><p>Nobody would get anything done if they had to fully audit all their dependencies.</p><p>However, they should spend some time auditing some portion of it.  Especially if they have specialized domain knowledge which allows them to audit that section better.</p><p>In other words, improve, even if slightly, some of the things you use.  Contribute.  Don't just take.  If everyone did that, then security would improve.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506615">

</div>
</div>

<div id="replyto_53506615"></div>

<ul id="group_53506615">
	<li id="hiddens_53506615" class="hide"></li>
</ul>

<ul id="commtree_53506615"><li id="tree_53506729" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506729" class="commentstatus"></div>
<div id="comment_53506729" class="cw">
	<div id="comment_top_53506729" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506729" name="comment_link_53506729" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506729" onclick="return D2.setFocusComment(53506729)" >Re:</a>


		 	<span id="comment_score_53506729" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506729); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AuMatar">AuMatar</a>  <span class="uid"><a href="//slashdot.org/~AuMatar">( 183847 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506729"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506729"><p>Sure they would.  They'd just get things done slightly slower.  But the big, well known dependencies aren't the problem-  they may find an occasional security bug, but they'll be quickly patched.  The problem is when you use some random library that doesn't have a large user base and contributor base.  If you find something on github and use it without reading and understanding  every line of it, you're incompetent.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506729">

</div>
</div>

<div id="replyto_53506729"></div>

<ul id="group_53506729">
	<li id="hiddens_53506729" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53505813" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53505813" class="commentstatus"></div>
<div id="comment_53505813" class="cw">
	<div id="comment_top_53505813" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505813" name="comment_link_53505813" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505813" onclick="return D2.setFocusComment(53505813)" >Oh, sure code reuse leads to insecure software.</a>


		 	<span id="comment_score_53505813" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505813); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hey!">hey!</a>  <span class="uid"><a href="//slashdot.org/~hey!">( 33014 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505813">		
		on Saturday December 17, 2016 @08:58PM (<span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505813">#53505813</a>)
		<small><a href="http://kamthaka.blogspot.com/" title="http://kamthaka.blogspot.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~hey!/journal/" title="Friday March 13, 2015 @06:45AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505813"><p>So does reinventing the wheel.   So does cut-and-paste coding.</p><p>Code reuse leads to insecure software in much the same way that breathing leads to cancer.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505813">
<span class="ind"></span><a id="reply_link_53505813" class="btn link" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505813" onclick="D2.replyTo(53505813); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Oh, sure code reuse leads to insecure software. by hey! @slashdot" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505813" data-title="Oh, sure code reuse leads to insecure software.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Oh, sure code reuse leads to insecure software. by hey!" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505813" data-title="Oh, sure code reuse leads to insecure software.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Oh, sure code reuse leads to insecure software. by hey!" data-url="https://it.slashdot.org/comments.pl?sid=10008949&cid=53505813" data-title="Oh, sure code reuse leads to insecure software.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://it.slashdot.org/comments.pl?sid=10008949%26cid=53505813" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53505813" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53505813" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53505813"></div>

<ul id="group_53505813">
	<li id="hiddens_53505813" class="hide"></li>
</ul>

</li><li id="tree_53505847" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505847" class="commentstatus"></div>
<div id="comment_53505847" class="cw">
	<div id="comment_top_53505847" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505847" name="comment_link_53505847" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505847" onclick="return D2.setFocusComment(53505847)" >OpenSource solves all of these problems... geez</a>


		 	<span id="comment_score_53505847" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505847); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Proudrooster">Proudrooster</a>  <span class="uid"><a href="//slashdot.org/~Proudrooster">( 580120 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505847"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505847"><p>Code Re-use and open source software lead to super-reliable, robust, and secure code that is the foundation of the Internet.  With all the eyes constantly looking over the code it continues to get better and better.  And since no program or company has time to write everything from scratch, code will be reused until we can teach computers how to write code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505847">

</div>
</div>

<div id="replyto_53505847"></div>

<ul id="group_53505847">
	<li id="hiddens_53505847" class="hide"></li>
</ul>

</li><li id="tree_53505899" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505899" class="commentstatus"></div>
<div id="comment_53505899" class="cw">
	<div id="comment_top_53505899" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505899" name="comment_link_53505899" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505899" onclick="return D2.setFocusComment(53505899)" >Stupidity endagers software development</a>


		 	<span id="comment_score_53505899" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505899); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thesandbender">thesandbender</a>  <span class="uid"><a href="//slashdot.org/~thesandbender">( 911391 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505899"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505899">Good code is good code.  Bad code is bad code.  Knowing the difference is what makes you a "programmer".</div>
	</div>

	<div class="commentSub" id="comment_sub_53505899">

</div>
</div>

<div id="replyto_53505899"></div>

<ul id="group_53505899">
	<li id="hiddens_53505899" class="hide"></li>
</ul>

</li><li id="tree_53505911" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505911" class="commentstatus"></div>
<div id="comment_53505911" class="cw">
	<div id="comment_top_53505911" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505911" name="comment_link_53505911" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505911" onclick="return D2.setFocusComment(53505911)" >Code reuse is good, but...</a>


		 	<span id="comment_score_53505911" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505911); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sigmabody">sigmabody</a>  <span class="uid"><a href="//slashdot.org/~sigmabody">( 1099541 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505911"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505911"><p>As has already been stated, you generally want to prefer to use a third-party library over a custom implementation, for most security-related code. This is doubly true for well-defined algorithms, which are implemented in well-tested (and preferably open source) libraries.</p><p>However... there's an inherent danger in adopting third-party libraries based on uninformed assumptions about quality, as I'm personally well acquainted with. If you have a manager who is prone to making baseless assumptions, and downloadi<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53505911">

</div>
</div>

<div id="replyto_53505911"></div>

<ul id="group_53505911">
	<li id="hiddens_53505911" class="hide"></li>
</ul>

</li><li id="tree_53506131" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506131" class="commentstatus"></div>
<div id="comment_53506131" class="cw">
	<div id="comment_top_53506131" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506131" name="comment_link_53506131" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506131" onclick="return D2.setFocusComment(53506131)" >Use the SECOND-most popular library</a>


		 	<span id="comment_score_53506131" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506131); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tony+Isaac">Tony Isaac</a>  <span class="uid"><a href="//slashdot.org/~Tony+Isaac">( 1301187 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506131"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506131"><p>Hackers will typically target the most popular libraries, because these will be found on the largest number of computers. If you want your software to be more secure, use the #2 or #3 library, assuming they have appropriate functionality. Hackers are less likely to attack these.</p><p>This principle is beneficial in other ways as well. If you are using commercial libraries, the #2 or #3 brand will try harder to support you, the customer, because they want to catch up with #1. The #1 brand, on the other hand, tends<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506131">

</div>
</div>

<div id="replyto_53506131"></div>

<ul id="group_53506131">
	<li id="hiddens_53506131" class="hide"></li>
</ul>

</li><li id="tree_53506223" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506223" class="commentstatus"></div>
<div id="comment_53506223" class="cw">
	<div id="comment_top_53506223" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506223" name="comment_link_53506223" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506223" onclick="return D2.setFocusComment(53506223)" >No, it's the Operating System, silly!</a>


		 	<span id="comment_score_53506223" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506223); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506223"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506223"><p>Analogy time: Imagine homes with no Circuit Breakers. Any short circuit anywhere could burn down a house.  Lawyers and lawmakers arrive on the scene and declare that everything you want to plug in needs to be short proof. Every product has to be certified not to burn down houses, no matter what failure happens. The designers of even a simple lamp can end up being charged with murder, and as a result nobody really wants to use electricity.</p><p>We have circuit breakers, which limit the amount of current to be supp<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506223">

</div>
</div>

<div id="replyto_53506223"></div>

<ul id="group_53506223">
	<li id="hiddens_53506223" class="hide"></li>
</ul>

<ul id="commtree_53506223"><li id="tree_53506867" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506867" class="commentstatus"></div>
<div id="comment_53506867" class="cw">
	<div id="comment_top_53506867" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506867" name="comment_link_53506867" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506867" onclick="return D2.setFocusComment(53506867)" >Re:</a>


		 	<span id="comment_score_53506867" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506867); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506867"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506867">That's not going to fix things, and here's why:<br> <br>
Imagine a system where Apache is running as a web server, can only access the database, and nothing else. In fact, limit it further: it can't even write/read to the database, just forwards requests to an application server. <br> <br>
A hacker who manages to break in to this Apache instance still has all the user data that is streaming through the server, which is quite a lot.</div>
	</div>

	<div class="commentSub" id="comment_sub_53506867">

</div>
</div>

<div id="replyto_53506867"></div>

<ul id="group_53506867">
	<li id="hiddens_53506867" class="hide"></li>
</ul>

<ul id="commtree_53506867"><li id="tree_53507985" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507985" class="commentstatus"></div>
<div id="comment_53507985" class="cw">
	<div id="comment_top_53507985" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507985" name="comment_link_53507985" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507985" onclick="return D2.setFocusComment(53507985)" >Re:</a>


		 	<span id="comment_score_53507985" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507985); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507985"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507985"><p>Yes, being able to copy the flow of data to a user would be bad, but not system-compromising bad. And why would an instance of Apache be able to connect to more than one IP address?  Each thread would be isolated from each other, further limiting the information leakage.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507985">

</div>
</div>

<div id="replyto_53507985"></div>

<ul id="group_53507985">
	<li id="hiddens_53507985" class="hide"></li>
</ul>

<ul id="commtree_53507985"><li id="tree_53509561" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509561" class="commentstatus"></div>
<div id="comment_53509561" class="cw">
	<div id="comment_top_53509561" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509561" name="comment_link_53509561" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509561" onclick="return D2.setFocusComment(53509561)" >Re:</a>


		 	<span id="comment_score_53509561" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509561); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509561"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509561"><p><div class="quote"><p>Yes, being able to copy the flow of data to a user would be bad, but not system-compromising bad.</p> </div><p>Probably the most valuable thing on that system is the flow of data.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53509561">

</div>
</div>

<div id="replyto_53509561"></div>

<ul id="group_53509561">
	<li id="hiddens_53509561" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53509335" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509335" class="commentstatus"></div>
<div id="comment_53509335" class="cw">
	<div id="comment_top_53509335" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509335" name="comment_link_53509335" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509335" onclick="return D2.setFocusComment(53509335)" >Re:</a>


		 	<span id="comment_score_53509335" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509335); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ledow">ledow</a>  <span class="uid"><a href="//slashdot.org/~ledow">( 319597 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509335"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509335"><p>In the UK, every device has to be supplied with a mains plug pre-wired.</p><p>Every such main plug has an individual fuse in it, of the correct rating for the appliance..</p><p>And every circuit is on an RCD / breaker on the fuse board.</p><p>And every fuse board has an RCD / breaker.</p><p>And the house has a fuse for the fuse board.</p><p>Don't lay the blame at one point or one component.  Isolate them all.</p><p>As pointed out, an application with permissions to private data is vulnerable no matter what you do - a compromise is a compromise and<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53509335">

</div>
</div>

<div id="replyto_53509335"></div>

<ul id="group_53509335">
	<li id="hiddens_53509335" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506779" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506779" class="commentstatus"></div>
<div id="comment_53506779" class="cw">
	<div id="comment_top_53506779" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506779" name="comment_link_53506779" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506779" onclick="return D2.setFocusComment(53506779)" >Betteridge's Law</a>


		 	<span id="comment_score_53506779" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506779); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xtifr">Xtifr</a>  <span class="uid"><a href="//slashdot.org/~Xtifr">( 1323 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506779"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506779"><p>One of the best examples of <a href="https://en.wikipedia.org/wiki/Betteridge's_law_of_headlines" title="wikipedia.org">Betteridge's Law of headlines<span class="substr"> </span></a> [wikipedia.org] I've seen in <em>quite</em> a while!<nobr> <wbr></nobr>:)</p><p>No, code reuse obviously does not endanger secure software development. It was hard enough for the <em>experts</em> to get ssh right, and you think you're just going to whip one up from scratch? Yer a freakin' idiot if you think that!</p><p>Code reuse (like pretty much everything else associated with software development) has risks <em>and</em> benefits. Learn what those risks and benefits are, and stop searching for magical "silver bullets" tha</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506779">

</div>
</div>

<div id="replyto_53506779"></div>

<ul id="group_53506779">
	<li id="hiddens_53506779" class="hide"></li>
</ul>

<ul id="commtree_53506779"><li id="tree_53506787" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506787" class="commentstatus"></div>
<div id="comment_53506787" class="cw">
	<div id="comment_top_53506787" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506787" name="comment_link_53506787" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506787" onclick="return D2.setFocusComment(53506787)" >Re:</a>


		 	<span id="comment_score_53506787" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506787); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xtifr">Xtifr</a>  <span class="uid"><a href="//slashdot.org/~Xtifr">( 1323 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506787"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506787"><p>Correction to my previous post. A <em>real</em> silver bullet fired directly through your CPU will solve your bug problems, because you'll no longer be able to run software--hence, no bugs. Aside from <em>that</em>, silver bullets that fix all your problems are imaginary.<nobr> <wbr></nobr>:D</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506787">

</div>
</div>

<div id="replyto_53506787"></div>

<ul id="group_53506787">
	<li id="hiddens_53506787" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506825" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506825" class="commentstatus"></div>
<div id="comment_53506825" class="cw">
	<div id="comment_top_53506825" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506825" name="comment_link_53506825" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506825" onclick="return D2.setFocusComment(53506825)" >A possible remedy: Use Copyright Law</a>


		 	<span id="comment_score_53506825" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506825); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ross+Finlayson">Ross Finlayson</a>  <span class="uid"><a href="//slashdot.org/~Ross+Finlayson">( 17913 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506825"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506825"><p>There is (conceivably) a remedy available under Copyright Law.  Many "Internet of Things" devices (in particular, network cameras) run (at least some) libraries that were licensed under the GNU LGPL. One of the conditions of the LGPL is that users be able to - at will - replace the device's LGPL'd libraries with their own version (with the same API).  If these devices do not have such an 'upgrade' mechanism available (and I suspect that few, if any, do), then they could find themselves legally liable.</p><p>If the<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53506825">

</div>
</div>

<div id="replyto_53506825"></div>

<ul id="group_53506825">
	<li id="hiddens_53506825" class="hide"></li>
</ul>

<ul id="commtree_53506825"><li id="tree_53507233" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507233" class="commentstatus"></div>
<div id="comment_53507233" class="cw">
	<div id="comment_top_53507233" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507233" name="comment_link_53507233" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507233" onclick="return D2.setFocusComment(53507233)" >Re:</a>


		 	<span id="comment_score_53507233" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507233); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~GuB-42">GuB-42</a>  <span class="uid"><a href="//slashdot.org/~GuB-42">( 2483988 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507233"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507233"><p>That's the case with LGPLv3, not LGPLv2.<br>And the "anti-tivoisation" clause as it is called only applies to consumer products.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507233">

</div>
</div>

<div id="replyto_53507233"></div>

<ul id="group_53507233">
	<li id="hiddens_53507233" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53506857" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53506857" class="commentstatus"></div>
<div id="comment_53506857" class="cw">
	<div id="comment_top_53506857" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53506857" name="comment_link_53506857" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53506857" onclick="return D2.setFocusComment(53506857)" >Bad software endangers software development</a>


		 	<span id="comment_score_53506857" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53506857); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~XparXnoiaX">XparXnoiaX</a>  <span class="uid"><a href="//slashdot.org/~XparXnoiaX">( 4714613 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53506857"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53506857">The reality is most companies don't care about security.<br> <br>
When was the last time your boss added a security audit to your sprint? When was the last time someone said, "make sure you add enough time on this task to make it secure."?  Security is not a priority for companies, so we don't spend time thinking about it.<br> <br>
<a href="https://medium.com/@xParXnoiAx/irresponsible-disclosure-52d08cddcd07" title="medium.com" rel="nofollow">For these reasons I advocate irresponsible disclosure</a> [medium.com]: we need to give companies motivation to improve their code.</div>
	</div>

	<div class="commentSub" id="comment_sub_53506857">

</div>
</div>

<div id="replyto_53506857"></div>

<ul id="group_53506857">
	<li id="hiddens_53506857" class="hide"></li>
</ul>

<ul id="commtree_53506857"><li id="tree_53507357" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507357" class="commentstatus"></div>
<div id="comment_53507357" class="cw">
	<div id="comment_top_53507357" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507357" name="comment_link_53507357" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507357" onclick="return D2.setFocusComment(53507357)" >Re:</a>


		 	<span id="comment_score_53507357" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507357); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507357"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507357"><p>I'n not really going to answer those questions, for we're a very special case with very high security requirements (security is here one of the major parts of the specs, usually it's about the same length as the feature demands), so I can't complain about not being asked enough, actually, it would be nice to at least be left out of the meetings that discuss the color of the user interfaces...</p><p>My problem is on the other hand that I cannot outsource anything. I cannot find any partners that can actually comply<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507357">

</div>
</div>

<div id="replyto_53507357"></div>

<ul id="group_53507357">
	<li id="hiddens_53507357" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53507287" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507287" class="commentstatus"></div>
<div id="comment_53507287" class="cw">
	<div id="comment_top_53507287" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507287" name="comment_link_53507287" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507287" onclick="return D2.setFocusComment(53507287)" >It can be if done wrong</a>


		 	<span id="comment_score_53507287" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507287); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Casandro">Casandro</a>  <span class="uid"><a href="//slashdot.org/~Casandro">( 751346 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507287"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507287"><p>My argument is that many programmers design needless complexity into things because they believe they can just "outsource" their problems.<br>For example people design systems with complex file formats they could not parse themselves, then they load a script interpreter which will parse it for them.... and as a side effect execute any code in that file.<br>If they would have chosen a simpler file format, a few lines of code would have been able to parse it perfectly well.</p><p>Also there is one particularly toxic way of<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507287">

</div>
</div>

<div id="replyto_53507287"></div>

<ul id="group_53507287">
	<li id="hiddens_53507287" class="hide"></li>
</ul>

</li><li id="tree_53507327" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507327" class="commentstatus"></div>
<div id="comment_53507327" class="cw">
	<div id="comment_top_53507327" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507327" name="comment_link_53507327" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507327" onclick="return D2.setFocusComment(53507327)" >Code reuse doesn't. Cargo cult programming does.</a>


		 	<span id="comment_score_53507327" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507327); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507327"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507327"><p>It's not a problem when a programmer pulls code out of his archive to put it to new use. What is a problem, though, is people googling their problem du jour that they cannot solve, find code that more or less does what they want, adapt it to their specs and consider that programming.</p><p>What you will usually find as one of the first hits that way is tutorial code that showcases the function that you might be after, but without any sanity checks and without the even barest minimal security in mind, simply becaus<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53507327">

</div>
</div>

<div id="replyto_53507327"></div>

<ul id="group_53507327">
	<li id="hiddens_53507327" class="hide"></li>
</ul>

<ul id="commtree_53507327"><li id="tree_53509191" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53509191" class="commentstatus"></div>
<div id="comment_53509191" class="cw">
</div>

<div id="replyto_53509191"></div>

<ul id="group_53509191">
	<li id="hiddens_53509191" class="hide"></li>
</ul>

<ul id="commtree_53509191"><li id="tree_53512695" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53512695" class="commentstatus"></div>
<div id="comment_53512695" class="cw">
	<div id="comment_top_53512695" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53512695" name="comment_link_53512695" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53512695" onclick="return D2.setFocusComment(53512695)" >Re:</a>


		 	<span id="comment_score_53512695" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53512695); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53512695"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53512695"><p>Either you replied to the wrong comment or you have trouble with reading comprehension, which one is it?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53512695">

</div>
</div>

<div id="replyto_53512695"></div>

<ul id="group_53512695">
	<li id="hiddens_53512695" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53507579" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53507579" class="commentstatus"></div>
<div id="comment_53507579" class="cw">
	<div id="comment_top_53507579" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53507579" name="comment_link_53507579" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53507579" onclick="return D2.setFocusComment(53507579)" >Libraries vs. Bespoke Code</a>


		 	<span id="comment_score_53507579" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53507579); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RLGSC">RLGSC</a>  <span class="uid"><a href="//slashdot.org/~RLGSC">( 838262 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53507579"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53507579">It is indeed simplistic and one-sided to assert that "using libraries exposes systems to bugs". The problem is far deeper, and affects both library and bespoke code bases.

First, consider the somewhat psychological problem that often happens when using libraries. The various flavors of public code (e.g., Open, Free, etc.) have as an implicit or explicit basis the presumption that since the source is freely available, those using the libraries will peruse the source, either to fix shortcomings or to correct</div>
	</div>

	<div class="commentSub" id="comment_sub_53507579">

</div>
</div>

<div id="replyto_53507579"></div>

<ul id="group_53507579">
	<li id="hiddens_53507579" class="hide"></li>
</ul>

</li><li id="tree_53508207" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53508207" class="commentstatus"></div>
<div id="comment_53508207" class="cw">
	<div id="comment_top_53508207" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53508207" name="comment_link_53508207" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53508207" onclick="return D2.setFocusComment(53508207)" >Yes</a>


		 	<span id="comment_score_53508207" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53508207); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nuc1e0n">nuc1e0n</a>  <span class="uid"><a href="//slashdot.org/~nuc1e0n">( 924639 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53508207"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53508207">But more accurately, code reuse permits more software development in general, including insecure software development.</div>
	</div>

	<div class="commentSub" id="comment_sub_53508207">

</div>
</div>

<div id="replyto_53508207"></div>

<ul id="group_53508207">
	<li id="hiddens_53508207" class="hide"></li>
</ul>

</li><li id="tree_53508389" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53508389" class="commentstatus"></div>
<div id="comment_53508389" class="cw">
	<div id="comment_top_53508389" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53508389" name="comment_link_53508389" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53508389" onclick="return D2.setFocusComment(53508389)" >Mark for upgrade</a>


		 	<span id="comment_score_53508389" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53508389); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jraff2">jraff2</a>  <span class="uid"><a href="//slashdot.org/~jraff2">( 2828801 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53508389"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53508389">Put a string of password like alphabet soup in a routine. Then when that routine becomes ensconced in some other application it can still be searched for and noted for replacement of removal. It would only take about 128 bytes to clearly note application, programmer, usage, date, time, etc. It  used to be a size issue but with todays Gigabyte memory size, that issue has diminished dramatically.</div>
	</div>

	<div class="commentSub" id="comment_sub_53508389">

</div>
</div>

<div id="replyto_53508389"></div>

<ul id="group_53508389">
	<li id="hiddens_53508389" class="hide"></li>
</ul>

</li><li id="tree_53508509" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53508509" class="commentstatus"></div>
<div id="comment_53508509" class="cw">
	<div id="comment_top_53508509" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53508509" name="comment_link_53508509" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53508509" onclick="return D2.setFocusComment(53508509)" >Pointy-Haired Bosses Endanger Secure Development</a>


		 	<span id="comment_score_53508509" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53508509); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jevvim">jevvim</a>  <span class="uid"><a href="//slashdot.org/~jevvim">( 826181 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53508509"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53508509"><p>The big issue I see in my daily work life is that management acts as if using a third-party solution, be it proprietary or open-source, means we will receive perfect code at the beginning and never have to update it. We lock versions early in the dev cycle, but if a new version comes out mid-development there is a general distrust of changing to the new one.</p><p>And then, when the inevitable critical issue is discovered after we have release, we have no efficient plan on how to update. At least GPL solves that;<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53508509">

</div>
</div>

<div id="replyto_53508509"></div>

<ul id="group_53508509">
	<li id="hiddens_53508509" class="hide"></li>
</ul>

</li><li id="tree_53508649" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53508649" class="commentstatus"></div>
<div id="comment_53508649" class="cw">
	<div id="comment_top_53508649" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53508649" name="comment_link_53508649" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53508649" onclick="return D2.setFocusComment(53508649)" >Root Cause</a>


		 	<span id="comment_score_53508649" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53508649); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~snadrus">snadrus</a>  <span class="uid"><a href="//slashdot.org/~snadrus">( 930168 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53508649"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53508649"><p>The problem with unbounded pointer vulnerabilities (stack smashing, return value changing, parameter changing) is the unboundedness of the pointer. ONLY the programmer and (for some languages) the compiler know what values are legal for a pointer offset.</p><p>Programmers aren't enough.</p><p>So I use GoLang (but Java, Rust, Node are all similar in this regard) because I know that all my pure-GoLang 3rd-party libs cannot have unbounded pointer errors. This means Go's SSL, not Go's OpenSSL wrapper. A Userspace written in<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53508649">

</div>
</div>

<div id="replyto_53508649"></div>

<ul id="group_53508649">
	<li id="hiddens_53508649" class="hide"></li>
</ul>

</li><li id="tree_53512679" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53512679" class="commentstatus"></div>
<div id="comment_53512679" class="cw">
	<div id="comment_top_53512679" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53512679" name="comment_link_53512679" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53512679" onclick="return D2.setFocusComment(53512679)" >It's one of my gripes</a>


		 	<span id="comment_score_53512679" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53512679); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~joboss">joboss</a>  <span class="uid"><a href="//slashdot.org/~joboss">( 4453961 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53512679"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53512679">If you manually install libraries this is also going to be problematic. I've often found myself my own package maintainer. It's hard to keep track of everything and some libraries or packages can break each version needing code changes. In niche cases the libraries are being build not simply because they are out of data on the system and newer is needed. Sometimes they need to be patched in a way that wont be accepted upstream which raises the maintenance code for upgrading. VCS helps but it's still a big h</div>
	</div>

	<div class="commentSub" id="comment_sub_53512679">

</div>
</div>

<div id="replyto_53512679"></div>

<ul id="group_53512679">
	<li id="hiddens_53512679" class="hide"></li>
</ul>

</li><li id="tree_53505757" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53505757" class="commentstatus"></div>
<div id="comment_53505757" class="cw">
</div>

<div id="replyto_53505757"></div>

<ul id="group_53505757">
	<li id="hiddens_53505757" class="hide"></li>
</ul>

<ul id="commtree_53505757"><li id="tree_53505843" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53505843" class="commentstatus"></div>
<div id="comment_53505843" class="cw">
	<div id="comment_top_53505843" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53505843" name="comment_link_53505843" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53505843" onclick="return D2.setFocusComment(53505843)" >Re:</a>


		 	<span id="comment_score_53505843" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53505843); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fuzzyfuzzyfungus">fuzzyfuzzyfungus</a>  <span class="uid"><a href="//slashdot.org/~fuzzyfuzzyfungus">( 1223518 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53505843"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53505843">(Edit: the one arguably major vice of code reuse is that it makes lazy over-inclusion easy and tempting. We had <a href="https://linux.slashdot.org/story/16/12/16/0229207/zero-days-hitting-fedora-and-ubuntu-open-desktops-to-a-world-of-hurt" title="slashdot.org">a story<span class="substr"> </span></a> [slashdot.org] a few days back about some fairly common 'default' desktop linux setups that were vulnerable because of a bug in the implementation of the emulator of one of the chips in the SNES. Outside of chiptunes enthusiasts and some of the more serious console emulation wonks, almost nobody is likely to ever see SPC audio; and the few people who will are likely to know what it is and be minimally in</div>
	</div>

	<div class="commentSub" id="comment_sub_53505843">

</div>
</div>

<div id="replyto_53505843"></div>

<ul id="group_53505843">
	<li id="hiddens_53505843" class="hide"></li>
</ul>

<ul id="commtree_53505843"><li id="tree_53507105" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53507105" class="commentstatus"></div>
<div id="comment_53507105" class="cw">
</div>

<div id="replyto_53507105"></div>

<ul id="group_53507105">
	<li id="hiddens_53507105" class="hide"></li>
</ul>

<ul id="commtree_53507105"><li id="tree_53509705" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53509705" class="commentstatus"></div>
<div id="comment_53509705" class="cw">
	<div id="comment_top_53509705" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53509705" name="comment_link_53509705" href="//it.slashdot.org/comments.pl?sid=10008949&amp;cid=53509705" onclick="return D2.setFocusComment(53509705)" >Re:</a>


		 	<span id="comment_score_53509705" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53509705); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fuzzyfuzzyfungus">fuzzyfuzzyfungus</a>  <span class="uid"><a href="//slashdot.org/~fuzzyfuzzyfungus">( 1223518 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53509705"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53509705">I'm on partial agreement with you on that: I agree that (given the sometimes fairly high complexity of media codecs; and the fact that the web is a malicious place) media rendering code needs to be given <em>much, much</em> more aggressive handling in terms of sandboxing/privilege restriction. If all the decoder needs to do is provide audio suitable to be fed to the soundcard; or provide a series of frames to be painted wherever the video is supposed to be playing, there is <em>no</em> reason for it to be running with all th</div>
	</div>

	<div class="commentSub" id="comment_sub_53509705">

</div>
</div>

<div id="replyto_53509705"></div>

<ul id="group_53509705">
	<li id="hiddens_53509705" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//it.slashdot.org/comments.pl?sid=10008949&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">3 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//it.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 5;
		D2.currents()['full']     = 17;
		D2.currents()['oneline']  = 78;
		// D2.currents_total(100);

		D2.abbrev_comments({53506083:514,53507743:810,53505771:528,53508649:528,53507579:512,53506147:529,53505685:514,53505861:522,53506349:63,53509335:556,53506223:522,53509705:530,53508509:521,53507357:522,53506825:522,53506943:536,53507287:529,53505855:522,53505767:529,53505911:522,53506059:530,53506279:244,53505807:512,53507327:522,53507167:772,53506925:521,53505933:529,53506131:522,53512679:512,53509411:512,53506779:152,53505843:269});
		D2.noshow_comments([53505583,53507039,53505613,53507059,53508283,53506213,53505673,53505909,53505863,53505709,53505737,53505845,53509191,53505757,53507105]);
		D2.pieces_comments([53505807,53506639,53509135,53506083,53507507,53508913,53505657,53505853,53506155,53509435,53506157,53506257,53506279,53506649,53509499,53506911,53507665,53509417,53506647,53508403,53509411,53505769,53505821,53506087,53506659,53507167,53505855,53506925,53507743,53506147,53507765,53506943,53505933,53506519,53505631,53505637,53505693,53506349,53506691,53506059,53505861,53506555,53505685,53505707,53506569,53505767,53505765,53505771,53506951,53505937,53506615,53506729,53505847,53505899,53505911,53506131,53506223,53506867,53507985,53509561,53509335,53506779,53506787,53506825,53507233,53506857,53507357,53507287,53507327,53512695,53507579,53508207,53508389,53508509,53508649,53512679,53505843,53509705]);
		D2.init_hiddens([53505633,53505589,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(320147);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>813<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/16/10/12/1447229/outsourced-it-workers-ask-sen-feinstein-for-help-get-form-letter-in-return?sdsrc=popbyskidbtmprev">Outsourced IT Workers Ask Sen Feinstein For Help, Get Form Letter in Return</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>704<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/16/07/26/180204/dnc-hacker-unmasked-he-really-works-for-russia-researchers-say?sdsrc=popbyskidbtmprev">'DNC Hacker' Unmasked: He Really Works for Russia, Researchers Say</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>541<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/16/12/05/1619223/many-ceos-believe-technology-will-make-people-largely-irrelevant?sdsrc=popbyskidbtmprev">Many CEOs Believe Technology Will Make People Largely Irrelevant</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>540<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/16/11/19/0345224/why-automation-wont-displace-human-workers?sdsrc=popbyskidbtmprev">Why Automation Won't Displace Human Workers</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>414<span class="hide"> comments</span></span></span><a href="//it.slashdot.org/story/16/11/05/1744231/it-workers-facing-layoffs-jolted-by-ceos-message?sdsrc=popbyskidbtmprev">IT Workers Facing Layoffs Jolted By CEO's Message</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//hardware.slashdot.org/story/16/12/17/1851218/the-un-will-consider-banning-killer-robots?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/government_64.png" width="64" height="64" alt="Government"></span>
	    
					<p class="grid_12"><a href="//hardware.slashdot.org/story/16/12/17/1851218/the-un-will-consider-banning-killer-robots?sdsrc=nextbtmprev">The UN Will Consider Banning Killer Robots</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>206<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//it.slashdot.org/story/16/12/17/1925238/massive-mirai-botnet-hides-its-control-servers-on-tor?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/botnet_64.png" width="64" height="64" alt="Botnet"></span>
	    
					<p class="grid_12"><a href="//it.slashdot.org/story/16/12/17/1925238/massive-mirai-botnet-hides-its-control-servers-on-tor?sdsrc=prevbtmprev">Massive Mirai Botnet Hides Its Control Servers On Tor</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>148<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="railad">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//it.slashdot.org/comments.pl?sid=10008949&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">148</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>It's not so hard to lift yourself by your bootstraps once you're off the ground.
		-- Daniel B. Luten</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2016 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                $('#firehoselist article').eq(2).after(html);
            }
        });
        
        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	<img src="//slashdot.org/adbanner.gif?t=20161222" alt="">
	<img src="//slashdot.org/purple.gif?t=20161222" alt="">
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?830">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?531">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->